Converting sequential surfaces to non-sequential objects

This article explains how to use the Convert to NSC Group tool to convert sequential surfaces to non-sequential objects. It discusses the usage of the "Design Lockdown" and "Critical Rayset Generator" tools. It shows how to create Non-Sequential Sources and Detectors and how to perform a non-sequential ray trace and analyze results. The article uses four examples to demostrate the converstion to Non-Sequential Mode: manually converting a Cooke triplet design to NSC mode, using the Convert to NSC Group tool to automatically convert an infinite conjugate Double Gauss design and a finite conjugate Double Gauss design, and conversion of an off-axis system.

Authored By Kristen Norton, Nam-Hyong Kim

Downloads

Article Attachments

Introduction

After optimizing, analyzing, and tolerancing a sequential optical system in OpticStudio, it can be converted to a non-sequential system for optomechanical design or stray light analysis. ​Once the surfaces have been converted into Non-Sequential Mode objects, it is easy to insert additional CAD objects to represent mounts, baffles, or iris apertures and to look in detail at the interaction between the optical and mechanical components of the system.

This article explains how to manually convert Sequential Mode systems into Non-Sequential Mode systems, and how to use the Convert To NSC Group tool that does the conversion automatically. 

Example 1: Converting sequential surfaces to non-sequential Components

We will go through an example that shows how to convert sequential surfaces to non-sequential components. Open the sample file “Cooke 40 degree field.zmx” located in {Zemax}\Samples\Sequential\Objectives.

Here is the Lens Data Editor and the 2D Layout:

Lens_Data

Prepare the File for Conversion to Mixed Mode

We will start by converting from surface #1 (the front of the first lens) through surface #6 (the back of the last lens) into equivalent non-sequential components. Then, we will manually place a non-sequential detector object at the location of the current sequential IMAGE plane (surface #7). We will also place a non-sequential source that represents the on-axis rays in object space. The source and detector objects will help us confirm that the system was converted correctly.

The conversion tool has an option to convert the file to Non-Sequential Mode:

KA-01380_4_Convert_to_NSC.jpg

If “Convert file to non-sequential mode” is not selected, then OpticStudio will replace the range of sequential surfaces with one Non-Sequential Component surface in the Lens Data Editor. This Non-Sequential Component surface contains the group of converted non-sequential objects, which can be accessed in the Non-Sequential Component Editor. This creates a Mixed Mode system, meaning that both Sequential and Non-Sequential Modes are used. In a Mixed Mode system, rays are traced sequentially outside of the Non-Sequential Component group but may follow non-sequential paths inside of the Non-Sequential Component group. The sequential rays may go into the Non-Sequential Component at the Entrance Port and may leave the Non-Sequential Component at its Exit Port.

The concept of a Stop Surface only applies to sequential ray tracing. This is because in sequential raytracing, the rays are aimed to fill the Entrance Pupil, which is the image of the Stop Surface in object space. Therefore, only a sequential surface can be set as the system Stop. The Stop Surface must precede the non-sequential segment of the design. In the Cooke Triplet example, the Stop Surface is embedded in the system. Consequently, to convert this to a Mixed Mode system, we need to move the current stop location to a dummy surface, inserted before the first lens we want converted to a non-sequential object.

Also, all Semi-Diameters should be fixed (this is indicated with a “U” next to the Semi-Diameter) before converting to a non-sequential design. The Semi-Diameter values in this file are already fixed, but later we will do another example which shows how to fix the Semi-Diameters.

To move the Stop Surface in the Cooke Triplet file, start by inserting a new surface prior to current surface #1.

KA-01380_5_Lens_Data_2.jpg

Expand the Surface Properties of the new dummy surface. You can do this by double-clicking on the Surface Type or using the down arrow in the Surface Properties title bar. Check-on Make Surface Stop in the Surface 1 Properties:

KA-01380_6_Lens_Data_3.jpg

The Lens Data Editor will display "STOP" next to the new dummy surface (#1) indicating that this is now the Stop Surface. This means that we’ve changed the Stop Surface, and thus have also changed the Entrance Pupil. Because the rays from each sequential field point are aimed to fill the Entrance Pupil, you’ll notice that the layout rays have changed:

KA-01380_7_Layout.jpg

In this example, we had already fixed the Semi-Diameters of the lenses, so the lenses themselves have not changed. Therefore, we can still correctly convert the lenses to non-sequential objects. Save this file before moving to the next step. For reference, this is saved as “Cooke 40 degree field_1.zmx” in the Article Attachments.

Using the Convert to NSC Tool

Now the file is ready to be converted to Mixed Mode. Select Convert to NSC Group from the File tab. The Convert to NSC Group tool will automatically convert sequential surfaces to their equivalent non-sequential objects. It can convert most commonly used sequential surface types, surface apertures, and coordinate breaks into a Non-Sequential Component group in mixed mode or into a non-sequential system in Non-Sequential Mode.

Convert to NSC Group_3

Some sequential surfaces do not have a non-sequential equivalent, and therefore cannot be converted. Don’t assume this feature perfectly converts your sequential surface data; carefully check the conversion results before doing any important analysis. The capabilities of this conversion tool are constantly being updated to support more sequential surface types. For the latest information about the currently supported surface types, please refer to the OpticStudio Help system in The File Tab... Convert to NSC Group.

For now, ignore the Production Tools. Select Surface 2 through 7, and un-check all settings except “Ignore errors and convert as much as possible”:

KA-01380_9_Convert_to_NSC_Group_4.jpg

Click OK, and Surfaces 2 through 7 will be converted into a Non-Sequential Component surface:

KA-01380_10_Lens_Data_4.jpg

We now have a Mixed Mode system with Entrance and Exit Ports. For more information on using a Non-Sequential Component surface with ports, please see OpticStudio’s in-line Help Files section in The Setup Tab>Editors Group>Non-Sequential Component Editor>Non-Sequential Overview>How to use NSC With Ports.

You’ll notice that the 2D Layout is now blank because the Non-Sequential Components represent a potentially non-symmetric 3D system. Instead, open a 3D layout in the Analyze tab...3D Viewer:

Layout_2

If you look in the Setup tab, you’ll notice that the Sequential UI mode button is still selected, but the button for the Non-Sequential Component Editor is now enabled:

Non-Sequential_Editor

Click Setup...Editors..Non-Sequential to view the Non-Sequential Component (NSC) Editor. This NSC Editor corresponds to the Non-Sequential Component surface (#2) in the Lens Data Editor. It contains 3 objects, which represent Surfaces 2 through 7 from the Sequential Mode file: 

Lens_Data_5

Save this file before moving to the next step. For reference this is saved as “Cooke 40 degree field_2.zmx” in the Article Attachments.

Convert from Mixed Mode to Non-Sequential Mode

We want to add non-sequential source and detector objects, and this will be easiest in a purely non-sequential system. We will do this by changing to Non-Sequential Mode, which means that all sequential surfaces in the Lens Data Editor will be lost, and only the information in the Non-Sequential Component Editor will be retained.

To do this, go to the Setup Tab...Mode...Non-Sequential:

Non-Sequential

Click Yes in the following dialog box:

KA-01380_15_Switch_program_mode.jpg

The file is converted to Non-Sequential Mode, and the Lens Data Editor is no longer available. The Non-Sequential Component Editor (NSCE) still contains the same non-sequential components, corresponding to the lenses in sequential Cooke Triplet file.

Open a layout to view the three lenses in the NSC Editor. Go to Analyze...NSC 3D Layout:

NSC_3D_Layout

The lenses are still present, but to confirm the converted results, we need to insert a non-sequential source and detector.

Inserting a non-sequential source

The sequential system had an entrance pupil diameter of 10 lens units, with the OBJECT distance at Infinity. To create the same on-axis input beam, we can place a collimated, circular non-sequential source object to the left of the first lens.

Insert a new line anywhere is the Non-Sequential Component Editor:

NSCE

Open the Object Properties by double clicking on Object Type in the NSC Editor or by clicking the down arrow next to the Object Properties title bar. Change the Category to Sources, and set the type as “Source Ellipse”:

Source_Ellipse

In the NSC editor, set the following parameters for the Source Ellipse and leave all other parameters same as default.

Z position = -10 (since it is collimated, it does not matter where it is located as long as it is to the left of first lens)

# Layout Rays = 10

# Analysis Rays = 100000

X Half Width = 5

Y half Width = 5

NSCE

Update the 3D Layout, and you will see the 10 layout rays:

KA-01380_20_NSC_3D_Layout_2.jpg

Next, to show the results of the 100000 analysis rays, we need to add a detector object.

Inserting a Detector Object

To maintain consistency with the sequential file, we need to place a detector object at the same location as the sequential IMAGE surface. To determine the location of the sequential IMAGE surface, we need to refer back to the Global Vertex Data of the sequential file. Save what you have thus far and open the “Cooke 40 degree field_1.zmx” file again.

Cooke_40_degree_field

In the System Explorer, change the Global Coordinate Reference Surface to Surface 1:

System_explorer

Then go to the Analyze tab...Reports...Prescription Data:

Prescription_Data

Expand the settings of the Prescription Data window and click the Clear All button. Then, check-on Global Vertex. Looking at the Global Vertex information for Surface 8 (the IMAGE surface), we can see that Z = 60.177 units relative to our Global Coordinate Reference, which is Surface 1.

KA-01380_24_Prescription_Data_2.jpg

While you have this file open, go to the Analyze tab...Rays & Spots...Standard Spot Diagram. We want to look at the on-axis results, and we can use this as a reference once we have the non-sequential system completed.

Expand the settings of the Spot Diagram and make the following changes: Ray Density = 40, Pattern = Dithered, Field = 1, check-on Show Airy Disk, and uncheck Use Symbols.

Spot_diagram

The Spot Diagram shows the ray intercepts at the IMAGE surface, but there is no Z-axis which indicates the cumulative irradiance. To see the irradiance distribution, we can use the Geometric Image Analysis. Go to the Analyze tab...Extended Scene Analysis...Geometric Image Analysis.

Expand the settings of the Geometric Image Analysis and make the following changes: Field size = 0, Image size = 0.02, Raysx1000 = 1000, Show = False Color, and # Pixels = 200.

KA-01380_26_Geometric_Image_Analysis.jpg

Looking back at the text below the Spot Diagram, you’ll notice that the Airy Radius is only about 2 um less than the RMS Radius. This means that we may want to take a look at the diffraction limited results as well. Go the Analyze tab...PSF...Huygens PSF.

Expand the settings of the Huygens PSF and make the following changes: Pupil and Image Sampling = 256x256, Image Delta = 0.078 um, Wavelength = 2, and Show As = False Color.

KA-01380_27_Huygens_PSF.jpg

We can refer back to these sequential results once the source and detector are added to the non-sequential file. Go back to the converted Non-Sequential Mode file using the list of recently opened files via the File tab...Open. We know that the sequential IMAGE surface is at Z = 60.177 units, relative to Surface #1 in the Lens Data Editor. In the non-sequential file, Surface #1 is the front of Object #1, which is conveniently located at Z = 0. Therefore, the detector object should be placed with a Z position of +60.177.

Insert another object anywhere in the NSC Editor. Open the Object Properties by double clicking on the Object Type in the NSC Editor, or by clicking the down arrow next to the Object Properties title bar. Change the Category to Detectors, and set the Type as “Detector Rectangle”:

Detector_Rectangle

Here are the parameters for the Detector Rectangle object:

Z position = 60.177

X half Width = 0.01

Y half Width = 0.01

# X Pixels = 100

# Y Pixels = 100

Update the 3D Layout (toolbar icon with the blue double arrows) and reset the zoom (toolbar icon with the black circle and white arrow).  You will now see the Source Ellipse’s Layout rays traced though the Detector Rectangle:

NSCE_3

Tracing non-sequential rays

Next, we need to analyze the results on the Detector Rectangle. To do this, open the Detector Viewer by clicking Analyze...Detector Viewer. For now, the Detector Viewer will show a blank window. In order to see the optical power landing on the Detector Rectangle, we need to trace the Analysis rays from the Source Ellipse.

Open the Ray Trace Control from the Analyze...Ray Trace:

KA-01380_30_Ray_Trace

Press Clear & Trace to clear any detector data and start a ray trace. OpticStudio will trace 100000 rays, as specified in the "# Analysis Rays" parameter of the Source Ellipse in the editor.

Once the ray trace is complete, the Detector Viewer will show the irradiance distribution. Note that the settings have been changed in the following screenshot to show the results in False Color:

KA-01380_31_Detector_Viewer.jpg

The distribution shown in the Detector Viewer closely agrees with that of the sequential Spot Diagram and Geometric Image Analysis, as shown in the previous section. Please refer back to these screenshots for comparison.

Note that the “Percent efficiency” and Watts reported in the sequential Geometric Image Analysis may differ from the total number of Watts reported in the non-sequential file.  This is because in the non-sequential file, the rays may take multiple non-sequential paths to the detectors, whereas in the sequential file, there is only one path that the rays may take.  To simulate only this path in the non-sequential file, you would need to use filter strings or add absorbing annular apertures around each lens.

Detector Viewer: diffraction analysis

The results we’ve seen on the Detector Rectangle can be compared to the sequential Spot Diagram and Geometric Image Analysis, but all of these analyses use geometrical rays and ignore diffraction effects.

We can, however, also compare the diffraction calculations of the sequential Huygens PSF to a similar non-sequential calculation using the “PSF Wave#” parameter of the Detector Rectangle. Setting the “PSF Wave#” equal to one of the wavelength numbers (defined in the Wavelength Data Editor) turns on a special mode which allows the detector to perform a coherent Huygens PSF integration at that wavelength. Each ray that strikes the detector is converted into a local plane wave that illuminates every pixel on the detector, and the coherent amplitude of the plane wave is summed across all pixels. This results in a Point Spread Function (PSF) that is comparable to the sequential Huygens PSF.

To view the Huygens PSF in the non-sequential file, set the following parameters for the Source Ellipse and Detector Rectangle:

Source Ellipse

  • # Analysis Rays: 5000 (reduced rays to speed up the ray trace)

Detector Rectangle

  • Data Type: 1
  • PSF Wave#: 2

Open the Ray Trace Control again and run another ray trace. In the Detector Viewer, change the Show Data setting to Coherent Irradiance:

KA-01380_32_Coherent_Irradiance.jpg

As you can see, the sequential Huygens PSF and the non-sequential detector show remarkably similar results. The small difference in the intensity of the outer ring is just due to the different number of rays traced.

Example 2: Automatic Conversion to Non-Sequential Mode

The preceding sections showed how to manually convert a file to a Mixed Mode system, and then to a Non-Sequential Mode file. Now, we will use OpticStudio's built-in tools to simplify the process!

To demonstrate the use of these tools, open the sample file “Double Gauss 28 degree field.zmx” in the folder {Zemax}\Samples\Sequential\Objectives. Notice that in the System Explorer, the Aperture Type is Entrance Pupil Diameter and Ray Aiming is turned off. Also, there are no solves on the surface Semi-Diameters, meaning that they are automatically adjusted to let all rays pass through:

System_explorer_2

Go to the File tab...Convert to NSC Group. There are two Production Tools, before the conversion settings, that we will use in this example.

KA-01380_34_Convert_to_NSC_Group_5.jpg

Start by clicking on Design Lockdown:

KA-01380_35_Design_Lockdown.jpg

A number of steps are generally required to convert a system designed in Sequential Mode into a Non-Sequential Mode system. All idealized inputs of the system should be converted into real manufacturing inputs. The Design Lockdown tool automates this conversion in a multi-step process, which starts by turning on Ray Aiming. Ray Aiming is an iterative ray tracing algorithm in OpticStudio that finds rays at the object which correctly fill the Stop Surface. This ensures that the correct rays are traced through the Stop Surface, and that surfaces with automatic Semi-Diameters are adjusted to the correct size. 

The Design Lockdown tool also changes the System Aperture to a physical aperture size. For example, in a real system, the rays don’t magically know where they need to start in order to create an Entrance Pupil Diameter equal to 10 mm. The user can specify an Entrance Pupil Diameter of 10 mm, but this means that OpticStudio iteratively adjusts the diameter of the Stop Surface until the Entrance Pupil reaches the correct size. In a real system, the limiting aperture will be fixed, and this determines which rays make it through the system. Other real aperture settings include "Object Space NA" or "Object Cone Angle". For more information, see the OpticStudio’s in-line Help Files section in the Tolerance Tab...Production Tools Group...Design Lockdown.

Similarly, the Design Lockdown tool will switch from the use of image-based field point definitions (if they are being used) to object-based definitions. This is because the image-based calculations are iterative, like the Entrance Pupil Diameter example described above.

Then, the Design Lockdown tool will convert all Semi-Diameters to fixed apertures. This means that dummy surfaces will be converted into the non-sequential file as Annulus surfaces, and the clear aperture information for each surface is retained.

Lastly, solves may be removed, and thickness values are rounded to reasonable precision values based on user specifications. Again, for more information, see the OpticStudio’s in-line Help Files section in the Tolerance Tab...Production Tools Group...Design Lockdown.

Use the settings shown in the above screenshot for the Design Lockdown tool and click OK. This creates a new file, called “Double Gauss 28 degree field-PROD.zmx”. This is included in the Article Attachments for reference.

Next, click on Critical Rayset Generator:

KA-01380_36_Critical_Rayset_Generator.jpg

The Critical Rayset Generator tool creates a “critical” set of ray data with the sequential system. These rays provide a basis for ensuring that changes made to the system while converting to Non-Sequential Mode, or other changes made while in Non-Sequential Mode (e.g., by adding components to reduce stray light effects or by adding optical mounts), are not detrimental. It creates a *.CRS file that can be traced in Non-Sequential Mode with the Critical Ray Tracer or used as a Source File object. Note that the Critical Rayset Generator is only available in the Premium edition of OpticStudio.

Use the default settings in the Critical Rayset Generator, shown in the above screenshot, and click OK. You will be returned to the Convert to NSC Group window.

Leaving all options in the Convert To NSC Group checked-on, click OK. This creates a new file called “Double Gauss 28 degree field-PROD-NONSEQ.zmx”. This is included in the Article Attachments for reference.

KA-01380_37_Convert_to_NSC_Group_6.jpg

The new file will open automatically, and once the conversion is complete, look at the Non-Sequential Component Editor. Instead of just Standard Lens objects replacing the Standard Surfaces from the Lens Data editor, we also have source and detector objects:

KA-01380_38_NSCE_4

Each sequential field in the Field Data Editor was converted to an equivalent non-sequential Source Ellipse. In addition, the centroid location at the IMAGE surface was calculated for each sequential field using the Spot Diagram analysis. Then, Detector Rectangles were inserted at these centroid locations, and we can see comments corresponding to each field number. This is a focal system with a flat image plane, so each field point’s Detector Rectangle lies in the same XY plane. These Detector Rectangles are small and separated in X & Y so that the Detector Rectangles do not overlap, and this will be true for most focal systems. In some systems, however, the Detector Rectangles might be larger, or closer together, and thus they may overlap. If this happens, then the nesting rule will be followed, and some detectors may not see all of the rays. In this case, we will need to manually adjust the locations of the detectors so that they are separated by more than the “Glue Distance” in the System Explorer.

Go to the Analyze tab...Ray Trace and run a ray trace with the default settings (Ignore Errors is turned on). Open the Detector Viewer, and take a look at the results for each field:

KA-01380_39_Detector_Viewer_2.jpg

The above screenshot also shows the results from the sequential file for comparison.

The results in the Detector Viewers look correct, but we can also run the Critical Ray Tracer to confirm that the conversion was successful. This will use the ray files created with the Critical Rayset Generator in the sequential file. Go to Analyze...Critical Ray Tracer:

KA-01380_40_Critical_Ray_Tracer.jpg

Looking at the report, we can see that 100% of the rays were traced completely through the system, and the positions and direction cosines of each ray were within the default tolerances of the target values.

Example 3: Automatic Conversion of a Finite Conjugate System

The preceding example converted a Sequential Mode file with the OBJECT surface at infinity. When converting finite conjugate systems with point-to-point imaging, OpticStudio automatically adds additional objects to test the imaging quality. To demonstrate this, open the sample file “Example 2, Double Gauss Experimental Arrangement.ZMX” in the folder {Zemax}\Samples\Sequential\Image Simulation.

Go to the File tab...Convert to NSC Group.

Click Design Lockdown, and use the following settings:

KA-01380_41_Design_Lockdown_2.jpg

The resulting file, “Example 2, Double Gauss Experimental Arrangement-PROD.ZMX”, is included in the Article Attachments section for reference.

Then, select all options in the Convert to NSC Group window, and click OK. The resulting non-sequential file is also included in the Article Attachments.

KA-01380_42_NSCE_5.jpg

You’ll notice that in the converted file, an inactive Source DLL and a Slide Object were inserted just before the field point Source Ellipses. A Detector Color was also added, and to prevent nested surfaces, it is located slightly after the Detector Rectangles. The Source DLL, Slide Object, and Detector Color can be used to test the imaging quality of the system. The sizes of the Source DLL and Slide Object are determined by the Semi-Diameter of the OBJECT surface in the Lens Data Editor. The size of the Detector Color is determined by the default display width of the sequential Full Field Spot Diagram analysis. The Source DLL “Lambertian_Overfill” will overfill the first aperture of the sequential system with a Lambertian distribution, much like a real light source. To maximize efficiency of the non-sequential ray trace, the size of the Source DLL matches the dimensions of the Slide Object.

To test the imaging performance, we need to trace rays from the Source DLL, which is the full-field source. Make the following changes in the NSC Editor:

Source Ellipses

  • # Layout Rays = # Analysis Rays = 0

Source DLL

  • # Layout Rays = 30
  • # Analysis Rays = 1000000
  • Here is the resulting 3D Layout:

3D_Layout

In the above NSC 3D Layout, the rays are colored by Segment # and Fletch Rays is checked-on. You’ll notice that rays are emitted from the entire source area, instead of just from points, and the first aperture is overfilled.

Go to Analyze...Ray Trace, and using the default settings, click the “Clear & Trace” button. Open a Detector Viewer, set it to show data from the Detector Color:

KA-01380_44_Detector_Color.jpg

The above screenshots show the Detector Color results in False Color as well as in True Color. You can see that the bars become blurrier at the corners of the graphic. For further investigation, we could increase the number of pixels on the Detector Color and increase the number of Analysis Rays for the Source DLL.

Looking at the True Color results, you’ll notice that the color appears to be white. This is because if there are multiple visible wavelengths in the Sequential file, the Source DLL is automatically set to emit a black body spectrum at 5800 K, using wavelengths from 0.44 to 0.64 um.

NSCE_6

If there were only one wavelength in the sequential file, or if any wavelengths were outside the visible spectrum, then the Source Color/Spectrum settings would be set to System Wavelengths, which are copied over from the sequential file.

Example 4: Automatic Conversion of an Off-Axis System

The preceding examples show how the Convert to NSC Group tool will automatically convert on-axis systems to Non-Sequential Mode. This example shows how an off-axis system with a decentered aperture is automatically converted.

Open the sample file “OAP using Chebyshev Polynomial surface.zmx” in the folder {Zemax}\Samples\Sequential\Tilted systems & prisms. Make the following changes:

  • Insert a new surface just before the Coordinate Break surface.
  • On the new surface, expand Surface Properties...Type settings and check Make Surface Stop.
  • In System Explorer...Aperture settings, change the Aperture Value to 50 mm.

System_explorer_3

If we were to convert the system without making these changes, there would be two problems. First, the position and orientation of the incoming rays will be significantly changed when the Design Lockdown tool is run. This is because the Design Lockdown tool turns on Ray Aiming, which adjusts the input rays to fill an off-axis Chebyshev Polynomial STOP surface. With the STOP surface changed to an on-axis Standard surface, the Ray Aiming algorithm does not change the incoming rays. The second problem is that some of the rays traced in the Critical Rayset Generator would be clipped by the rectangular aperture on the Chebyshev Polynomial surface. With the Aperture Value reduced to 50 mm, all the rays are traced through the system, and it will be easy to run the Critical Ray Tracer and compare the sequential rays to the non-sequential rays.

Next, go to the Chebyshev Polynomial surface. Expand the Surface Properties and go the Draw settings. Change the Mirror Substrate to Flat and add a Thickness of 5 mm:

Lens_data_6

The file is now ready for conversion to Non-Sequential Mode:

Shaded_model

Go to the File...Convert to NSC Group and run the Design Lockdown and the Critical Rayset Generator tools. Then, click OK to convert the file to Non-Sequential Mode. Here is the resulting non-sequential system:

NSCE_7

Sequential surfaces 1 and 2 were converted into non-sequential Annulus objects, now located at rows 3 and 4 in the Non-Sequential Component Editor. These objects aren't needed for the purpose of this example (and object 3 is actually blocking the rays after reflection from the OAP). Highlight the objects, right click, and select Ignore and Hide Object.

KA-01380_50_Ignore_and_Hide_Object.png

Next, run the Critical Ray Tracer to confirm that the conversion was correct:

Critical_Ray_Tracer_2

It looks like the conversion was successful. Now, let's investigate how the sequential OAP was converted into a non-sequential object. Objects 6-10 define the parameters of the non-sequential OAP:

NSCE_8

There is no non-sequential equivalent for the sequential Chebyshev surface, so it was replaced with Grid Sag Surface on object 6. The back face of the mirror is defined by Standard Surface, defined at object 7. The front and back faces of the mirrors are combined using Compound Lens object 8, and the decentered aperture is defined by a boolean operation on this Compound Lens object and a Rectangular Volume object. The placement and properties of the OAP mirror are defined by Boolean Native object 10.

Most sequential surfaces are automatically converted into an equivalent non-sequential surface (see the OpticStudio Help for the latest list of supported surfaces), and all other surfaces are converted to a Grid Sag Surface object as shown in this example. The surface sag is auto sampled and converted into a .GRD file in the user data folder {Zemax}\Objects\Grid Files. For pairs of sequential surfaces that define the front and back of a lens, and for mirrors with a defined substrate thickness like this OAP, if there is no non-sequential equivalent for the combination of front and back surfaces, then object will be converted into the reference objects of a non-sequential Compound Lens object. For example, if there were an Even Asphere surface on the front of a lens and an Extended Polynomial surface on the back, the lens would also be converted into a non-sequential Compound Lens object. If there were an Even Asphere surface on the front and a Standard surface on the back, then lens would be converted into a non-sequential Even Asphere Lens object. 

When the mirror substrate thickness is greater than 0, as shown in this example, the converter will copy the sequential substrate thickness to the thickness of the Compound Lens object. If the mirror substrate shape is flat, as defined in this example, then the back of the mirror will be represented with a flat Standard Surface object. If the mirror substrate had been curved, then the back surface of the Compound Lens object would have been the same surface type as the front surface. 

For pairs of sequential surfaces that define the front and back of a lens, and for mirrors with a defined substrate thickness, the aperture on the front surface will also define the aperture on the back surface. If the front surface contains an on-axis circular or rectangular aperture, the aperture values will be copied into the parameters of the non-sequential Compound Lens object. If the surface contains a decentered aperture, like the decentered rectangular aperture in this example, then in addition to the Compound Lens object, the converter will also insert a decentered Cylinder Volume object or Rectangular Volume object with a Boolean Native object to trim the lens to the specified aperture.

KA-01380

Was this article helpful?
1 out of 1 found this helpful

Comments

0 comments

Please sign in to leave a comment.