ブラック ボックス面の使用方法

ブラック ボックス面は、機密情報を開示することなく光学設計データを共有しなければならないという課題を解決します。この記事では、光学設計の一部または全部をブラック ボックス面としてエクスポートし、後工程の光学設計、最適化、解析でそれらの面を使用する方法について解説します。

著者 Mark Nicholson

ダウンロード

添付ファイル

序論

ブラック ボックス面は、機密情報を開示することなく光学設計データを共有しなければならないという課題を解決します。
光学設計者とその雇用主にとって、従来は光学設計データの共有には多くの課題がありました。

顧客、サプライヤ、社外コンサルタントなどが作業できるように、光線追跡可能なデータ ファイルを提供する必要があるものの、そうすると元の設計の知的所有権が開示される結果になります。近軸面や ABCD マトリックスなどの first order method であればこのような問題はなく、瞳のサイズと位置、像の位置と倍率などのデータを提供できます。しかし、この方法では収差のデータを提供できないので、光学系の前後に置く光学部品の設計では役に立ちません。

ブラック ボックスには、任意の視野点、波長、共役比で実光線を追跡するために必要な情報がすべて収録されています。その内容の正確さは、あたかも元の面と設計データをレンズ データ エディタで提供しているかのようです。実際には詳細データはブラック ボックスに隠されているので、利用者側ではそれらを参照することも変更することもできません。データは 256 ビット アルゴリズムで暗号化されています。

この記事では、ブラック ボックス レンズ ファイルの作成方法と使用方法について解説します。

ブラック ボックス面の作成

設計をブラック ボックスに変換する作業は、設計過程のどの段階でも可能ですが、一般的には設計が完了した時点で実行します。
エクスポートする面の範囲の最初と最後の面を定義する、2 つのダミー面を追加することをお勧めします。これらの面は、機械データ (光学部品を保持する機構的筐体の範囲を表すデータなど) または瞳の位置に置くことが普通です。

このサンプル ファイル (この記事の最終ページのリンクからダウンロードできます) は、ダブル ガウス対物レンズの最終設計をエクスポートすることを目的としています。このレンズを保持する機構的筐体を表すダミー面が追加されています。

Layout_1エクスポートする前に、目的とする範囲にあるすべての面に固定アパチャーを配置しておく必要があります。レンズを再生する際に、Zemax で各レンズの実際の物理的範囲を認識してビネッティングを計算できるようにするためです。この作業は、[ツール] (Tools) → [アパチャー] (Apertures) → [半径を円形アパチャーに変換] (Convert Semi-Diameters to Circular Apertures) を使用すると効率的です。
ユーザー定義アパチャー (UDA) を除くあらゆるタイプのアパチャーを使用して、エクスポート範囲にある各レンズの機械的範囲を定義できます。

ブラック ボックス ファイルを作成するには、[ツール] (Tools) → [データのエクスポート] (Export Data) → [Zemax ブラック ボックス データのエクスポート] (Export Zemax Black Box Data) を選択します。

Export_ZEMAX_balck_box_data

[ブラック ボックスのエクスポート後にテスト ファイルを作成し読み込む] (Create and load test file after black box export) オプションはチェックしたままにしておくことをお勧めします。ブラック ボックス ファイルが作成されるだけでなく、指定範囲の面が削除され、ブラック ボックスが読み込まれて、{元のファイル名}_BB.zmx という名前のファイルに保存されます。これにより、品質保証の重要な手順として、エクスポートしたファイルの内容が正しくブラック ボックスに反映されていることを容易に確認できます。次のように、新しいファイルが自動的に読み込まれます。

Layout_2

光線追跡の結果が元のファイルとブラック ボックスで完全に同じであることを確認できます。

ブラック ボックス面の使用に伴う効果

ブラック ボックスの性質に起因する効果がいくつか考えられます。これには、その効果が明らかなものもあれば、そうでないものもあります。ブラック ボックスの前面に到達した光線は、ブラック ボックスの後面から射出します。これは、レンズ データ エディタで等価の面を通じて実行した光線追跡と正確に同じ結果ですが、面のデータはまったく開示されません。これらの効果を以下に挙げます。これには当然と思われるものもあれば、意外なものもあります。

  • ブラック ボックス内部の面のデータはすべて隠蔽されているため、解析機能、最適化オペランド、ZPL コマンドからはアクセスできません。たとえば、ブラック ボックス ファイルに対する公差解析や熱解析は実行できません。ブラック ボックスであるため、作成した後で変更することはできません。当然のことながら、ブラック ボックスの外にある面については通常どおりに解析、最適化、公差解析などが可能です。
  • 通常、Zemax では、アパチャーで遮蔽される光線、全反射する光線、有効な光線と面の交差点が存在しないためにどの面にも到達しない光線が区別され、それぞれに応じたエラー コードが出力されます。一方、ブラック ボックスの追跡でこのような光線があっても、Zemax では入射した光線が射出しないことが認識されるだけなので、「光線の喪失」エラーのみが生成されます。主光線を追跡できない場合は (中央遮蔽がある望遠鏡など)、主光線の基準データが存在しないため、波面計算は不可能です。
  • ブラック ボックスにあるどの面でも光線データを生成できないので、物体面、絞り面、像面はブラック ボックス内部に配置できません。Zemax では、これら 3 種類の面のすべての光線データに直接アクセスできる必要があります。
  • ブラック ボックス光学系は、取得できるデータが出力光線のデータのみなので、物理光学解析には適していません。FFT やホイヘンス PSF/MTF などは、いずれも通常どおり機能します。
  • エクスポートする面の範囲には座標ブレークや面のティルト/ディセンタを設定できますが、最初の面と最後の面は同じ座標系に置き、入力面と出力面の間には厚みのみが設定されているようにする必要があります。
  • ブラック ボックス面の厚みは、その後に面を配置する際に必要になるので、レンズ データ エディタに表示されます。これによって内部の設計の詳細が開示されることはありません。入力面から出力面までの距離を示しているにすぎません。ブラック ボックスの厚みは変更できないので、元のレンズと同じ「ミラー空間」で再生する必要があります。したがって、元の設計がミラーの後に配置されている場合は、ブラック ボックスも同じ側に配置する必要があります。

注:ブラックボックスツールの代わりに、ゼルニケ非球面があります。 この面により、単一の視野点、波長、共役比について収差データを定義できます。 「How To Model a Black-Box Optical System Using Zernike Coefficients」を参照してください。

 

KA-01382

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています

コメント

0件のコメント

サインインしてコメントを残してください。