ディテクタ (極) と IESNA/EULUMDAT 光源データの使用方法

この記事では、ディテクタ (極) の使用方法、および光源の IESNA データと EULUMDAT データのインポートとエクスポートの方法について説明します。NSDP 最適化オペランドと ZPL 数値関数についても説明します。封止型 LED を使用して、これらの機能を具体的に示します。

著者 Akash Arora

ダウンロード

記事の添付資料

序論

OpticStudio には、多様な空間および角度の光源 (光線) 分布をシミュレーションするために、膨大な数のノンシーケンシャル光源タイプが組み込まれています。ディテクタ (極) を使用すると、IESNA 光源や EULUMDAT 光源などのインポートした光源をはじめとする、これらすべての光源の放射強度を測定できます。光源を選択し、光学系のモデル化と最適化を完了すると、ディテクタ (極) を使用して、個々の光源データまたはシステムの光出力を標準フォーマットにエクスポートし、別のソフトウェアで使用することもできます。

この記事では、角度光源データをエクスポートする方法と、それを OpticStudio にインポートして適切なエネルギー分布を確認する方法を示します。

ディテクタ (極)

ディテクタ (極) は、極座標に放射強度データを表示する球体のディテクタです。ディテクタに到達した NSC 光線のパワーと三刺激値 (トゥルー カラーなど) の両方のデータを示すことができます。このタイプのディテクタは「遠視野」ディテクタと考えることができます。一方、「近視野」ディテクタは空間座標でデータを表示します。光源の特性の場合、遠視野強度データは強度プロファイルを表示する際に最も有益であることが普通です。極座標は角度データを確認する際に最も直観的な方法です。

Polar Detector

ディテクタ (極) には、以下の固有なパラメータがあります。

  • 最大角度 : 最大極角 (0°~ 180°の範囲の度数)。これは極角なので球体を定義できます。
  • 半径 : ディテクタの最大半径。球体ディテクタの半径を決定します。
  • #P ピクセル : 極方向ピクセル数 (10 ~ 721)。
  • #A ピクセル : 方位方向ピクセル数 (12 ~ 720)。
  • ミラー : 入射光線に適切な対称性があれば、それをディテクタで利用できます。ほとんどのディテクタ タイプでサポートされます。

ディテクタ (極) の頂点は、ディテクタのローカル座標原点からの半径に等しい距離にあります。測定対象の光源の中心にディテクタを配置することをお勧めします。この場合は、光源からディテクタの頂点までの距離が半径によって決まり、ディテクタの横方向の広がり (光源から見てディテクタが張る角度) が角度によって決まります。光源の特性を十分に把握するには、光源からのすべての光線を収集できるようにディテクタの配置とサイズを判断する必要があります。

固有の最適化オペランドである NSDP を使用して、ディテクタ (極) 上のデータを最適化できます。NSDP オペランドの構文は次のとおりです。

NSDP Surf Det# Pix# Data

Surf はノンシーケンシャル グループの面を定義し (純粋な NSC 光学系では 1)、Det# はデータを取得するディテクタ (極) を定義します (1 つまたはすべてのディテクタのクリアにも使用できます)。Pix# は、戻り値となる特定のピクセル値または計算値を定義し、Data はパワー、光束、放射測定/光度測定の強度、色度、三刺激値のどのデータを返すかを定義します。NSDP の機能の詳細については、OpticStudio ユーザーズ ガイドの最適化に関する章を参照してください。

Zemax プログラミング言語にも数値関数 NSDP() があり、最適化オペランドと同じデータを返します。この関数では、マクロを使用して、ディテクタ (極) から目的のデータを返すことができます。ZPL の詳細については、ヘルプ ファイルで「[プログラミング] (Programming) タブ」→「ZPL について」を参照してください。

IESNA および EULUMDAT のデータ形式

IESNA および EULUMDAT のファイル形式は、角度データを表現する標準的な手法として開発されました。どちらの形式も、複数の極角と方位角における相対強度を ASCII テキスト ファイルで記述しています。IESNA ファイルの拡張子は *.IES、EULUMDAT ファイルの拡張子は *.LDT です。

IESNA 形式の詳細については、次のリンクを参照してください。https://www.ies.org/

EULUMDAT 形式の詳細については、次のリンクを参照してください。 https://en.wikipedia.org/wiki/EULUMDAT

ノンシーケンシャル光学系にインポートした IESNA ファイルと EULUMDAT ファイルを光源として使用できるように、OpticStudio には 2 つの光源タイプが用意されています。IESNA 形式には「光源 (IESNA ファイル)」、EULUMDAT 形式には「光源 (EULUMDAT ファイル)」をそれぞれ使用します。IES ファイルは {Zemax}¥Objects¥Sources¥IESNA ディレクトリに配置し、LDT ファイルは {Zemax}¥Objects¥Sources¥EULUMDAT ディレクトリに配置する必要があります。これらのディレクトリにファイルを保存すると、そのファイルがオブジェクト プロパティ ダイアログの選択オプションとして表示されます。

 Non Sequential Component Editor

 Non Seqential Component Editor 2nd picture

極データを IES/LDT としてエクスポートするツール

ディテクタ (極) に記録した放射強度を、IES ファイルまたは LDT ファイルにエクスポートできます。光線を追跡し、エネルギーをディテクタに記録すると、光源データのエクスポート ツールを使用して IES 光源ファイルまたは LDT 光源ファイルを作成できます。このエクスポート ツールには、[ツール] (Tools) → [エクスポート] (Export) → [光源データのエクスポート] (Export Source Data) でアクセスできます。

Export Tool

 Export Tool 2nd

エクスポート ツールには、いくつかのオプションがあります。

  • [フォーマット] (Format) : IESNA 形式または EULUMDAT 形式にエクスポートします。
  • [ディテクタ] (Detector) : データのエクスポート元のディテクタ (極)
  • [ファイル名] (File Name) : 保存先光源ファイルの名前 (拡張子を除いた名前を指定)
  • [スムージング] (Smoothing) : データを保存する前にスムージング係数を適用します。

ファイルはその形式に応じて、{Zemax}¥Objects¥Sources の IESNA ディレクトリまたは EULUMDAT ディレクトリに保存されます。フル パス名を指定すると、ファイルはそのパスのディレクトリに保存されます。

光線の放射照度、強度、位置データも同時にエクスポートできます。光線データベースの設定には、特定のオブジェクト上の光線を保存するオプションもあります。ユーザーに必要な操作は、光線を追跡して保存し、光線データベースを開いて光線の保存先ファイルを選択して、その *.dat ファイルを使用して光源ファイルを定義することです。

LED の例 : ディテクタ (極)

ディテクタ (極) と光源のエクスポート ツールの機能を示すために、ここでは LED をモデル化しているサンプル ファイルを検討します。この記事に添付されているサンプル ファイル led_model_poldet.zar を見つけて開きます。

Polar Example

このファイルにある LED のモデル化では、アクティブな領域に光源 (体積矩形) を使用し、LED の封止と導線の表現には複数の形状オブジェクトを使用しています。ディテクタ (極) は、基準オブジェクトとして光源 (体積矩形) を参照し、その最大受光角は 60 度です。ディテクタの頂点は、光源そのものから 20mm の位置にあります。

ディテクタ (極) のデータが表示されるようにディテクタ ビューアを定義すると、OpticStudio では自動的に光源極座標図 (極方向プロット) が表示されます。これは、放射強度を表示するための最もわかりやすい方法です。ディテクタ ビューアには、光源極座標図の各種マークのほか、アクティブ カーソルが極座標で表示されます (デカルト座標表示ではありません)。 Polar Coordinates

光線を追跡し、ディテクタ (矩形) とディテクタ (極) に記録された放射強度の結果を比較します。
Radiant Intensity results

Radiant Intensity 2nd Picture

これらの放射強度の分布はほとんど同じです。実際にディテクタ (極) を構成する各ピクセルは、それぞれがほとんど同じ面積になるようなサイズに設定された三角形の領域です。ディテクタ (矩形) は、同じ面積の矩形のピクセルで構成されています。この差異によって、両方のエネルギー分布の表示には互いに多少の違いが発生します。

放射強度を光源極座標図に表示することの利点は、これら 2 つのタイプのディテクタを比較すると明らかになります。ディテクタ (極) では、光源極座標図の各種マークと極座標値を表示できるほか、90 度を超えるような任意の角度でも光線を捕捉できます。平面であるディテクタ (矩形) では、このような捕捉は不可能です。

どちらのディテクタも LED から放出されるすべてのエネルギーを収集するわけではありません。1 枚の平面ディテクタでは、90 度を超える角度で光線を放出する光源から、すべてのエネルギーを検出することはできません。この点で、ディテクタ (極) は優れています。ディテクタ (極) で、最大角度を 180 度に定義します。ディテクタは完全な球体になり、理論上は、すべてのエネルギーがディテクタに記録されます。この例では、PMMA 製封止とミラー面部品によるフレネル反射によって、多少のエネルギーが損失または吸収されます。

シェーデッド モデルのプロットには、球体のディテクタ (極) と、全球の範囲に放出された光線を、そのディテクタで捕捉できる様子が示されています。

Full Sphere
この光源極座標図から、入射角が 100 度を超えるエネルギーはほとんど存在しないことがわかります。

Radiant Intensity 3rd Picture

対数 -5 のプロットは、180 度までの範囲に少量のエネルギーが存在することを示しています。

Radiant Intensity 4th Picture

4π ステラジアンの範囲に放出される光線を捕捉する機能により、ディテクタ (極) では任意の光源の特性を全面的に評価できます。封止型 LED に関する情報がディテクタ (極) に得られたので、このデータを IES ファイルまたは LDT ファイルにエクスポートできます。

LED の例 : 光源のエクスポート

光源データのエクスポート ツールを使用して、ディテクタ (極) に保存された放射強度データを IES 形式または LDT 形式に変換します。エネルギー分布がディテクタに保存されていることを確認し、[解析] (Analyze) → [ディテクタ ツール] (Detector Tools) → [極ディテクタのデータをIES/LDT データとしてエクスポート] (Export Polar Detector Data as IES/LDT) から光源データのエクスポート ツールを開きます。

Getting to the Export Source Data Tool

次の設定を指定して [OK] をクリックします。

 Export Polar Detector Data as IES/LDT

IESNA または EULUMDAT の測光データ ファイルの作成手順はこれですべてです。任意のノンシーケンシャル光源または光源の組み合わせを使用して、光源ファイルを作成できます。ディテクタ (極) を定義して光線を追跡します。

エクスポートした強度プロファイルを確認するには、光源 (EULUMDAT ファイル) タイプを使用して LDT ファイルをインポートします。この記事に添付された別のファイル led_model_LDT.zar には、この光源とディテクタ (極) のみが収録されています。このファイルを開きます。

Sample Image 2nd

光源 (EULUMDAT ファイル) は、元の光源のような楕円体積としてではなく、点光源としてモデル化されていることに注目してください。光線の方向は、ディテクタ (極) に記録された放射強度プロファイルに応じて選択されます。光線を追跡して得られた放射強度プロファイルを、元の光学系で得られたプロファイルと比較します。

Comparison

このように結果を比較する場合は、ディテクタ (極) を基準として EULUMDAT 光源を元の位置に配置する必要があること、光源と極ディテクタの両方のプロパティ値を、データの記録に使用した時の値にする必要があることを忘れないでください。

KA-01443

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています

コメント

0件のコメント

サインインしてコメントを残してください。