OpticStudio のノンシーケンシャル モードについて

この記事は、ノンシーケンシャル モードで利用できる一連の機能をOpticStudioの将来のユーザーに紹介することを目的としています。 ノンシーケンシャル モードと混合モードの利点について説明します。 ノンシーケンシャル モードに固有のいくつかのオブジェクト タイプと機能の概要も提供します。

著者 Akash Arora

序論

シーケンシャル モードでは、光線は1つのオブジェクトから次のオブジェクトへの伝播に制限されます。 この特性により、シーケンシャル モードは、イメージングおよびアフォーカルシステムの分析に最適です。 より高い柔軟性が必要なシステムを使用している場合は、ノンシーケンシャル モードを使用することをお勧めします。 ノンシーケンシャル 光線追跡により、光線が任意の順序で光学部品を伝播し、光線を分割、散乱、反射して、すでに遭遇したオブジェクトに戻すことができます。 この特性により、ノンシーケンシャル モードは、あらゆるシステムタイプの迷光、散乱、照明の分析に理想的です。光学系を光線で追跡できる場合、OpticStudioのノンシーケンシャル モードでシミュレーションできます。 

ノンシーケンシャル光線追跡とは

ノンシーケンシャル光線追跡は、追跡されている光線が当たる必要のある事前定義された一連の面がないことを意味します。光線が当たるオブジェクトは、オブジェクトの物理的な位置とプロパティ、および光線の方向によってのみ決定されます。光線は、ノンシーケンシャルオブジェクトの任意の部分に当たる可能性があり、同じオブジェクトに複数回当たるか、まったく当たらない可能性があります。

ノンシーケンシャル モードでは、光学部品は面または体積として、3次元オブジェクトとしてモデル化されます。各オブジェクトは、独立して定義された方向で、独立したxyz座標に配置されます。シーケンシャルモードの単一面を使用して正確にモデル化できないオブジェクトが多数あり、代わりに実際の3Dコンポーネントとしてモデル化する必要があります。これらの光学系の例には、複雑なプリズム、コーナーキューブ リフレクタ、ライトパイプ、ファセットオブジェクト、CADプログラムで作成されたオブジェクト、埋め込みオブジェクト(他のオブジェクト内にあるオブジェクト)などがあります。

ノンシーケンシャル光線追跡は、次の2つのモードのいずれかを使用してOpticStudioでモデル化できます。

  • 純粋なノンシーケンシャル光線追跡
  • シーケンシャル/ノンシーケンシャル混合光線追跡

純粋なノンシーケンシャル光線追跡では、追跡の対象となるすべての光学部品が、1 つのノンシーケンシャル グループに属しています。また、そのグループの中で、光線を発する光源とその光線を記録するディテクタを設定します。OpticStudioの純粋なノンシーケンシャル モードが備える光源モデル化機能は、シーケンシャル モードの場合よりもはるかに包括的です。シーケンシャル モードでモデル化できる光源は、主に物体面上に置かれた点光源に限定されます。シーケンシャル モードの像解析機能を使用すると、物体面に置かれた平面状の拡張光源をモデル化できます。純粋なノンシーケンシャル光線追跡を使用すると、ノンシーケンシャル グループの中で光源を任意の位置に任意の方向で置くことができるほか、他のオブジェクトの内部に光源を配置することもできます。光源オブジェクト自体は、シーケンシャル モードで使用するような単純な点光源から、3 次元で分布する複雑な光源まで、多彩なオブジェクトとすることができます。OpticStudio Premium には、数百点の測定済み光源を収めたライブラリが用意されています。また、ベンダや外部プログラムから現実の光源の実測データをインポートすることもできます。

ノンシーケンシャル光源からの光線 (NSC 光線) には、光学部品による分割と散乱を適用できます。これらの光線に位相面や位相オブジェクトで回折が発生する設定も可能です。NSC 光線の追跡で使用できる解析オプションとして、ディテクタ上での放射照度データの評価や、光線データベース ファイルへの光線データの保存などがあります。ディテクタは、平面や曲面としてモデル化できるほか、3 次元の体積としてモデル化することもできます。

ノンシーケンシャル ディテクタでは、さまざまな種類のデータを表示できます。その例として、インコヒーレント放射照度、コヒーレント放射照度、コヒーレント位相、放射強度、放射輝度、トゥルー カラー測光結果があります。光線データベース ファイルには、追跡した各光線の履歴が保存されます。光線の光路にフィルタを適用して、特定のオブジェクトに到達した光線のみを抽出できます。このようにフィルタで抽出した光線データをレイアウトとディテクタ上に表示できます。高度な光路解析には、最大光束などの条件に基づいて光線の光路をソートする手段が用意されています。これらすべての機能により、純粋なノンシーケンシャル光線追跡は、ゴースト解析、迷光解析、さまざまな照明用途できわめて効果的な手法になっています。

混合モード (ハイブリッド モード)

シーケンシャル/ノンシーケンシャル混合光線追跡 (ハイブリッド モード光線追跡または混合モード光線追跡ともいいます) を使用する場合は、ノンシーケンシャル オブジェクトの集合をノンシーケンシャル グループの内部に設定します。このノンシーケンシャル グループは、それよりも大規模なシーケンシャル光学系に属しています。シーケンシャルに追跡されてきた光線は、入射ポートからノンシーケンシャル グループに入射し、そのグループから射出ポートを通じて射出した後、シーケンシャル光学系での伝搬を継続します。同じシーケンシャル光学系の中に複数のノンシーケンシャル グループを定義でき、各ノンシーケンシャル グループの中に任意の数のオブジェクトを配置できます。この機能により、フェーセット ミラー、ルーフ プリズム、CAD オブジェクトなどのノンシーケンシャル コンポーネントをシーケンシャル設計に追加できます。本質的にはシーケンシャルな光学系であっても、真の 3D オブジェクトとしてモデル化する方が容易なコンポーネントが存在する場合は、このシミュレーション モードが理想的です。

リボン オプションの [ファイル] (File) → [開く] (Open) またはツールバーの [開く] (Open) を使用して、\Samples\Non-sequential\Reflectors\Toroidal faceted reflector.zmx ファイルを開きます。

このファイルでは、シーケンシャル面と組み合わせてノンシーケンシャル コンポーネントを使用するシーケンシャル/ノンシーケンシャル混合光線追跡の使用方法を紹介しています。このファイルを開くときに [プロジェクト環境設定] (Project Preferences) で [セッション ファイルを使用] (Use Session Files) オプションをチェックすると、いくつかの解析ウィンドウとともに、レンズ データ エディタとノンシーケンシャル コンポーネント エディタの両方が表示されます。3D レイアウト プロットには、レイアウトの中央右側にある物体面の点光源から追跡された光線が表示されています。

3D_Layout_showing_faceted_mirror_system

ヒント : 浮動ウィンドウのタイトル バーをダブルクリックすると、そのウィンドウの表示を広げることができます。固定ウィンドウの境界をドラッグして広げると、そのウィンドウの表示を広げることができます。

[3D レイアウト] (3D Layout) ウィンドウのメニュー バーで [設定] (Settings) を選択します。[矢印の描画] (Fletch Rays) ボックスをチェックして [OK] (OK) をクリックします。光線の伝搬方向を示す矢印が描画されます。光線の光路が複雑になりやすいノンシーケンシャル光学系の多くで、このオプションは特に効果的です。

3D_Layout_with_fletches_shown

光線は最初に左から右へ伝搬し、ノンシーケンシャル コンポーネント グループに入射してフェーセット ミラー (ノンシーケンシャル コンポーネント エディタのオブジェクト 1) に到達します。そこで左方向に反射してノンシーケンシャル グループから射出し、シーケンシャルに定義されたレンズ (レンズ データ エディタの面 3 と面 4) に到達します。キーボードの矢印キー、PageUp キー、PageDown キーを使用して [3D レイアウト] (3D Layout) ウィンドウを回転し、さまざまなビューを表示できます。

ヒント : マウスのスクロール ホイールを使用して解析ウィンドウを拡大できます。また、解析ウィンドウの中で特定の位置をクリックしてからドラッグしてボックスを描画すると、そのボックスの領域を中心として解析ウィンドウを拡大できます。
ここでは、[3D レイアウト] (3D Layout) ウィンドウの中で反射鏡の周囲にこのようなボックスを描画してウィンドウを拡大します。メニュー バーのアイコンをクリックしてこの拡大表示をリセットできます。

3D_Layout_window_zoomed_in_on_faceted_reflector

このように拡大すると、反射鏡の個々のフェーセットが見やすくなります。OpticStudio のノンシーケンシャル モードでは、数多くのタイプのフェーセット オブジェクトをモデル化できます。そのようなオブジェクトとして、トロイダル面、ラジアル非球面、ポリノミアル非球面、フレネル レンズなどがあります。

[幾何学的像解析] (Geometric Image Analysis) ウィンドウでは、独特で複雑な光線分布がレンズ左側の像面に形成されます。

Geometric_Image_Analysis_window

次に、\Samples\Non-sequential\Prisms\Half penta prisms and amici roof.zmx ファイルを開きます。これは、シーケンシャル/ノンシーケンシャル混合光線追跡の別の例です。無限遠の位置にあるシーケンシャル物体面から光線を追跡します。面 1 の絞りを通過した光線は、ノンシーケンシャル プリズム光学系を通ってシーケンシャル像面に達します。

シェーデッド モデル レイアウトには、ルーフ面を画面手前に向けた状態で中央のプリズムのルーフが表示されています。このルーフ面は、互いに 90 度の角度を成す 2 つの面を屋根のように傾斜配置して構成されています。このルーフ面は平面鏡のように機能しますが、光路長が追加されるほか、それぞれの面で反射した光線が相手側の面で反射することにより、ルーフの軸を中心として像が反転する点が異なります。このシェーデッド モデル レイアウトを拡大して 3 つのプリズムを見やすくし、キーボードの PageDown キーを使用してプロットの中でビューを回転してみます。

prism_shaded_model

ヒント : この図にあるプリズムの半透明な部分は、シェーデッド モデルの「オパシティ」機能を使用して生成しています。詳細については、ナレッジ ベースの記事「How Do I Create Presentation Quality Graphics and Animations?」でオパシティに関するセクションを参照してください。

シーケンシャルに追跡している光線に対するルーフの影響を偏光瞳マップで確認できます。偏光瞳マップを開くには、リボン バーの [解析] (Analyze) → [偏光] (Polarization) → [偏光瞳マップ] (Polarization Pupil Map) を選択します。

pol_pupil_map

OpticStudio には、さまざまなプリズムの例が付属しています。プリズムのフェーセットの各角が占める x、y、z 座標を記述したテキスト ファイル形式でプリズムを定義できます。このようなファイルをポリゴン オブジェクトと呼びます。多くの CAD プログラムのエクスポート ファイル形式である STL ファイルで、プリズムとフェーセット オブジェクトをインポートすることもできます。OpticStudio で扱う POB オブジェクトと STL オブジェクトは実際のフェーセット オブジェクトです。

光源のモデル化

ここで、OpticStudio でのノンシーケンシャル光線追跡の例を見てみます。\Samples\Non-sequential\Reflectors\3 helical lamps with reflectors.zmx ファイルを開きます。このファイルでは、3 つのランプから 3 つのディテクタまで光線を追跡します。
リボン バーの [解析] (Analyze) → [NSC 3D レイアウト] (NSC 3D Layout) を選択して 3D レイアウトを開きます。[NSC 3D レイアウト] (NSC 3D Layout) ウィンドウでいずれかのランプを拡大すると、この光源のらせん構造がモデル化されていることがわかります。この例では、コイル状のらせんである光源 (フィラメント) オブジェクト タイプを使用して各ランプをシミュレーションしています。光線は、このらせん上のランダムな点から発し、各らせんを囲むフェーセット反射鏡で反射します。

layout_coil

リボン バーで [解析] (Analyze) → [光線追跡] (Ray Trace) を選択すると、ダイアログ ボックスが表示されます。このダイアログを使用して解析光線を追跡します。[クリアして追跡] (Clear & Trace) ボタンをクリックすると、ディテクタがクリアされて光線が追跡されます。新たな組み合わせのランダムな解析光線がディテクタまで追跡されます。光線追跡が終了したところで [終了] (Exit) ボタンをクリックします。

光線追跡の結果を確認するにはディテクタ ビューアを開きます。ディテクタ ビューアを開くには、リボン バーで [解析] (Analyze) → [ディテクタ ビューア] (Detector Viewer) を選択します。ノンシーケンシャル エディタのオブジェクト リストにある最初のディテクタ オブジェクトが、デフォルトでディテクタ ビューアに表示されます。この例では、オブジェクト 10 が該当します。

lamp_detector

[ディテクタ ビューア] (Detector Viewer) ウィンドウのメニュー バーで [設定] (Settings) をクリックします。別のディテクタを表示するには、[ディテクタ] (Detector) の設定をディテクタ オブジェクト 10 から別のディテクタに変更して [OK] (OK) をクリックします。

ヒント : ディテクタの位置を確認したり、その向きを判断したりするには、ノンシーケンシャル コンポーネント エディタ (NSCE) で、目的のディテクタの行をクリックします。レイアウト ウィンドウで、そのディテクタに該当する矩形がオレンジ色で強調表示されます。以下の図では、ディテクタ オブジェクト 11 がレイアウト ウィンドウで選択されています。

Detector_Rectangle

lamp_layout_highlight

この例では、追跡ごとに各光源から 10,000 本の解析光線を追跡しています。追跡する光線の本数は、ノンシーケンシャル コンポーネント エディタで光源ごとに設定します。定義した光線の本数を変更するには、ノンシーケンシャル コンポーネント エディタに記述した光源 (フィラメント) オブジェクト (オブジェクト 3、6、および 9) のうち、目的の光源に該当する行をクリックします。次に、[解析光線数] (# Analysis Rays) 列が表示されるまで右矢印キーでカーソルを右へ移動します。NSC エディタには、レンズ データ エディタ同様に「アクティブな」列見出しがあります。列の各セルにどのような値が記述されているかがわかるように、選択したオブジェクトのタイプに応じて列見出しが変化します。

NSC_Editor

この例では、各光源オブジェクトの [描画光線数] (#Layout Rays) に [解析光線数] (# Analysis Rays) よりも小さい値が設定されています。描画光線数は、解析光線数とは無関係に定義できます。したがって、解析で数千本の光線を何回追跡しても、レイアウト ウィンドウが混乱して見にくくなることがありません。開いているレイアウト ウィンドウをダブルクリックするか、レイアウト ウィンドウのメニュー バーで [更新] (Update) をクリックするたびに、ランダムに選択された新しい組み合わせの描画光線が描画されます。

NSC シェーデッド モデルの各レイアウト ウィンドウには、解析光線の追跡結果を表示できます。このオプションは、[NSC シェーデッド モデル] (NSC Shaded Model) ウィンドウの設定にある [ディテクタ] (Detector) オプションで制御します。この設定を [最終解析でピクセルを色付け] (Color pixels by last analysis) に設定すると、レイアウトには前回の解析追跡の結果に基づいてディテクタ オブジェクトが描画されます。

Color_pixels_by_last_analysis

lamp_shaded_model

OpticStudio では、簡単な形状近似とした光源 (点光源や楕円形の円盤状など) に始まり、実測の光源データに基づく光源ファイルまで、数多くのタイプの光源を使用できます。OpticStudio の Premium エディションには、数百点の実測光源を収めたライブラリが用意されています。このライブラリをダウンロードして、光線セットの生成に使用できます。リボン バーで [ライブラリ] (Library) → [Radiant Source Models] (Radiant Source Models) → [Radiant Source Models をダウンロード] (Download Radiant Source Models) を選択すると、このライブラリを表示できます。どのような光源がこのライブラリに用意されているか確認できます。

RSM_download_dialog

ヒント : 純粋なノンシーケンシャル光線追跡の設定の詳細については、ナレッジ ベースの記事「簡単なノンシーケンシャル光学系の作成方法」を参照してください。実測光源データの使用など、複雑な光源のモデル化の詳細については、ナレッジ ベースの記事「LED などの複雑な光源のモデルの作成方法」を参照してください。

複雑な形状の作成

次に、OpticStudio のノンシーケンシャル モードで複雑な形状を作成する機能について説明します。OpticStudio にはさまざまなタイプのオブジェクトが多数組み込まれており、それらを使用して数多くの多彩な形状をモデル化できます。これらのいくつかは、これまでの例で紹介しています。一方で、OpticStudio に用意されているネイティブのオブジェクトを使用しても、目的の形状を作成できないことが考えられます。

CADのインポート

そのような場合の対処手段として、CAD プログラムで目的の形状を作成し、その CAD オブジェクトを OpticStudio にインポートする方法があります。このインポートでは、静的インポートと動的インポートが可能です。静的インポートは、STP、SAT、IGS、STL などの広く使用されている CAD 形式を使用して実現できます。これらのファイル タイプをインポートし、光学プロパティを割り当ててシミュレーションに追加できます。この場合のオブジェクトの形状は均一のスケーリングに固定されていて変更できないので、このインポートは性格的に静的です。動的インポートは、Solidworks、Autodesk Inventor、または PTC Creo のパートやアセンブリに対応した CAD リンク機能を通じて実現できます (このリンク機能は Premium エディションにのみ用意されています)。この機能では、全面的にパラメータによる制御が可能です。この機能を使用するには、インポート元ソフトウェアの実動バージョンをインストールしておく必要があります。

OpticStudio に Solidworks コンポーネントをインポートした様子を以下に示します。

sw_shaded_model

ブーリアン演算

別の手段として、ブール オブジェクトを使用する方法もあります。ブール オブジェクトによる方法では、さまざまなブール演算を使用して、最大で 10 個のノンシーケンシャル体積オブジェクトを組み合わせることができます。得られたオブジェクトでは、その元となった親オブジェクトに基づいて、全面的にパラメトリックな状態が維持されています。

\Samples\Non-sequential\Geometry Creation\Boolean example 4- a lens mount.zmx ファイルを開きます。このサンプル ファイルでは、ブール オブジェクトを使用して複雑なオブジェクトを容易にモデル化する方法を紹介しています。

NSCE を見ると、4 つの体積オブジェクトが定義されていることがわかります (矩形体積と 3 つのシリンダ体積)。また、ブール オブジェクトも定義されています。このブール オブジェクトを NSCE で選択して、[オブジェクト A] (Object A) 列や [オブジェクト B] (Object B) 列などが表示されるまで、右へスクロールします。指定したブール演算は、これらのオブジェクトに適用されます。

Boolean_object

ここで見るように、矩形体積 (オブジェクト 1) はオブジェクト A、3 つのシリンダ体積 (オブジェクト 2 ~ 4) はオブジェクト B、C、D としてそれぞれ割り当てられています。

NSCE で左にスクロールして戻り、ブール オブジェクトの [コメント] (Comment) 列を確認します。この [コメント] (Comment) 列で、各オブジェクトに対するブール演算を指定します。

Comment_column_for_the_Boolean_object

[コメント] (Comment) で「a-b-c-d」が指定されているので、オブジェクト A から B、C、および D の各オブジェクトが減算されます。このように矩形体積から 3 つのシリンダ体積が減算され、簡単なレンズ取り付け構造を作成できます。この例で開いた NSC シェーデッド モデルでは、これら 4 つの親オブジェクトと演算で得られたブール オブジェクトが並んで表示されます。

boolean_shaded_model

この例では、ブール オブジェクトを使用したオブジェクトの減算を紹介していますが、加算、交差、排他 OR (XOR) の各演算によるオブジェクトの結合も可能です。

ヒント : 複雑な形状の作成については、ナレッジ ベースの記事「ブール CAD オブジェクト、ブール ネイティブ オブジェクト、複合レンズ オブジェクトと、オブジェクトの組み合わせツールの使用方法」に詳しい説明があります。記事「ネストされたオブジェクトによるNSCシミュレーション速度の向上」では、ブール オブジェクトの視認性を確保しながら、ネイティブ オブジェクトの速度を生かす方法について説明しています。

光線分割と散乱

光線分割

次に、OpticStudio の純粋なノンシーケンシャル モードの光線分割機能について説明します。\Samples\Non-sequential\Ray splitting\Beam splitter.zmx ファイルを開きます。

splitter_shaded_model

この例では、隣接して置いた 2 つのプリズム (ポリゴン オブジェクト タイプを使用してモデル化) を使用して立方体のビーム スプリッタをモデル化する方法を紹介しています。デフォルトでは、ポリゴン オブジェクトで入射光線が透過されるだけです。部分的に反射性で部分的に透過性のコーティングを施すことで、反射ビームの光路と透過ビームの光路の両方を生成できます。コーティングは、[オブジェクト プロパティ] (Object Properties) ダイアログの [コーティング/散乱] (Coat/Scatter) タブで指定します。ノンシーケンシャル コンポーネント エディタ (NSCE) で、オブジェクト 3 の [オブジェクト タイプ] (Object Type) 列をダブルクリックして、[コーティング/散乱] (Coat/Scatter) セクションをクリックします。ここで、オブジェクトごとにコーティングのプロパティを割り当てます。

Coat_Scatter_section

ヒント : この操作の詳細については、ナレッジ ベースの記事「反射性と散乱性が混在する面をモデル化する方法」を参照してください。

この例では、ビーム スプリッタの立方体を構成するすべての面にコーティングを適用しています。各外面には反射防止コーティングを適用し、内部の分割面には、半分が反射性で残り半分が透過性のコーティングを適用します。[NSC 3D レイアウト] (NSC 3D Layout) ウィンドウで光線分割の様子を確認できます。

splitter_layout

この NSC 3D レイアウトの設定を開き、[光線の分割] (Split Rays) と [偏光を使用] (Use Polarization) がチェックされていることを確認します。

NSC_3D_Layout_settings

OpticStudio で光線を分割するには偏光の計算が必要です。したがって、光線分割を確認するには、これら両方のボックスをチェックしておく必要があります。これらのボックス両方のチェックをはずして [OK] (OK) をクリックします。どの光線も分割されなくなり、入射した 1 本の光線が、立方体を構成する 2 つのプリズムを透過していることがわかります。

splitter_layout2

解析光線の追跡でも光線を分割できます。[光線追跡コントロール] (Ray Trace Control) ダイアログまたは [ディテクタ コントロール] (Detector Control) ダイアログで光線追跡と偏光計算の両方を有効にしておく必要があります。

splitter_rtc

ヒント : OpticStudio には簡易光線分割のオプションも用意されています。このオプションでは、分割界面で反射光線または屈折光線のいずれかのみを追跡します。どちらの光路を追跡するかはランダムに決まり、その確率は分割界面の反射性成分と透過性成分の相対比率に比例します。多くの光学系では、このオプションを有効にすることで処理速度が速くなります。詳細については、ナレッジ ベースの記事「単純分割とは」を参照してください。

光線散乱

ここで散乱に注目します。\Samples\Non-sequential\Scattering\ABg Scattering Surface.zmx ファイルを開きます。この例では、光線分割のほか、ノンシーケンシャル モードの散乱機能も紹介しています。

NSC 3D レイアウトには、オブジェクト 2 (平坦な矩形ミラー) での光線の散乱が示されています。これは、このレイアウトの設定で [光線の散乱] (Scatter Rays) ボックスがチェックされているからです。このレイアウトでは光線分割を無効にしているので、入射する正反射光線 1 本ごとに、反射に 1 本の散乱光線が発生します。NSC シェーデッド モデル レイアウトには、光線分割と散乱が示されます ([光線の散乱] (Scatter Rays) ボックスと [光線の分割] (Split Rays) ボックスの両方がチェックされているからです)。

scatter_shaded_model

散乱光学系で光線分割を有効にすると、散乱面または散乱オブジェクトの [オブジェクトのプロパティ] (Object Properties) にある [コーティング/散乱] (Coat/Scatter) タブでの [光線数] (Number of Rays) 設定に基づき、複数の分割された散乱光線が生成されます。オブジェクト 2 の [コーティング/散乱] (Coat/Scatter) タブに注目します。ここでは、入射する正反射光線 1 本ごとに 5 本の散乱光線を定義しています。

Coat Scatter tab for object 2

OpticStudio では、ランバーシアン、ガウス、ABg、BSDF、IS、およびユーザー定義の各散乱モデルを使用できます。IS 散乱機能は、広く使用されている市販材料の実測散乱データを収めたライブラリです。この例では、オブジェクト 2 の [コーティング/散乱] (Coat/Scatter) タブにあるように ABg 散乱を紹介しています (ABg モデルとして「TP_TEST」を選択していない場合は、ここで選択します)。

ABg scattering

散乱するエネルギーの比率は、選択した ABg モデルのパラメータの関数になります。使用されている ABg 散乱プロファイルを具体的に確認するには、リボン バーで [ライブラリ] (Library) → [ABg 散乱カタログ] (ABg Scatter Catalogs) を選択します。次のように [名前] (Name) を「TP_TEST」に変更します。

ABg Scatter Catalog

きわめて小型のディテクタ (オブジェクト 3) を、大型のディテクタ (オブジェクト 4) の前に、意図的に互いの中心を合わせて配置し、正反射光線のエネルギーを収集しています。この小型のディテクタをレイアウト上で確認するには、レイアウト ウィンドウの中で該当部分を大きく拡大表示する必要があります。大型のディテクタでは、散乱光線のエネルギーを収集します。散乱エネルギーを確認するには、ディテクタ ビューアを開き、[ディテクタ] (Detector) をディテクタ オブジェクト 4 に設定して [OK] (OK) をクリックします。

scatter_detviewer

ヒント : Zemax のフィルタ文字列機能を使用して、1 つのディテクタ上で散乱エネルギーと非散乱エネルギーを分離することもできます。使用できるフィルタ文字列とその使用方法の詳細については、ナレッジ ベースの記事「迷光の解析方法」を参照してください。

高度な機能

回折グレーティング

OpticStudio では、シーケンシャル モードとノンシーケンシャル モードのどちらでも回折性光学エレメントをモデル化できますが、回折のモデル化ではノンシーケンシャル モードの光線分割機能がはるかに有利です。

\Samples\Non-sequential\Diffractives\Diffraction grating multiple orders.zmx ファイルを開きます。

オブジェクト 2 で各入力光線が 5 本の光線に分割されていることがわかります。

grating_layout

grating_detviewer

ここでは、コーティングや散乱が設定されていることによって光線が分割されているわけではありません。ここで確認できるのは、透過回折グレーティング (オブジェクト 2) によって複数の回折次数に分割されたエネルギーです。このグレーティングの基本的なプロパティは、このオブジェクトのパラメータ列で定義します。このプロパティとして、ミクロンあたりの線数で表したグレーティング周波数などがあります。回折グレーティング オブジェクトのパラメータは、標準レンズ オブジェクトのパラメータに、回折グレーティング周波数 (ミクロンあたりの線数) のパラメータを追加したものです。

Diffraction Grating object

このオブジェクトの光線分割設定は、[オブジェクトのプロパティ] (Object Properties) ダイアログの [回折] (Diffraction) セクションで設定します。このセクションでは、各次数に分割されるエネルギーの相対量を指定します。

Object Properties dialog

ヒント : OpticStudio では、任意の次数での分割を指定できるカスタム回折 DLL を使用できます。これらの DLL を使用して、回折後の光線のプロパティをすべて明示的に指定することもできます。
このプロパティとして、相対エネルギー、方向余弦、電界の方向と大きさなどがあります。

コヒーレンスのモデル化

これらのほかに、高度な機能としてコヒーレンスのモデル化があります。\Samples\Non-sequential\Coherence\A Simple Interferometer.zmx ファイルを開きます。これも純粋なノンシーケンシャル ファイルであり、ノンシーケンシャル モードのコヒーレンス モデル化機能を紹介しています。

このファイルでは干渉計をモデル化します。オブジェクト 2 に割り当てられたポリゴン オブジェクトの前面には、透過と反射の比率が 50/50 のコーティングが施されています。このレイアウトの左上にある矩形光源からの光線は、この面で分割されます。分割された光線は干渉計の 2 本のアームを伝搬して右下のディテクタ (オブジェクト 6 と 7) に到達します。2番目のポリゴン オブジェクト (オブジェクト 5) にも、透過と反射の比率が 50/50 のコーティングが施されています。2 本の光線の光路は、このポリゴン オブジェクトによってディテクタの前で再結合されます。干渉計の左下側アームにあるミラー (オブジェクト 3) には、X 軸を中心とした 0.005 度のティルトが適用されています。このティルトによって、ディテクタ面の位置で 2 本のアームの光路が不等長になります。

interferometer_shaded_model

OpticStudio では、そのコヒーレント検出機能によって、ディテクタにコヒーレントに到達した光線に対し、検出された各光線の振幅と位相に応じてエネルギーが加算されます。これにより、干渉計で見られる干渉縞などの効果を定性的にシミュレーションできます。これらの効果を確認するには、ディテクタ ビューアの設定にある [データの表示方法] (Show Data) を [コヒーレント放射照度] (Coherent Irradiance) または [コヒーレント位相] (Coherent Phase) に設定する必要があります。

interferometer_detector_settings

リボン バーからディテクタ ビューアを開きます。ディテクタ ビューアの設定で、[ディテクタ] (Detector) をディテクタ オブジェクト 6、[データの表示方法] (Show Data) を [コヒーレント放射照度] (Coherent Irradiance) にそれぞれ設定して [OK] (OK) をクリックします。ミラー (オブジェクト 3) に適用した 0.005 度のティルトによってティルト干渉縞が発生していることがわかります。

interferometer_detviewer

ディテクタ ビューアの設定を開き、[データの表示方法] (Show Data) を [インコヒーレント放射照度] (Incoherent Irradiance) に設定して [OK] (OK) をクリックします。コヒーレント性の観点からディテクタを表示できなくなっているので、干渉縞がまったく見られなくなります。

interferometer_detviewer2

ヒント : ノンシーケンシャル モードでは、回折グレーティングのさまざまな次数で干渉を確認することもできます。この様子は、サンプル ファイル \Samples\Non-Sequential\Diffractives\Diffracting grating fringes.zmx で紹介しています。

吸収の測定

最後に、バルク体積内部で発生する吸収の測定について説明します。\Samples\Non-sequential\Miscellaneous\Voxel detector for flash lamp pumping.zmx ファイルを開きます。

これまで取り上げてきた純粋なノンシーケンシャルの例では、ディテクタとしてディテクタ (矩形) オブジェクトを使用してきました。これらは平坦面のディテクタです。OpticStudio では、曲面のディテクタや立体のディテクタなどの複雑なディテクタもモデル化できます。

この例では、簡単なレーザー フラッシュ ポンプのモデルでディテクタ (体積) オブジェクトを使用する方法を示しています。キャビティの両端にトロイダル ミラーを 1 つずつ (オブジェクト 3 と 4) 使用することで、このキャビティをモデル化しています。各ミラーの近くに、光線を発する光源 (チューブ) があります (オブジェクト 1 と 2)。キャビティの中央には、レーザー結晶をシミュレーションするシリンダ体積オブジェクト (オブジェクト 6) があります。

また、シリンダ体積オブジェクトに重なってディテクタ (体積) (オブジェクト 5) があることもわかります。このディテクタ (体積) オブジェクトは、ボクセルと呼ばれる 3 次元ピクセルで構成する矩形体積です。

voxel_layout

OpticStudio では、各ボクセル上の入射光束を記録できます。また、このディテクタ (体積) が、透過データが定義された他の体積オブジェクトに重なっている場合、OpticStudio ではディテクタ (体積) の各ボクセルに対する吸収光束を記録できます。ここでは、重なっているシリンダ体積の材料は BK7 で、その透過データは材料カタログで定義されています。この材料カタログにアクセスするには、リボン バーで [ライブラリ] (Library) → [材料カタログ] (Material Catalog) を選択します。

ノンシーケンシャル コンポーネント エディタでオブジェクト 5 に相当する行をクリックし、右へスクロールしながらディテクタ (体積) の各パラメータを確認します。このディテクタには、X 方向と Y 方向にそれぞれ 101 個、Z 方向に 25 個のピクセルがあることがわかります。

voxel_nsce

開いているディテクタ ビューアには、ディテクタ (体積) に吸収光束があることが示されています。また、ディテクタ (体積) の末尾には Z 平面の位置が示されています。ディテクタ ビューアによるディテクタ データの表示は 2 次元的表現に限られています。
このように一度に確認できるのはディテクタ (体積) 内部の 1 つの平面 (ボクセルの「スライス」) のみです。Z 平面の設定を使用して、X 方向と Y 方向のピクセルをどの Z 方向ピクセルの位置 (この例では 0 ~ 25 の範囲) で確認するかを Zemax に指定できます。

The Z Plane setting

この Z 平面の位置を変更するには、ディテクタ ビューアの設定で指定するか、キーボードの左右矢印キーを使用して Z 平面の位置をスクロールします。

voxel_detviewer2

ヒント : OpticStudio では、数多くのオブジェクト タイプをディテクタとして使用できます。この機能によって、複雑な面状ディテクタやシェル状ディテクタを容易にモデル化できます。

 

 

KA-01504

この記事は役に立ちましたか?
4人中4人がこの記事が役に立ったと言っています

コメント

0件のコメント

サインインしてコメントを残してください。