補償光学系をモデル化する方法

この上級者向けの記事では、Zemax のマルチコンフィグレーション機能を使用して、分割ミラーによる補償光学系を作成する方法を紹介します。サンプルを使用して、以下の項目を解説します。

  • 絞り面のディセンタを変更して絞り面を移動し、ミラーのアレイをモデル化する方法
  • 公差解析機能を使用してランダムな波面収差を作成し、大気による収差をモデル化する方法
  • 幾何光学点像強度分布 (PSF) および回折 PSF を最小化する最適化でこれらの収差を補償する方法
  • ソルブを使用して光学系の設定とパラメータの変更を簡素化する方法

 

著者 Nam-Hyong Kim

Downloads

添付ファイル

Introduction

分割ミラーによる補償光学系系は、収差を最小限に抑えるためにセグメントの位置を調整することができます。これは、地球の大気によって引き起こされる収差を低減する手段を必要とする天体望遠鏡で有用です。 

OpticStudio はこれらのシステムを任意のモードでモデル化できますが、このチュートリアルではシーケンシャル モードを使用します。マルチコンフィグレーションを使用して単純な分割ミラーをモデル化し、入力波面にランダムな収差を導入して解析します。これらの収差は大気効果を表すものであり、ミラーセグメントの傾きとZ位置に焦点を当てて最適化します。 

設計目標と前提条件

以下のアニメーションは、傾斜していないセグメントと、反射面の中心に対する各セグメントの傾斜をそれぞれ示しています。

 

 

 

析を目的として大気による影響を表すランダムな収差を入力波面に加え、像面での収差が最小になるように各セグメントのティルトと Z 位置を最適化します。以下の [レポート グラフィック] (Report Graphic) ウィンドウの左上に表示されているランダムな収差を自動的生成して、モンテカルロ解析を実行できるようにします。また、以下のアニメーションでは、入力波面ごとに最適化前後の幾何光学点 PSF と回折 PSF も示しています。解析を目的として大気による影響を表すランダムな収差を入力波面に加え、像面での収差が最小になるように各セグメントのティルトと Z 位置を最適化します。以下の [レポート グラフィック] (Report Graphic) ウィンドウの左上に表示されているランダムな収差を自動的生成して、モンテカルロ解析を実行できるようにします。また、以下のアニメーションでは、入力波面ごとに最適化前後の幾何光学点 PSF と回折 PSF も示しています。

 

 

以下に、設計目標と前提条件のいくつかを示します。

  • 分割ミラーとした放物面主鏡のみをモデル化します。副鏡など、完成品としての望遠鏡を構成する他のエレメントはモデル化しません。これは複雑になることを回避する措置にすぎないので、必要に応じてこれらのエレメントも容易に追加できます。
  • ミラー セグメント自体は変形しないものとします。これも単に複雑化を回避する措置であり、必要に応じて変形の効果も容易に加味できます。
  • 主鏡を 19 個のセグメントで構成し、それぞれを手動でエディタに入力します。より多数のセグメントで構成した主鏡は、エディタを変更する ZPL マクロによって作成できます。
  • 中央セグメントの頂点を基準とした各セグメントの半径方向の位置は、特定のセグメントのディセンタ パラメータからピックアップ (リンク) する必要があります。以下のアニメーションは、エディタ上で 1 つの制御用セグメントの位置を変更すると、すべてのセグメントの半径方向位置が変化する様子を示したものです。
  • 大気による影響を表すランダムな収差は、OpticStudioで自動的に生成します。

 

 

仕様の一部をご紹介します。

 

 Segment Parameter  Specification
 Sag shape (Conic constant)  -1
 Radius of Curvature  -4000 mm
 Focal Length  -2000 mm
 Shape  Hexagon
 Semi-Diameter  150 mm

 

 

3d layout

 

 

この演習を進めるためには、マルチコンフィグレーション、レイ エイミング、システム アパチャーなどの概念を理解している必要があります。これらの用語に精通していない読者は、以下の記事や OpticStudio ユーザー マニュアルを参照してください。

 

初期システムレイアウト

システムエクスプローラのウィンドウで以下のように設定します。

 

 System Explorer Setting  Value
 Aperture Type  Float by Stop Size
 Fields  One on-axis field (X = Y = 0)
 Wavelengths  550 um
 Ray Aiming  Paraxial
 Units  Millimeters

 

マルチコンフィグレーションを使用することで、コンフィグレーションごとに 1 つのセグメントをモデル化します。六角形のユーザー定義面アパチャー (UDA) による絞りを持つ面としてミラーを設定します。絞りの X 方向と Y 方向のディセンタ量を変更して絞りを移動し、レイ エイミングを使用して、ディセンタした絞り面に光線が向かうようにします。以下のアニメーションは、この絞り (六角形のセグメントを囲む赤い円) が移動する効果を示したものです。

 

3d layout

 

ミラーの前にガラス窓を配置し、公差オペランド TEZI を使用してそのサグを変更することで、入力波面に収差が発生したような状態にします。

shaded model

 

下図は、中央のセグメントと軸外 (Y = +540、X = 0) のセグメントの 1 つを示したものです。中心を外れたセグメントの X 方向、Y 方向、および Z 方向の各位置を、中央セグメントからどのように変更する必要があるかがわかります。セグメントのピボット点は必ずその面の中心です。一定の屈折率 2 を持つダミーのガラス窓をローカル Z = 0 (XY 平面) の前 90 mm の位置に配置します。これにより、この窓ガラスのサグの誤差によって直接波面収差が発生するようになります。このサグの誤差は解析の前に導入します

3d layout

 

3d layout

 

レンズデータエディタの設定

これらの面をエディタで入力する前に、六角形のユーザー定義アパチャー (UDA) を作成し、HEXAGON.UDA という名前で Zemax/Objects ディレクトリに保存しておく必要があります。
任意の ASCII テキスト エディタを起動します。UDA エンティティ「POL」を使用して六角形を作成します。シンタックスは次のとおりです。

 

POL   centerX   centerY   radius   n_edges   angle

POL x_center y_center radius(面の頂点から角までの距離) number_of_side(この例では 6) rotation_about_its_center(ゼロ)

hexgon

このファイルを HEXAGON.UDA として Zemax/Objects ディレクトリに保存します。

UDA エンティティの詳細は、マニュアルの「UDA ファイル形式」を参照してください。

まず中央のセグメントをモデル化するために、以下の面をレンズ データ エディタに挿入します。

lens data

 

面 6 を [イレギュラ] (Irregular) タイプの絞り面とし、半径を 150 mm に設定します。標準面ではなくイレギュラ面を使用するのは、ディセンタ量を面のパラメータとしてレンズ データ エディタで指定できるからです。イレギュラ面の場合、ディセンタの単位はレンズ ユニット、ティルトの単位は度数 (中央のセグメントではゼロ) で指定します。イレギュラ面のティルトとディセンタのパラメータは座標ブレーク面とまったく同様に機能しますが、面まで光線を追跡した後、これらのティルトとディセンタは内部的に取り消されます。光線追跡は次のアルゴリズムに従って実行されます。

ディセンタ、x 軸を中心としたティルト、y 軸を中心としたティルトがイレギュラ面に適用されます。

光線がこの面まで追跡されます。

この面に対する y 軸を中心としたティルト、x 軸を中心としたティルト、ディセンタがこの順序で解除されます。ミラー セグメント面 6 にユーザー定義アパチャー HEXAGON.UDA を指定します。

 

lens data

 

面 5 に位置ソルブを配置し、面 3 から面 5 までの合計距離が必ず 2100 mm になるようにします。この設定により、さまざまな (x,y) シフトを指定してミラー セグメントの複数のコピーを追加すると、それらが正しい Z 位置に自動的に配置されます。

 

thickness solve on surface 5

 

面 2 のガラスのソルブ タイプに [モデル] (Model) を選択し、屈折率 2、分散 0、アッベ数 0 を設定します。これは、純粋な位相プロファイルをモデル化するためです。

pure phase

 

面のプロパティ ウィンドウでミラーの基板厚みを 50 mm に指定します。この設定は、レイアウト プロットに表示するミラーの形状にのみ影響するにすぎません。

 

lens data

 

レンズデータエディタでピックアップを適用

座標ブレーク (CB) 面 4 に対する X 方向と Y 方向のディセンタのパラメータを、マルチコンフィグレーション エディタで変更することでこの絞り面を移動します。これらのディセンタは CB 面 8 のピックアップ ソルブによって自動的に復元されます。ミラーセグメントのティルトは CB 面 4 に対する X 軸中心と Y 軸中心のティルトのパラメータで制御し、CB 面 7 で元に戻します。さらに、イレギュラ面を CB 面 4 と同じ距離で反対方向にディセンタし、放物面の軸外の構成部分を正確にモデル化する必要があります。

 

lens data editor

 

該当するパラメータに対して、以下のピックアップ ソルブを配置します。

 

 Solve Type:   Pickup
 From Surface:  4
 Scale Factor:  -1
 Offset:  0
 From Column:  Current

 

ピックアップは、以下のパラメータに配置する必要があります。

  • 面6のパラメータ1
  • 面6のパラメータ2
  • 面8のパラメータ1
  • 面8のパラメータ2
  • 面7のパラメータ3
     

マルチコンフィグレーション エディタの設定

CB 面 4 に対する X 軸中心と Y 軸中心のティルトおよびディセンタを制御するために、マルチコンフィグレーション エディタ (MCE) を設定します (PRAM 4/1 ~ 4/4)。また、THIC オペランドを挿入して面 3 の厚みを制御し、軸外セグメントが正しい Z 位置に配置されるようにします。

 

multi config editor

 

コンフィグレーション 1 でティルトとディセンタの値をすべてゼロに設定し、中央のセグメントをモデル化します。
面 3 の厚みを 2100 mm に設定します。この値は、ダミーのガラス窓後面から中央セグメントまでの距離であるからです。

最初の軸外セグメントをモデル化するために、コンフィグレーションを 1 つ追加します。

multi config editor

 

このコンフィグレーション 2 は、Y = 270 mm、X = 0 に配置するセグメントをモデル化します。ダミーのガラス窓からこのセグメントの中心までの Z 距離は、分割されていない放物面鏡がその頂点から半径距離 270 mm の位置で示すサグ値を 2100 mm から差し引くことで求められます。このサグ値は標準面の式から計算できます。コーニック定数として -1、曲率半径として -4000 mm、動径座標として 270 mm を入力します。なお、メリット ファンクション エディタ (MFE) で SSAG オペランドを使用して Zemax で計算する方法の方がはるかに容易です。

merit function editor

 

この計算の対象となるコンフィグレーション (CONF) は 2 です。SSAG オペランドの X および Y のパラメータ値はゼロです。この面はコンフィグレーション 2 で -270 mm ディセンタ済みであるからです。2100 mm - 9.113 mm = 2090.887 mm の値を、MCE で コンフィグレーション 2 の THIC オペランドに入力する必要があります。

コンフィグレーション 2 の LDE を確認してみます。

 

lens data

ダミー面 5 は CB 面 4 と同じ位置に配置されています。したがって、放物面鏡の頂点 (軸外セグメントの中心ではありません) は座標ブレーク面の頂点から +Z 方向に 9.112 mm 離れた位置にあります。軸外セグメントの中心は、放物面鏡の頂点から -9.113 mm の位置にあり、これは CB 面 4 と同じ位置です。

面 5 と面 1 はダミー面なので、レイアウトに表示しない設定も可能です。それには、面のプロパティ ウィンドウで以下の各オプションを選択します。

 

lens data

 

lens data

 

マルチコンフィグレーションを追加

3 番目のコンフィグレーションを追加します。
 

3d layout

 

幾何計算から、上図に示したセグメントの Y 座標は 270 mm * sin(30°) = 270 * 0.5 および X 座標は 270 mm * cos(30°) = 270 * 0.866 です。オペランド PRAM 4/1 および 4/2 に対し、ピックアップ ソルブを使用してコンフィグレーション 2 の Y ディセンタ パラメータの値をピックアップし、これらの係数を乗算します。

pick up solves

 

multi config editor

 

以上のプロセスを繰り返して 7 つのコンフィグレーションを追加します。

 

config

 

以下の設定を指定して 3D レイアウトを開き、設定を確認します。
3d layout

 

3d layout

 

コンフィグレーション 8 を挿入します。このセグメントを Y = 270 mm * 2、X = 0 に配置します。

面 3 の THIC オペランドは、コンフィグレーション 8 に SSAG オペランドを使用して計算することで 53.55 mm になります。

config

 

コンフィグレーション 9 を挿入します。THIC オペランドの値は 62.094 mm、Y 座標 = 270 mm * 1.5 および X 座標 = 270 mm * 0.866 です。

          

 

3d layout

 

コンフィグレーション 19 まで、このプロセスを繰り返します。
 

config

 

セグメント数がこれより著しく多いミラーでは、コンフィグレーションを挿入して適切なピックアップ ソルブを設定する ZPL マクロが効果的です。

以下の設定を指定して 3D レイアウトを開きます。

 

3d layout

 

3d layout

 

設定を確認してメリットファンクションを構築

評価関数を検討する前に、マルチコンフィグレーション エディタが適切に設定されていることを確認します。[ツール] (Tools) → [その他] (Miscellaneous) → [スライダ] (Slider) を開き、コンフィグレーション 2 のパラメータ 1 をスライダで 270 mm から 350 mm に変更します。[実行] (Animate) ボタンをクリックすると、下図のアニメーションが表示されます。
slider

 

 

この図から、すべてのセグメントがセグメント間の距離を正確にピックアップしていることがわかります。確認を終えたら [終了] (Exit) をクリックします。

続いて、大気による収差を最小にするメリット ファンクション エディタの作成を検討します。大気による収差を最小にするということは、幾何光学 PSF と回折 PSF の大きさを最小にするということです。可能なオプションはいくつかありますが、その 1 つとして、すべてのセグメントで、幾何光学セントロイドの位置が像面の頂点に配置されるようにする方法があります。幾何光学スポットと回折スポットのセントロイドは同じ位置にあるので、この方法であれば回折 PSF と幾何光学 RMS. スポット サイズが最小になります。さらに、各セグメントの主光線の光路長を互いに可能な限り近い値にする制約も必要です。

メリット ファンクション エディタを開き、すべてのコンフィグレーションで、像面上の CENX および CENY (セントロイド位置) の目標値をゼロに設定します。光路長をターゲットにするには、主光線 (Px = Py =0) に対して PLEN オペランドを使用し、光路長がすべてのコンフィグレーションで等しくなるように制約を適用します。セグメント数がこれより著しく多いミラーでは、MFE に適切なオペランドを自動的に挿入する ZPL マクロが効果的です。コンフィグレーションごとに、以下の引数設定で CENX、CENY、PLEN の各オペランドを定義します。
 

merit function editor

 

PLEN オペランドには重み付けを設定しません。この例では、主光線の光路長の絶対値ではなく、各光路長どうしの差を目標値とします。この差を目標値とするには、EQUA オペランドを使用して、各オペランドの平均値の RMS を MFE で計算します。PLEN オペランドは分散した位置に記述されているので、適切な数の OPVA オペランドを使用してコンフィグレーションごとの光路長を順番に取得し、これらを EQUA の引数として使用する必要があります。

現在の評価関数の末尾に OPVA オペランドを 19 個定義し、行の引数として PLEN オペランドの行を指定します。これらのオペランドでは目標値と重み付けをゼロのままにします。この範囲の OPVA オペランドを引数として使用する EQUA オペランドを 1 つ定義します。目標値はゼロ、重み付けは 1 に設定します。

 

merit function editor

 

公差設定

公差解析機能を使用してランダムな波面収差を生成し、セグメントのアレイを構成する各ミラー セグメントのティルトと Z 位置を調整することでこの収差を補償します。公差解析データ エディタ (TDE) でダミーのガラス窓 (面 3) に TEZI オペランドを指定して、ランダムなサグ誤差を導入します。また、CB 面 4 (MCE ではオペランド 4 と 5) に対する X 軸中心と Y 軸中心のティルトおよび各ミラー セグメントの位置を最適化のコンペンセータ (変数) として指定する必要があります

ミラーの位置の制御には厚みソルブを使用してきました。ミラー位置がコンペンセータとして機能するには、このソルブを削除して、MCE でミラーの公称位置を定義する必要があります。面 5 から厚みソルブを削除します (ソルブのタイプを [位置] (Position) から [固定] (Fixed) に変更します)。MCE の行 7 に 1 行挿入して、面 5 に THIC オペランドを定義します。ガラス板からミラーまでの厚みが公称値 2100 になるように、各コンフィグレーションの値を設定します。

 

multi config editor

 

TDE ([エディタ] (Editors) → [公差解析データ] (Tolerance Data)) を開いて、コンペンセータのオペランドを挿入します。コンフィグレーションごとに 3 つの CMCO オペランドとして、X 軸を中心としたティルト (MC オペランド 4)、Y 軸を中心としたティルト (MC オペランド 5)、Z 位置 (MC オペランド 7) を定義する必要があります。コンペンセータを定義する場合、MCE でオペランドごとにコンペンセータをグループ化することをお勧めします。たとえば、オペランド 4 のすべてコンペンセータを記述してからオペランド 5 のすべてのコンペンセータを記述するようにします。TDE の最後に TEZI オペランドを挿入し、以下のパラメータ値を指定します。ゼルニケ項 2 ~ 9 を使用して、半径上に現れるサグの山と谷の数を制御します。RMS 誤差は 0.5 um に設定します。

tolerance data editor     

 

tolerance data editor

 

以下のオプションで公差解析を実行します ([ツール] (Tools) → [公差解析] (Tolerancing) → [公差解析] (Tolerancing))。警告メッセージで [OK] (OK) をクリックします。

tolerancing     

 

tolerancing

 

公差解析の最後で公差解析レポート ウィンドウが表示されます。現在のレンズ ファイルと同じ保存ディレクトリに 5 つのモンテカルロ ファイルが保存されます。

text viewer

 

結果を分析

現在のレンズ ファイルを保存して、モンテカルロ ファイルのいずれか 1 つを開きます。LDE の面 3 のタイプが、元のレンズ ファイルで TDE に設定した TEZI オペランドによってゼルニケ標準面に変更されています。MCE のオペランド 4、5、7 は、CMCO 公差解析オペランドによってすべてのコンフィグレーションで変数として設定されています。公差解析では評価関数が最小になるようにコンペンセータが変更されるので、これらの変数はゼロ以外の値になります。

lens data

 

multi config editor

 

追加データ エディタを起動します ([エディタ] (Editors) → [追加データ] (Extra Data))。

[正規化半径] (Norm Radius) は、LDE の面 3 の半径に相当する 800 mm に設定されています。


lens data

入力波面の形状である面 3 の形状を確認するには、[解析] (Analyze) → [面] (Surface) → [面のサグ] (Surface Sag) で面のサグ プロットを以下の設定で開きます。下記のアニメーションは、各モンテカルロ ファイルで見られる面のサグのプロットです。サグ誤差はランダムに生成されるので、実際の画面に表示されるプロットは解析実行のたびに異なります。

surface sag

 

追加分析

[解析] (Analyze) → [PSF] (PSF) → [ホイヘンス PSF] (Huygens PSF) でホイヘンス点像強度分布の解析ウィンドウを開きます。また、[解析] (Analyze) → [スポット ダイアグラム] (Spot Diagram) → [標準] (Standard) でスポット ダイアグラムを開きます。

huygens psf     huygens psf

 

spot diagram settings     spot diagram

 

最適化前の幾何光学 PSF と回折 PSF を確認するために、すべてのティルト値をゼロに設定して、ミラーの位置をリセットします。

multi config editor

 

解析ウィンドウを更新します。

 

huygens psf

 

spot diagram

 

セグメントのティルトによって収差を大幅に低減できることがわかります。

[レポート] (Report) → [レポート グラフィック 4] (Report Graphics 4) → [新規レポート] (New Report) でレポート グラフィック機能を使用して、4 つの解析結果を 1 つのウィンドウにプロットすることも可能です。

以下のレポート グラフィックは、5 つのモンテカルロ ファイルのそれぞれに対する最適化前後の PSF です。

 

report graphic

 

KA-01561

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています

コメント

0件のコメント

記事コメントは受け付けていません。