OpticStudio による物理光学伝搬の検討

この記事では、これから OpticStudio ユーザーになる可能性のある方々および新たに OpticStudio ユーザーになった方々を対象に、OpticStudio の物理光学伝搬機能について説明します。

Authored By Andrew Locke, edited by Sandrine Auriol

はじめに

幾何光学的光線追跡では、光の伝搬を十分には記述できません。厳密には、光の伝搬はコヒーレントなプロセスです。自由空間 (光学媒質) を進む波面はコヒーレントに自身と干渉します。このコヒーレントな伝搬をモデル化することは、物理光学の領域になります。物理光学伝搬 (Physical Optics Propagation: POP) とは、回折計算を使用して光学系の各面を通じた波面の伝搬を記述する、OpticStudio の機能です。光が持つコヒーレントな性質は、この機能で全面的に記述できます。

物理光学伝搬とは

POP では、点のアレイを使用して波面をモデル化します。アレイを構成する各点には、ビームに関する複素振幅情報を格納します。アレイの寸法、サンプリング、アスペクトはユーザー定義可能です。

ビームが面から面に伝搬できるように、フレネル回折伝搬アルゴリズムまたは角スペクトル伝搬アルゴリズムのいずれかを使用します。OpticStudio では、数値精度が最も高いアルゴリズムが自動的に選択されます。回折伝搬アルゴリズムでは、あらゆる伝搬距離と任意のビームで適切な結果が得られ、ユーザー定義アパチャー (UDA) などのあらゆる面アパチャーを考慮できます。

POP の応用例として、ファイバ結合 (シングル モードとマルチモード)、あらゆるタイプの光学空間での回折伝搬、収差による最適なウェスト焦点位置のシフトの計算、光学面でのビーム光束と放射照度の計算があります。物理光学伝搬を使用して、複雑な光学系における任意のレーザー ビーム伝搬を詳しく解析することもできます。このような解析としてエムスクエア計算などがあります。

アナモルフィック ビーム

リボン バーで [ファイル] (File) → [開く] (Open) を選択するかツールバーで [開く] (Open) ボタンを使用し、\Samples\Physical Optics\Anamorphic Beams.zmx ファイルを開きます。このファイルは、アナモルフィックなプリズムを通るビームの伝搬を紹介しています。

Shaded_Model_layout_showing_anamorphic_prism_propagation

[設定] (Setup) → [プロジェクト環境設定] (Project Preferences) → [全般] (General) で [セッション ファイルを使用] (Use Session Files) オプションが有効になっていると、ファイルを開いたときにレンズ データ エディタ、スポット ダイアグラム、シェーデッド モデル レイアウト、および [物理光学伝搬] (Physical Optics Propagation) ウィンドウが開きます。POP ウィンドウには、像面 (面 14) におけるビーム放射照度が示されます。

当初のビーム設定を表示するには、[物理光学伝搬] (Physical Optics Propagation) ウィンドウのメニューバーで [設定] (Settings) をクリックし、[ビーム定義] (Beam Definition) タブをクリックします。ビーム タイプはガウシアンであり、X と Y 両方向の半径ウェスト サイズは 0.004 mm (4 ミクロン) です。続いて [全般] (General) タブをクリックします。ビームは面 1 から開始するように設定され、そこから像面まで伝搬します。[X、Y を分離] (Separate X, Y) オプションをチェックします。このオプションを使用すると、非点ビームやアナモルフィック ビームの伝搬を解析する際に高い精度が得られます。このオプションをオンにすると、X 方向と Y 方向で別々の位相基準が使用されます。

Beam_Definition_tab_of_POP_settings

[OK] (OK) をクリックして解析を再実行します。

POP_window_showing_anamorphic_beam

入力ビームは ウェストが 4 ミクロンの回転対称なガウス ビームですが、出力ビームはアナモルフィックになっていることがわかります。これは、面 5 ~ 13 で構成するアナモルフィックなプリズムを伝搬したからです。ウィンドウ下段にあるパイロット ビーム データでは、この様子が数値で表現されています。このパイロット ビームは、最適 (best-fit) なガウス ビームです。この最適なビームは、実際の波面パラメータに基づいて生成されています。.

アナモルフィック ビームを詳細に解析するには、物理光学伝搬の断面プロットを使用します。POP 断面プロットを作成するには、POP ウィンドウのメニューバーで [設定] (Settings) をクリックします。[表示] (Display) タブをクリックし、[表示方法] (Show) を [断面 X] (Cross X) に設定して [OK] (OK) をクリックします。

X-direction_cross_section_POP_display

ヒント : POP ウィンドウ下部にあるタブで [テキスト] (Text) をクリックすると、表示されたデータを要約したテキストを生成できます。ここでデータ範囲を強調表示し、標準の Windows ショートカット (Ctrl-C と Ctrl-V) を使用すると、そのデータをクリップボードにコピーして、他のアプリケーションに貼り付けることができます。メニューバーの [コピー] (Copy) アイコンをクリックするとテキスト全体をコピーでき、メニューバーの [名前を付けて保存] (Save As) ボタンをクリックすると、テキストファイルにデータを保存できます。総合的なデータ分析が必要な場合に効果的な機能です。

フォーカスリング付きアキシコン

\Samples\Physical Optics\Axicon with ring focus.zmxファイルを開きます。このファイルは、OpticStudio の物理光学伝搬機能を使用して、レーザービームをリング状の分布に変換する計算を行うデモです。このようなリング状のビームは、レーザー角膜手術やレーザー材料加工などの医療用途でよく使用されます。

mceclip0.png

アキシコンのサグは、POPの伝搬アルゴリズムの自動選択を混乱させることがあります。

mceclip1.png

そのため、アキシコンでは、POPの設定は手動で設定することが多いです。

mceclip2.png

ファイバ結合

\Samples\Physical Optics\Fiber Coupling.zmx ファイルを開きます。このファイルでは、OpticStudio の物理光学伝搬機能を使用したファイバ結合の計算を紹介しています。このファイルで表示される POP ウィンドウの下部に、ファイバ結合の情報が表示されます ([セッション ファイルを使用] (Use Session Files) をチェックしておく必要があります)。現在、結合はきわめて良好であり、結合効率が 99% を超えています。

Fiber_coupling_information_displayed_at_bottom_of_POP_window

結合対象のビームは、ウェストが 2 mm のガウス ビームです。これは、POP ウィンドウ設定の [ビーム定義] (Beam Definition) タブで確認できます。受光ファイバの定義は、POP ウィンドウ設定の [ファイバ データ] (Fiber Data) タブで確認できます。受光ファイバ モードはガウシアンで、ウェストは 8 ミクロンです。また、[ファイバー結合積分を計算] (Compute Fiber Coupling Integral) をチェックしておく必要があります。このボックスをチェックしておくと、ファイバ結合情報のみが表示されます。チェックしていない場合、POP ウィンドウの下部にはパイロット ビーム データが表示されます。

Fiber_Data_tab_of_POP_window_settings

これ以上細いファイバへの結合をシミュレートする場合は、受光ファイバ モードを変更します。[ファイバ データ] (Fiber Data) タブで、[ウェスト X] (Waist x)[ウェスト Y] (Waist y) を 0.004 に変更し、[OK] (OK) をクリックします。結合が再計算されます。

POP_window_showing_reduced_fiber_coupling_efficiency

ヒント : フル ライセンス バージョンの OpticStudio では、評価関数のオペランドである FICP を使用すると、物理光学伝搬の計算に基づいてファイバ結合を最適化できます。
ライセンスを付与されているユーザーであれば、ナレッジ ベースの記事「OpticStudioでのシングルモードファイバ結合」で、シングルモード ファイバ結合について詳しく知ることができます。

ギブズ現象

ここでは、物理光学的伝搬 (Physical Optics Propagation) を使用して、均一なビームをアパチャーで遮蔽したときに発生する近視野回折効果をモデル化する方法について説明します。
\Samples\Physical Optics\Gibbs Phenomenon.zmx ファイルを開きます。

この例では、絞り面の半径の隣に「U」が表示されています。これは、この面に形状が明確な固定アパチャーが設定されていることを示します。このアパチャーの半径は、面の半径に等しくなっています。したがって、この場合、アパチャーは半径 0.1 mm の円形アパチャーです。

Lens_Data_Editor_showing_fixed_Semi-Diameter_on_stop_surface

このファイルを開くと、2 つの断面 POP ウィンドウが同時に開きます。一方のウィンドウは面 1 での POP 出力を示し、もう一方のウィンドウは像面 (面 2) での結果を示します。両方のウィンドウに同じビームが定義されています。唯一の相違点は、設定ダイアログの [全般] (General) タブで定義されている [終了面] (End Surface) です。[ビーム定義] (Beam Definition) タブでは、トップ ハット ビーム タイプを使用してウェスト サイズが 0.1 mm の均一ビームが定義されています。

Beam_definition_tab_of_POP_settings_showing_Top_Hat_settings

左側の断面プロットには、アパチャーを通る前の均一なビーム振幅が示されています。右側のプロットには、アパチャー通過後のわずかな距離でビームのエッジに見られるリンギングが示されています。これは、回折の特性によって発生しています。

POP_output_on_surface_1    POP_output_on_surface_2

このリンギングは、幾何光学的光線追跡では予測できません。このような効果をモデル化するには、物理光学伝搬が必要です。
ヒント : 物理光学伝搬では複素振幅のアレイが伝搬するので、ビームの位相も表示できます。POP を使用して位相出力を表示するには、POP 設定ダイアログの [表示] (Display) タブで [データ] (Data) の設定を [位相] (Phase) に変更します。

空間フィルタ

\Samples\Physical Optics\Pinhole Aperture.zmx ファイルを開きます。この例では、POP を使用した空間フィルタのモデル化を紹介しています。面 2 と面 3 で記述されているレンズにより、面 4 の位置で光が焦点を結びます。アパチャーは面 5 に置かれていますが、これは面 4 と同じ場所です。このアパチャーがどのように定義されているかを確認するには、レンズ データ エディタの面 5 の行で [標準] (Standard) と表示されている場所をダブルクリックします。続いて [アパチャー] (Aperture) タブをクリックします。この面には、半径が 6 ミクロンのピンホール状円形アパチャーが設定されています。

Pinhole_aperture_settings_on_surface_5

のファイルを開くと同時に開く 2 つの [物理光学伝搬] (Physical Optics Propagation) ウィンドウには、ピンホールの前 (面 4) とピンホールの後 (面 5) でのビーム出力が示されます。

POP_output_before_pinhole   POP_output_after_pinhole

ビームは、ピンホールによって大きく変化しています。入力ビームに収差がある場合は、ピンホールを基本モードのみが通過し、ビームがクリーン アップされます。ピンホールを通過したビームの全パワーは、元の入力の 1 W から大幅に減少しています 。ピンホールでビームがクリーンアップされましたが、ビームのパワーが元のパワーの 20% に満たない 0.18 W に減少しています。

ヒント : レンズ データ エディタの [コメント] (Comment) 列に表示されているコメントは、伝搬に対して [終了面] (End Surface) として定義された面について POP ウィンドウに表示されます。これは、さまざまな面でビーム出力を生成する際に、複数の POP ウィンドウを区別するうえで効果的です。

複合光学系

物理光学伝搬の適用範囲は、単純なレンズによる伝搬に限定されません。レンズ アレイのような複合光学系での伝搬も計算できます。
\Samples\Physical Optics\Lenslet Array.zmx ファイルを開きます。このファイルでは、球面レンズの矩形アレイを通じたトップ ハットビームの伝搬を紹介しています。このアレイは、ユーザー定義タイプの面を使用して定義した面 2 でモデル化します。このタイプの面は全面的に任意な設定が可能であり、外部 DLL を使用して定義します。これらのタイプの面の詳細については、ナレッジ ベースの記事「ユーザー定義DLLをコンパイルする方法」を参照してください。

この例で使用されているユーザー定義面は球面レンズレットの矩形アレイです。これは、OpticStudio に付属する多数のサンプル DLL の 1 つです。このアレイのパラメータは、レンズ データ エディタのパラメータ列で定義します。これらのパラメータを表示するには、LDE で面 2 に対応する行の任意の場所をクリックします。次に、キーボードの右矢印キーを使用して右にスクロールします。コーニック定数の列を通り過ぎた位置までスクロールします。アレイを構成するエレメントの数を定義した列およびそれぞれのエレメントの幅を定義した列が X 方向と Y 方向について表示されます。アレイにある各エレメントの曲率半径は、標準の [曲率半径] (Radius) パラメータを使用して定義します。

Lens_Data_Editor_showing_parameters_of_lens_array_surface

このファイルとともに開く [面のサグ] (Surface Sag) ウィンドウには、アレイを構成する各レンズレット エレメントの曲率とアパチャーが示されます。

Surface Sag plot showing lens array

このファイルとともに開く POP ウィンドウには、このアレイを通じて伝搬する均一なビーム (トップ ハット) の結果が示されます。

POP_output_through_lens_array

各アレイ エレメントによって形成される個々の画像を確認します。レンズレットの矩形アパチャーでも回折が発生します。この回折を [物理光学伝搬] (Physical Optics Propagation) ウィンドウで明確に表示するには、ウィンドウの設定を開き、[表示] (Display) タブをクリックします。[スケール] (Scale) 設定を [対数 -5] (Log -5) に変更し、[OK] (OK) をクリックします。

POP_window_in_Log-5_scale

ヒント : フル ライセンス バージョンの OpticStudio では、評価関数のオペランドである POPD を使用して POP の計算を最適化できます。

ビーム ファイル ビューア

物理光学伝搬にはビーム出力を保存する機能が用意されているので、後でその出力を再確認できます。保存したファイルは、ビーム ファイル ビューアを使用して表示できます。

これらの機能を確認するには、\Samples\Physical Optics\Tangential and Sagittal Focus.zmx ファイルを開きます。このファイルでは、トロイダル レンズ (面 2 と面 3) を通る回転対称なガウス ビームの伝搬を紹介しています。トロイダル レンズによってビームに非点収差が発生します。

[物理光学伝搬] (Physical Optics Propagation) ウィンドウの設定を開き、面 6 (像面) でのビーム出力を計算し、[表示] (Display) タブをクリックします。[出力ビームを保存] (Save Output Beam To) ボックスをチェックし、その横のボックスでファイル名「Toroidal Lens」を指定します。[各面におけるビームを保存] (Save Beam At All Surfaces) ボックスをチェックして [OK] (OK) をクリックします。

Display_tab_of_POP_window_showing_how_to_save_beam_files

OpticStudio で解析が再計算されますが、今回は面ごとにビーム出力が保存されます。保存された出力を表示するには、[解析] (Analyze) リボンに移動し、[レーザーとファイバ] (Laser and Fibers) 解析グループで [ビーム ファイル ビューア] (Beam File Viewer) を選択します。ビーム ファイル ビューアの設定を開き、[ファイル] (File) ドロップダウンボックスの右側にある矢印をクリックします。用意されているビームファイルの名前が表示されます。保存したファイルの名前 (Toroidal Lens) が、その末尾に番号が付加された形で示されます。この番号は、ファイルの中でビームの保存位置となっている面の番号に相当します。POP ウィンドウで [各面におけるビームを保存] (Save Beam At All Surfaces) をチェックしているので、面ごとのファイルが列挙されます。Toroidal Lens_0001 ファイルを選択し、[OK] (OK) をクリックします。

Beam_File_Viewer_showing_output_at_surface_1

ビーム ファイル ビューアの出力は、基本的に POP ウィンドウでの表示データと同じです。ビーム ファイル ビューアの設定には、POP ウィンドウの [表示] (Display) タブに用意されているオプションと同じものが多数あります。他の面での POP 出力を確認するには、ビーム ファイル ビューアの設定の [ファイル] (File) ドロップダウンで該当のファイルを選択します。

ヒント : キーボードの左右矢印キーを押すと、ビーム出力を一度に 1 面ずつスクロールできます。

Scrolling_through_beam_output_at_each_surface

References

OpticStudio のガイド付きツアーを続行するには、次のナレッジ ベースの記事を参照することをお勧めします。

Video Tutorial: Physical Optics on the Zemax Resources page

 

KA-01582

この記事は役に立ちましたか?
5人中5人がこの記事が役に立ったと言っています

コメント

0件のコメント

サインインしてコメントを残してください。