チュートリアル 1:ファイル ビューア

OpticsViewer では、精度の低下や情報の喪失を伴うことなく、OpticStudio のあらゆるシーケンシャル ファイルを読み込むことができます。設計目標や公差の範囲をはじめとして、すべての設計データが得られます。

著者 Alina Shmidt

Downloads

ダウンロード 記事の添付資料

Introduction

OpticsViewer では、ZMX 形式または ZAR 形式のあらゆるシーケンシャル ファイルを開くことができます。これにより、光学系の調査、解析、図面作成のほか、光学設計部門で使用した最適化と公差解析の基準も確認できます。このチュートリアルでは、シーケンシャル ファイルを読み込み、設計目標や公差範囲をはじめとする設計データを表示する方法を学びます。

OpticsViewer でファイルを開くには、[ファイル] (File) → [開く] (Open) を使用します。
 

Open

 

はじめに、この記事に添付されたサンプル ファイル SC_Tol_Cooke.zmx を開きます。レンズ データ エディタの画面にファイルの内容が表示されます。光学系内のレンズのパラメータは、すべてレンズ データ エディタで定義します。シーケンシャル光線追跡では、光を「物体」面と呼ばれる光源から面 1、さらに面 2、3... を経て最後の「像」面まで追跡します。歴史的な理由から、光学系が光源の像を形成しない場合であっても、この最後の面は常に像面と呼ばれます。
 

LDE

 

このサンプルの光学系では、一般的なレンズ タイプである Cooke トリプレットを 3 枚のレンズで構成しています。各レンズは、2 つの面の組み合わせで表され、第 1 面で第 2 面までの厚みと材質を定義します。この例では、面 1 と面 2、面 3 と面 4、面 5 と面 6 によって 3 枚のレンズを定義しています。各面に相当する行には、その面の定義に使用する各種パラメータが表示され、それぞれの値が何を表しているかはすべて見出し行で確認できます。各面に相当する行には、その面の定義に使用する各種パラメータが表示され、それぞれの値が何を表しているかはすべて見出し行で確認できます。各面に相当する行には、その面の定義に使用する各種パラメータが表示され、それぞれの値が何を表しているかはすべて見出し行で確認できます。
  

3D Viewer

 

3D ビューアを開くと、レンズ光学系のレイアウトが表示されます。レンズ データ エディタで現在選択している面は橙色でハイライト表示されます。
 

3D Layout

 

画面左側のシステム エクスプローラでは、アパチャーの設定、視野の定義、システム波長など、光学系全体にわたる設定を確認できます。
 

System Explorer

 

光学系を定義するパラメータを表示できるほか、最適化の目標値や公差解析のパラメータにもアクセスできます。最適化の目標値を確認するには、開いているメリット ファンクション エディタのタブをクリックするか、[データ] (Data) → [メリット ファンクション エディタ] (Merit Function Editor) を選択します。
 

MFE

 

メリット ファンクション エディタでは、オペランドと呼ばれる一連の設計目標値として、設計仕様が記述されています。各オペランド名は、通常はそれが表す数量に対応した 4 つの文字で構成されます。たとえば、MTFA オペランドは MTF の平均値 (MTF Averaged)、OPGT は「ある値より大きいオペランド」 (OPerand Greater Than) を意味します。
 

MFE

 

メリット ファンクション エディタの各行には、光学系で測定する何らかの値を計算するオペランドが配置されています。オペランドが異なれば、その引数も異なります。引数の名前はエディタの見出し行に表示されます。見出し行に表示される引数名は、メリット ファンクション エディタでハイライト表示した行 (オペランド) に応じて変化することがあります。この様子を確認するには、MTFA オペランドの行のどこかをクリックしてから、BLNK オペランドまたは OPGT オペランドの行のどこかをクリックしてみます。

クリックしたオペランドごとに値が計算され、結果がエディタの [現在値] (Value) の列に返されます。オペランドには達成する目標値と重みも設定できます。それぞれ [目標値] (Target) と [重み] (Weight) の列に入力します。

このファイルでは、MTF (光学系のコントラスト) をさまざまな空間周波数で計算し、次に OPGT オペランドを使用して MTFA オペランドが特定の値よりも大きくなるように、最適化機能に指示しています。MTFA オペランドの [重み] (Weight) の列が 0 であることに注意してください。これは、MTF の具体的な値は重要ではなく、値列の数値よりも大きい MTF の実現が目標であることを意味します。OPGT オペランドの重みが 1 に設定されている理由はこの点にあります。

使用できるオペランドの詳細とそれぞれの意味を確認するには、メリット ファンクション エディタ ツールバーの [ヘルプ] (Help) アイコンをクリックします。

 

Help

 

ヘルプ ファイルのページ下部にある [最適化オペランド (アルファベット順)] (Optimization Operands (Alphabetically)) をクリックするか、手動で [OpticsViewer] タブ→ [データ] (Data) ドロップダウン → [メリット ファンクション エディタ] (Merit Function Editor) → [最適化オペランド (アルファベット順)] (Optimization Operands (Alphabetically)) を選択します。
 

Help Files

 

最適化の目標のほか、公差解析データ エディタで公差解析の目標値を確認することもできます。公差解析データ エディタにアクセスするは、[データ] (Data) → [公差解析データ エディタ] (Tolerance Data Editor) を選択します。

 

TDE

 

公差解析データ エディタは、光学系のさまざまな部分の公差を各種オペランドで定義するという点で、メリット ファンクション エディタと同様に動作します。オペランドを追加すると、公称値 (公差解析の初期値) が自動的に入力され、その右の [最小] (Min) 列と [最大] (Max) 列に公差の範囲を設定する値が表示されます。たとえば、オペランド 5 の TRAD には、公称値として -144.5、公差の範囲として -0.2 ~ +0.2 が設定されています。この TRAD (Tolerance on RADius of curvature) オペランドは、面 3 の曲率半径の公差です。

 

TDE

 

公差オペランドの詳細はヘルプ ファイルを参照してください。ツールバーの青いヘルプ ボタンをクリックするか、「[OpticsViewer] タブ」→「[データ] (Data) ドロップダウン」→「[公差解析データ エディタ] (Tolerance Data Editor)」→「[公差解析オペランド] (Tolerance Operands)」を参照します。
 

Help Files

 

KA-01879

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています

コメント

0件のコメント

記事コメントは受け付けていません。