チュートリアル 4:性能解析

このチュートリアルでは、光学系を解析するために OpticsViewer に用意されている強力な機能のいくつかを紹介し、その機能で出力されるデータを視覚化して操作する方法について解説します。
 

著者 Alina Shmidt

Introduction

さまざまなシステム ビューアと解析機能を使用して、光学設計の性能を検討し、設計仕様を満たしていることを検証します。
 

OpticsViewer は、光学系の性能の計測に必要なあらゆる解析機能を備えています。これらの機能は、[解析] (Analyze) ドロップダウンから利用できます。
 

Analyze drop-down

 

各解析ウィンドウには、レンズ データ エディタに入力したレンズ光学系で計算されたデータがグラフィック形式またはテキスト形式で表示されます。これらのウィンドウではレンズ データは一切変更されません。レンズ光学系の性能を、さまざまな観点から捉えた診断情報が表示されます。
 

Field Curvature and Distortion

 

各解析ウィンドウはすべて、同じユーザー インターフェイスで動作し、同じメニュー バーが表示されます。
 

Toolbar

 

[設定] (Settings) アイコンをクリックすると、計算に渡す入力パラメータを指定するダイアログ ボックスに切り替わります。[保存] (Save)、[読み込み] (Load)、[リセット] (Reset) の各ボタンをクリックすると、それぞれデフォルト設定の保存、その呼び出し、出荷時デフォルトへのリセットが可能です。いずれかのウィンドウで設定を保存すると、その設定は固有の設定がないすべてのファイルのデフォルトになるため、指定した設定がすべての作業に自動的に反映されます。
 

Settings

 

[設定] (Settings) アイコンの隣にある [更新] (Update) メニュー項目をクリックするか、解析ウィンドウの任意の場所をマウスの左ボタンでダブルクリックすると、解析ウィンドウの表示内容が再計算されます。
 

Update

 

OpticsViewer ウィンドウの上部にあるクイック アクセス ツールバーで [すべて更新] (Update All) ボタンをクリックすることで、開いているすべてのウィンドウを同時に更新することもできます。
 

Update all

 

ウィンドウの [更新] (Update) ボタンの隣には、[コピー] (Copy)、[名前を付けて保存] (Save As)、[印刷] (Print) の標準的な各アイコンもあります。
 

Copy Save As Print

 

右クリックするとコンテキスト メニューが表示されます。3 次元データを表示する解析ウィンドウには、2 次元データのプロットよりも多くのオプションがあります。
 

Context Menu

 

一連の注釈ツールを使用すれば、テキスト、矩形、矢印、線などを使用した注釈を解析機能に追加できます。
 

Annotation Tools

 

ウィンドウのロック、ロック解除、クローン作成、オーバーレイ表示ができるほか、描画解像度を変更することもできます。また、ウィンドウのアクティブ カーソルのオンとオフを切り替えることができます。
 

Other Settings

 

プロット領域では、特定の領域を拡大表示できます。マウスの左ボタンをクリックしたままドラッグして、拡大する領域を指定します。または、X 軸と Y 軸の端にある灰色のバー (下図参照) をクリックしてドラッグするか、右マウス クリックで表示されるメニューから [軸オプションを編集] (Edit Axis Options) を選択します。
 

Axis Options

 

[テキスト] (Text) タブには、計算で使用されたデータが表示されます。これらのデータの全体または一部 (目的の部分をハイライトして右クリックします) を、クリップボードにコピーできるほか、テキスト ファイルに保存することもできます。
 

Text Tab

 

レンズの性能を確認するために頻繁に使用する解析として、スポット ダイアグラム、MTF、画像シミュレーションの 3 つがあります。
スポット ダイアグラムは、[解析] (Analyze) → [標準スポット ダイアグラム] (Standard Spot Diagram) から利用できます。
 

Standard Spot Diagram

 

この解析から、光学系で追跡されてきた光線束が到達する位置の座標がわかります。
 

Spot Diagram

 

MTF データは、[解析] (Analyze) → [FFT MTF] (FFT MTF) または [解析] (Analyze) → [ホイヘンス MTF] (Huygens MTF) から利用できます。
この例では、FFT MTF を実行しています。
 

FFT MTF

 

この解析では、高速フーリエ変換 (FFT) を使用して変調伝達関数 (MTF) を計算します。MTF は光学系の解像度を表す測定値です。
 

FFT MTF

 

画像シミュレーションは、[解析] (Analyze) → [画像シミュレーション] (Image Simulation) から利用できます。
 

Image Simulation

 

この解析は、光学系を通して画像がどのように見えるかを近似的に表示します。レンズ性能の把握には効果的ですが、定量的な解析には使用できません。
 

Image Simulation

 

上記の解析のほかにも多数の機能が用意されていて、光学系とその性能に関するほぼあらゆる情報を確認できます。
 

KA-01881

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています

コメント

0件のコメント

記事コメントは受け付けていません。