シーケンシャル面からノンシーケンシャル オブジェクトへの変換

この記事では、シーケンシャル面をノンシーケンシャル オブジェクトに変換する方法、デザインの固定とクリティカル光線生成の使用方法、ノンシーケンシャルの光源およびディテクタの挿入方法、ノンシーケンシャル光線追跡の実行方法を紹介します。

著者 Kristen Norton, Nam-Hyong Kim

ダウンロード

この記事の添付ファイル

序論

最適化、解析、公差解析が終了したシーケンシャル光学系は、光学機械的な迷光の問題の詳細な検討をはじめとして、ノンシーケンシャル光学系への変換が必要になることが普通です。面がノンシーケンシャル モードのオブジェクトに変換されたら、追加のCADオブジェクトを簡単に挿入して、マウント、バッフル、またはアイリスの開口部を表し、システムの光学コンポーネントと機械コンポーネント間の相互作用を詳細に見ることができます。

この記事では、シーケンシャル モードの光学系を手動でノンシーケンシャル モードの光学系に変換する方法と、自動的に変換を行うNSCグループに変換ツールを使用する方法について説明します。 

例 1 : シーケンシャル面からノンシーケンシャル コンポーネントへの変換

<...\Documents\Zemax\Samples\Sequential\Objectives> に保存されているサンプル ファイル Cooke 40 degree field.zmx を使用して、例を示しながらこの変換を実行する方法について説明します。

下図に、レンズ データ エディタと 2D レイアウトを示します。

Lens_Data

ミックスドモードへの変換に使用するファイルの作成

まず、面 1 (最初のレンズの前面) から 面 6 (最後のレンズの後面) までの範囲を、それと等価なノンシーケンシャル コンポーネントに変換します。次に、現在のシーケンシャル像面 (面 7 の IMAGE) の位置にノンシーケンシャル ディテクタ オブジェクトを手動で配置します。また、物空間の軸上光線を表すノンシーケンシャル光源も配置します。これらの光源とディテクタ オブジェクトは、光学系が正しく変換されたことを確認するうえで効果的です。

変換ツールには、[ファイルをノンシーケンシャル モードに変換] (Convert file to non-sequential mode) のオプションがあります。

Convert_to_NSC

このオプションを選択しない場合、OpticStudio では、指定されたシーケンシャル面の範囲が、レンズ データ エディタ上で 1 つのノンシーケンシャル コンポーネント面に置き換えられます。このノンシーケンシャル コンポーネント面には、変換後のノンシーケンシャル オブジェクトのグループがあります。これらのオブジェクトにはノンシーケンシャル コンポーネント エディタでアクセスできます。このようにして、シーケンシャル モードとノンシーケンシャル モードの両方を使用する「ミックスドモード」の光学系が作成されます。ミックスドモードの光学系の場合、ノンシーケンシャル コンポーネント (NSC) グループの外では光線がシーケンシャルに追跡されますが、NSC グループの中ではノンシーケンシャル光路をたどる追跡が可能です。シーケンシャル光線は入射ポートから NSC グループに入り、射出ポートから出ます。

「絞り面」の概念は、シーケンシャル光線追跡にのみ適用されます。シーケンシャル光線追跡では、入射瞳を満たすように光線の方向が決まるからです。入射瞳とは物空間で見た絞り面の像です。したがって、光学系の絞り面として設定できるのはシーケンシャル面のみです。設計の中で、絞り面はノンシーケンシャル部分より前に置く必要があります。クック トリプレットの例では、絞り面が光学系の内側に置かれています。そのため、クック トリプレットをミックスドモード光学系に変換する場合、現在の絞りの位置を、ノンシーケンシャル オブジェクトに変換する最初のレンズの前に挿入したダミー面に移動する必要があります。

さらに、ノンシーケンシャル設計への変換前に、すべての半径を固定する必要があります (固定されていると半径の横に「U」と表示されます)。このファイルの半径の値は既に固定されていますが、後ほど別の例で半径を固定する方法を説明します。

クック トリプレットのファイルで絞り面を移動するには、まず現在の面 1 の前に新しい面を挿入します。

Lens_Data_2

この新しいダミー面の [面のプロパティ] (Surface Properties) を展開します。展開するには、[面タイプ] (Surface Type) のセルをダブルクリックするか、面のプロパティのタイトル バーにある下向き矢印をクリックします。面 1 のプロパティの [絞り面として設定] (Make Surface Stop) をチェックします。

Lens_Data_3

レンズ データ エディタの新しいダミー面 (面 1) の行に、この面が絞り面になったことを示す「STOP」という文字が表示されます。
絞り面を変更したことで入射瞳も変更されています。各シーケンシャル視野点からの光線の方向は、入射瞳を満たすように決まるので、描画光線が次のように変化します。

Layout

この例では、レンズの半径を固定済みであるため、レンズ自体は変化していません。したがって、このままでもレンズを正確にノンシーケンシャル オブジェクトに変換できます。次の手順に進む前に、このファイルを保存します。参考として、この段階のファイルが Cooke 40 degree field_1.zmx として記事添付ファイルに収録されています。

NSC への変換ツールの使用方法

ここまでの作業で、ミックスドモードに変換するファイルを準備できました。[ファイル] (File) タブから [NSC グループに変換] (Convert to NSC Group) ツールを選択します。NSCグループに変換ツールは、シーケンシャル面を同等のノンシーケンシャル オブジェクトに自動的に変換します。 最も一般的に使用されているシーケンシャル サーフェスタイプ、サーフェスアパーチャ、および座標ブレークを混合モードのノンシーケンシャル コンポーネント グループに変換したり、ノンシーケンシャル モードのノンシーケンシャル システムに変換したりできます。

Convert to NSC Group_3

一部のシーケンシャル面にはノンシーケンシャルに同等物がないため、変換できません。この機能がシーケンシャル面データを完全に変換するとは限りません。重要な分析を行う前に、変換結果を注意深く確認してください。 この変換ツールの機能は、より多くの連続したサーフェスタイプをサポートするように常に更新されています。 現在サポートされているサーフェスタイプの最新情報については、[ファイル]タブの[NSCグループに変換]のOpticStudioヘルプシステムを参照してください。

現段階では、[製造ツール] (Production Tools) は無視します。面 2 ~ 7 を選択し、[エラーを無視し可能な限り変換を実行] (Ignore errors and convert as much as possible) を除くすべての設定のチェックをはずします。

Convert to NSC Group_4

[OK] (OK) をクリックすると、面 2 ~ 7 がノンシーケンシャル コンポーネント面に変換されます。

Lens_Data_4

これで、入射ポートと射出ポートを備えたミックスドモード光学系が作成されました。ポートを備えたノンシーケンシャル コンポーネント面の詳細については、OpticStudio のヘルプで、「[設定] (Setup) タブ」→「[エディタ] (Editor) グループ」→「[ノンシーケンシャル コンポーネント エディタ] (Non-Sequential Component Editor)」→「ノンシーケンシャルの概要」→「ポートありの NSC の使用方法」を参照してください。

2D レイアウトに何も表示されなくなることがわかります。ノンシーケンシャル コンポーネントは、非対称となる可能性がある 3D 光学系を表しているからです。2D レイアウトの代わりに、3D レイアウトを表示します ([解析] (Analysis) タブ→ [3D ビューア] (3D Viewer))。

Layout_2

[設定] (Setup) タブでは、シーケンシャルUIボタンが選択されていますが、ノンシーケンシャルエディタのボタンも選択可能になっていることがわかります。

Non-Sequential_Editor

[設定] (Setup) タブの [エディタ] (Editor) グループの [ノン シーケンシャル] (Non-Sequential) ボタンをクリックし、ノンシーケンシャル コンポーネント (NSC) エディタを表示します。この NSC エディタは、レンズ データ エディタに記述されたノンシーケンシャル コンポーネント面 (面 2) に相当します。グループには、シーケンシャル モード ファイルの面 2 から 7 に相当する 3 つのオブジェクトがあります。

Lens_Data_5

次の手順に進む前に、このファイルを保存します。参考として、この段階のファイルが Cooke 40 degree field_2.zmx として記事添付ファイルに収録されています。

ミックスドモードからノンシーケンシャル モードへの変換

光源とディテクタの各オブジェクトを追加する必要がありますが、純粋にノンシーケンシャルの光学系では容易な操作です。追加するには、ノンシーケンシャル モードに切り換えますが、その操作によってノンシーケンシャル コンポーネント エディタの情報のみを残し、レンズ データ エディタのシーケンシャル面がすべて失われます。

次のように、[設定] (Setup) タブの [モード] (Mode) グループにある [ノンシーケンシャル] (Non-Sequential) ボタンをクリックします。

Non-Sequential

次のダイアログ ボックスで [はい] (Yes) をクリックします。

Switch_program_mode

ファイルがノンシーケンシャル モードに変換され、レンズ データ エディタは使用できなくなります。ノンシーケンシャル コンポーネント (NSC) エディタには、ミックスドモードのときと同じノンシーケンシャル コンポーネントが保持されています。これらは、シーケンシャルのクック トリプレット ファイルの各レンズに相当しています。

レイアウトを開いて、NSC エディタにある 3 つのレンズを表示します。[解析] (Analysis) タブ→ [NSC 3D レイアウト] (NSC 3D Layout) に移動します。

NSC_3D_Layout

レンズは引き続き存在していますが、変換結果を確認するにはノンシーケンシャルの光源とディテクタを挿入する必要があります。

ノンシーケンシャル光源の挿入

シーケンシャル光学系では、無限遠にある OBJECT 面に直径 10 レンズ ユニットの入射瞳が設定されていました。これと同じ軸上入力ビームを生成するために、平行光線を発する円形のノンシーケンシャル光源オブジェクトを最初のレンズの左に配置します。

ノンシーケンシャル コンポーネント エディタの任意の場所に新しい行を挿入します。

NSCE

NSC エディタで [オブジェクト タイプ] (Object Type) のセルをダブルクリックするか、オブジェクトのプロパティのタイトル バーにある下向き矢印をクリックして、[オブジェクト プロパティ] (Object Properties) を開きます。[カテゴリ] (Category) を [光源] (Sources) に変更し、[タイプ] (Type) を [光源 (楕円)] (Source Ellipse) に設定します。

Source_Ellipse

NSC エディタで、光源 (楕円) のパラメータを以下のように設定します。その他のパラメータはすべてデフォルト値のままにします。

  • [Z 位置] (Z position) = -10 (光源は平行光線になっているので最初のレンズの左側であれば、どこに配置してもかまいません)
  • [描画光線数] (# Layout Rays) = 10
  • [解析光線数] (# Analysis Rays) = 100000
  • [X 半幅] (X Half Width) = 5
  • [Y 半幅] (Y Half Width) = 5

NSCE

3D レイアウトを更新すると、10 本の描画光線が表示されます。

NSC_3D_Layout_2

次に、100000 本の解析光線の追跡結果を表示するために、ディテクタ オブジェクトを追加する必要があります。

ディテクタ オブジェクトの挿入

シーケンシャル ファイルとの整合性を維持するために、シーケンシャル光学系の IMAGE 面と同じ位置にディテクタ オブジェクトを配置する必要があります。シーケンシャルの IMAGE 面の位置を判断するには、シーケンシャル ファイルに戻ってグローバル頂点データを参照します。ここまでの作業結果を保存し、再度 Cooke 40 degree field_1.zmx ファイルを開きます。

Cooke_40_degree_field

システム エクスプローラで [グローバル座標基準面] (Global Coordinate Reference Surface) を面 1 に変更します。

System_explorer

[解析] (Analysis) タブ→ [レポート] (Reports) → [データ一覧] (Prescription Data) に移動します。

Prescription_Data

[データ一覧] (Prescription Data) ウィンドウの設定を展開し、[全てクリア] (Clear All) をクリックしたうえで、[グローバル頂点] (Global Vertex) をチェックします。面 8 (IMAGE 面) のグローバル頂点情報を確認すると、グローバル座標基準面である面 1 を基準とした IMAGE 面の Z 座標が 60.177 レンズ ユニットであることがわかります。

Prescription_Data_2

このファイルを開いたまま、[解析] (Analysis) タブ→ [光線とスポット] (Rays & Spots) → [標準スポット ダイアグラム] (Standard Spot Diagram) に移動します。表示する必要があるのは、軸上のスポット ダイアグラムです。このダイアグラムは、ノンシーケンシャル光学系が完成した後の基準として使用できます。

スポット ダイアグラムの設定を展開し、[光線密度] (Ray Density) = 40、[パターン] (Pattern) = [ディザー] (Dithered)、[視野] (Field) = 1 を設定します。[エアリー ディスクを表示] (Show Airy Disk) をチェックし、[記号を使用] (Use Symbols) のチェックをはずします。

Spot_diagram

スポット ダイアグラムには IMAGE 面と光線の交差が表示されますが、累積放射照度を示す Z 軸が存在しません。放射照度の分布を表示するには、幾何学的像解析を使用します。[解析] (Analysis) タブ→ [拡張光源解析] (Extended Scene Analysis) → [幾何学的像解析] (Geometric Image Analysis) に移動します。

幾何学的像解析の設定を展開し、[視野サイズ] (Field Size) = 0、[画像サイズ] (Image Size) = 0.02、[光線数 x 1000] (Rays x 1000) = 1000、[表示方法] (Show) = [疑似カラー] (False Color)、[ピクセル数] (# Pixels) = 200 に変更します。

Geometric_Image_Analysis

スポット ダイアグラム下部のテキストを確認すると、エアリー半径が RMS 半径よりもわずか 2 um ほど小さいだけであることがわかります。これは、回折限界の結果も確認しておく必要があることを意味しています。[解析] (Analysis) タブ→ [PSF] (PSF) → [ホイヘンス PSF] (Huygens PSF) に移動します。

ホイヘンス PSF の設定を展開し、[瞳のサンプリング] (Pupil Sampling) および [像のサンプリング] (Image Sampling) = 256 x 256、[像のデルタ] (Image Delta) = 0.078 um、[波長] (Wavelength) = 2、[表示方法] (Show As) = [疑似カラー] (False Color) に設定します。

Huygens_PSF

ノンシーケンシャル ファイルに光源とディテクタを追加した後で、これらのシーケンシャル解析の結果を参照できます。[ファイル] (File) タブ → [開く] (Open) で、最近開いたファイルのリストから、変換したノンシーケンシャル ファイルを選択します。シーケンシャルの IMAGE 面は、レンズ データ エディタの面 1 を基準として Z = 60.177 レンズ単位の場所に配置されていることがわかっています。
ノンシーケンシャル ファイルでは、面 1 はオブジェクト 1 の前面であり、Z = 0 に配置されています。したがって、ディテクタ オブジェクトは +60.177 の Z 位置に配置します。

NSC エディタの任意の場所に、もう一つオブジェクトを挿入します。NSC エディタで [オブジェクト タイプ] (Object Type) のセルをダブルクリックするか、オブジェクトのプロパティのタイトル バーにある下向き矢印をクリックして、[オブジェクト プロパティ] (Object Properties) を開きます。[カテゴリ] (Category) を [ディテクタ] (Detectors) に変更し、[タイプ] (Type) を [ディテクタ (矩形)] (Detector Rectangle) に設定します。

Detector_Rectangle

ディテクタ (矩形) オブジェクトのパラメータを次のように設定します。

  • [Z 位置] (Z Position) = 60.177
  • [X 半幅] (X Half Width) = 0.01
  • [Y 半幅] (Y Half Width) = 0.01
  • [X ピクセル数] (# X Pixels) = 100
  • [Y ピクセル数] (# Y Pixels) = 100

3D レイアウトを更新し (ツールバーにある 2 つの青い矢印のアイコン)、ズームをリセットします (ツールバーにある黒丸に白矢印のアイコン)。光源 (楕円) からディテクタ (矩形) まで追跡された描画光線が表示されます。

NSCE_3

ノンシーケンシャル光線追跡

続いて、ディテクタ (矩形) で得られた結果を解析する必要があります。それには、[解析] (Analysis) タブ→ [ディテクタ ビューア] (Detector Viewer) をクリックしてディテクタ ビューアを開きます。現状では、ディテクタ ビューアには空白のウィンドウが表示されます。ディテクタ (矩形) に到達する光のパワーを確認するには、光源 (楕円) からの解析光線を追跡する必要があります。

[解析] (Analysis) タブ→ [光線追跡] (Ray Trace) から [光線追跡コントロール] (Ray Trace Control) を開きます。

KA-01380_30_Ray_Trace

[クリアして追跡] (Clear & Trace) をクリックしてディテクタのデータをすべてクリアしてから光線追跡を開始します。エディタの [光源 (楕円)] (Source Ellipse) の [解析光線数] (#Analysis Rays) パラメータの指定に従い、100000 本の光線が追跡されます。

光線追跡が完了すると、ディテクタ ビューアに照度分布が表示されます。以下のスクリーンショットでは、結果を疑似カラーで表示するために設定を変更しています。

Detector_Viewer

ディテクタ ビューアに表示された分布は、前のセクションで示したシーケンシャル スポット ダイアグラムや幾何学的像解析の結果とよく一致しています。これらのスクリーンショットに戻って比較するとはっきりします。

シーケンシャルの幾何学的像解析で得られたパーセント効率とワット数が、ノンシーケンシャル ファイルで得られた総ワット数と異なっていることがあります。ノンシーケンシャル ファイルでは、ディテクタに至るまでに光線は同じ面と複数回交差できますが、シーケンシャル ファイルでは、可能な光路が 1 つのみで各面との交差は 1 回のみであるからです。ノンシーケンシャル ファイルで、この 1 本の光路のみをシミュレートするには、フィルタ文字列を使用するか、各レンズの前後に吸収性の環状アパチャーを追加します。

ディテクタ ビューア : 回折の解析

ディテクタ (矩形) で得られた結果は、シーケンシャルのスポット ダイアグラムや幾何学的像解析の結果と比較できますが、この 2 つの解析では、いずれも幾何光学的な光線を使用していることから回折の効果が無視されます。

一方、シーケンシャル ホイヘンス PSF の回折の計算も、ディテクタ (矩形) の [PSF 波長番号] (PSF Wave #) パラメータを使用した同等のノンシーケンシャル計算と比較できます。波長データ エディタに定義されている波長番号のいずれかを [PSF 波長番号] (PSF Wave #) に指定すると、その波長におけるコヒーレントなホイヘンス PSF 積分をディテクタで実行できる特別なディテクタ モードが有効になります。ディテクタに到達した各光線を、ディテクタ上のすべてのピクセルを照らすローカルな平面波に変換し、すべてのピクセルにわたって、この平面波のコヒーレントな振幅の合計を計算します。これによって、シーケンシャルのホイヘンス PSF と比較可能な点像強度分布関数 (PSF) が得られます。

ノンシーケンシャル ファイルのホイヘンス PSF を表示するには、光源 (楕円) およびディテクタ (矩形) のパラメータを以下のように設定します。

光源

  • [解析光線数] (# Analysis Rays) : 5000 (光線追跡を高速化するために光線数を少なくします)

ディテクタ矩形

  • [データ タイプ] (Data Type) : 1
  • [PSF 波長番号] (PSF Wave #) : 2

[光線追跡コントロール] (Ray Trace Control) を再度開き、もう一度光線追跡を実行します。ディテクタ ビューアの [データの表示方法] (Show Data) の設定を [コヒーレント放射照度] (Coherent Irradiance) に変更します。

Coherent_Irradiance

ここに示したとおり、シーケンシャルのホイヘンス PSF とノンシーケンシャル ディテクタの結果はきわめて良好に一致しています。外側のリングの強度に見られる若干の差は、追跡した光線数の違いによるものにすぎません。

例 2: ノンシーケンシャル ファイルへの自動変換

前のセクションでは、ファイルを手動でミックスドモード光学系に変換したうえで、さらにノンシーケンシャル ファイルに変換しました。
ここでは、OpticStudio に標準装備されたツールを使用して、このプロセスを簡素化します。

このツールの使用方法を確認するために、<...\Documents\Zemax\Samples\Sequential\Objectives> フォルダにあるサンプル ファイル Double Gauss 28 degree field.zmx を開きます。

システム エクスプローラの [アパチャー タイプ] (Aperture Type) が [入射瞳径] (Entrance Pupil Diameter)、[レイ エイミング] (Ray Aiming) が [オフ] (Off) にそれぞれ設定されていることを確認します。また、どの面の半径にもソルブが設定されていません。つまり、すべての光線が通過できるように半径が自動的に調整されます。

System_explorer_2

[ファイル] (File) タブ → [NSC グループに変換] (Convert to NSC Group) に移動します。変換の各種設定の上に 2 つの製造ツールがあります。

Convert to NSC Group_5

今回の例では、これらの製造ツールを使用します。まず [デザインの固定] (Design Lockdown) ツールをクリックします。

Design_Lockdown

シーケンシャル モードで設計した光学系をノンシーケンシャル光学系に変換するには、通常、数々の手順を踏む必要があります。光学系で理想化したすべての入力値を実際の製造入力値に変換する必要があります。デザインの固定ツールは、この変換を複数のステップで構成したプロセスによって自動化します。最初のステップはレイ エイミングです。レイ エイミングは、OpticStudio の反復的な光線追跡アルゴリズムであり、物体位置を出発して絞り面を正確に満たす光線を見つけます。このアルゴリズムにより、絞り面を通る適切な光線が追跡され、自動半径の面が適切なサイズの半径に調整されます。

デザインの固定ツールでも、システム アパチャーが物理的なアパチャー サイズに変更されます。たとえば、実際の光学系では、入射瞳径を 10 mm にするために、どこから出発すればいいかを光線が認識することはできません。ユーザー側では入射瞳径を 10 mm に指定できますが、これは入射瞳がその指定サイズになるまで絞り面の直径を繰り返し調整するように OpticStudio に指示していることです。実際の光学系では開口絞りが固定されているので、これによって光学系を通過できる光線が決まります。その他の実際のアパチャーの設定として、[物空間での NA] (Object Space NA) や [物側円錐半角] (Object Cone Angle) などがあります。詳細は、OpticStudio のヘルプ ファイルの「[公差] (Tolerance) タブ」→「[製造ツール] (Production Tools) グループ」→「[デザインの固定] (Design Lockdown)」を参照してください。

同様に、像に基づく視野点定義を使用していれば、デザインの固定ツールによって物体に基づく定義を使用するように変更されます。これは、前述の入射瞳径の例と同様に、像に基づく定義でも反復計算が使用されるからです。

次に、デザインの固定ツールはすべての面の半径を固定アパチャーに変換します。これは、ダミー面を環状の面としてノンシーケンシャル ファイルに変換し、各面の有効口径の情報を保持することです。

最後に、ソルブがあれば削除され、ユーザー仕様に基づいて厚みの値が妥当な精度の値に丸められます。以上についても、詳細は OpticStudio のヘルプ ファイルの「[公差] (Tolerance) タブ」→「[製造ツール] (Production Tools) グループ」→「[デザインの固定] (Design Lockdown)」を参照してください。

デザインの固定ツールを上記のスクリーンショットのように設定し、[OK] (OK) をクリックします。Double Gauss 28 degree field-PROD.zmx というファイルが新たに作成されます。参考として、このファイルは記事の添付ファイルに収録されています。

次に、[クリティカル光線生成] (Critical Rayset Generator) をクリックします。

KA-01380_36_Critical_Rayset_Generator

クリティカル光線生成ツールは、シーケンシャル光学系で「重要な」一組の光線データを生成します。これらの光線は、ノンシーケンシャル モードへの変換時に光学系に発生する変更、またはノンシーケンシャル モードで光学系に発生するその他の変更 (迷光の効果を低減するための部品や光学系マウントの追加など) が悪影響を及ぼすものにならないようにするための基準として使用されます。この基準によって *.CRS ファイルが作成されます。このファイルは、クリティカル光線追跡によるノンシーケンシャル モードで追跡できるほか、[光源 (ファイル)] (Source File) オブジェクトとして使用することもできます。なお、クリティカル光線生成生成ツールは、OpticStudio の Premium Edition でのみ使用できます。

上記のスクリーンショットのように、[クリティカル光線生成] (Critical Rayset Generator) ツールにデフォルト設定を適用して [OK] をクリックします。[NSC グループに変換] (Convert to NSC Group) ウィンドウに戻るので、すべてのオプションをチェックした状態のまま、[OK] (OK) をクリックします。Double Gauss 28 degree field-PROD-NONSEQ.zmx というファイルが新たに作成されます。参考として、このファイルは記事の添付ファイルに収録されています。

Convert to NSC Group_6

新しいファイルが自動的に開きます。変換が完了したらノンシーケンシャル コンポーネント エディタを確認します。
レンズ データ エディタの標準面が標準レンズ オブジェクトに置き換わっているだけではなく、光源オブジェクトとディテクタ オブジェクトも追加されています。

KA-01380_38_NSCE_4

視野データ エディタの各シーケンシャル視野は、等価なノンシーケンシャル楕円光源に変換されています。さらに、スポット ダイアグラム解析を使用して、シーケンシャル視野ごとに IMAGE 面でのセントロイド位置が計算されています。これらのセントロイド位置にディテクタ (矩形) が挿入され、各視野番号のコメントも入力されています。この光学系は平坦な像面を持つフォーカル光学系であり、各視野点のディテクタ (矩形) は像面と同じ XY 平面上にあります。ほとんどのフォーカル光学系では、これらのディテクタ (矩形) は小さく、互いに重ならないように X 方向と Y 方向に離れて配置されています。しかし、ディテクタ (矩形) が大きいか、互いに近い位置に配置されているために、ディテクタが重なり合う光学系もあります。重なり合った場合、ネスティングのルールが適用されるので、ディテクタによってはすべての光線が到達しないものが発生する可能性があります。その場合は、ディテクタの位置を手動で調整する必要があります。システム エクスプローラで指定した「貼り合わせ距離」よりも大きい分離距離がディテクタ間に得られるように、その位置を変更します。

[解析] (Analysis) タブ→ [光線追跡] (Ray Trace) に移動し、デフォルト設定で光線追跡を実行します ([エラーを無視] (Ignore Errors) をチェックしておきます)。ディテクタ ビューアを開いて各視野の結果を確認します。

Detector_Viewer_2

上記のスクリーンショットには、比較のためにシーケンシャル ファイルによる結果も示しています。ディテクタ ビューアの結果は正しいようですが、さらにクリティカル光線も追跡すれば、変換が正常に実行されているかどうかを確認できます。これには、シーケンシャル ファイルのクリティカル光線生成ツールで作成した光線ファイルを使用します。[解析] (Analysis) タブ→ [クリティカル光線追跡] (Critical Ray Tracer) に移動します。

Critical_Ray_Tracer

上記のレポートを見ると、すべての光線が光学系全体を通して追跡され、各光線の位置と方向余弦がデフォルトの許容値の範囲で目標値に一致していることを確認できます。
 

例 3: 有限共役光学系の自動変換

ここまでは、OBJECT 面が無限遠にあるシーケンシャル ファイルを変換する例を取り上げてきました。OpticStudio では、物体側の点が一対一の対応で像側に結像する有限の共役光学系を変換すると、結像品質をテストするためのオブジェクトが自動的に追加されます。この機能を試すために、<...\Documents\Zemax\Samples\Sequential\Image Simulation> フォルダにあるサンプル ファイル Example 2, Double Gauss Experimental Arrangement.ZMX を開きます。

[ファイル] (File) タブ → [NSC グループに変換] (Convert to NSC Group) に移動します。

[デザインの固定] (Design Lockdown) をクリックして、次のように設定します。

Design_Lockdown_2

参考として、実行結果のファイル Example 2, Double Gauss Experimental Arrangement-PROD.ZMX が記事の添付ファイルに収録されています。

続いて、[NSC グループに変換] (Convert to NSC Group) ウィンドウですべてのオプションをチェックして [OK] (OK) をクリックします。今回の実行結果も、記事の添付ファイルに収録されています。
 NSCE_5

変換したファイルでは、光源 (楕円) の視野点の直前に非アクティブな光源 (DLL) とスライド オブジェクトが挿入されていることがわかります。ディテクタ (色) も追加され、面がネストされないように、ディテクタ (矩形) のわずか後方に配置されています。これらの光源 (DLL)、スライド オブジェクト、ディテクタ (色) を使用して、光学系の結像品質をテストできます。光源 (DLL) とスライド オブジェクトのサイズは、レンズ データ エディタで OBJECT 面に指定されている半径で決まります。ディテクタ (色) のサイズは、シーケンシャルの全視野スポット ダイアグラム解析のデフォルトの表示幅で決まります。光源 (DLL) である「Lambertian_Overfill」は、シーケンシャル光学系にある最初のアパチャーを、より実際の光源に近い、ランバーシアン分布による光で埋めます。ノンシーケンシャル光線追跡に最大限の効率を実現するために、光源 (DLL) はスライド オブジェクトと同じサイズにします。

結像性能をテストするには、全視野光源である光源 (DLL) からの光線を追跡する必要があります。NSC エディタの設定を次のように変更します。

 

光源 (楕円)

  • [描画光線数] (# Layout Rays) = [解析光線数] (# Analysis Rays) = 0

光源 (DLL)

  • #[描画光線数] (# Layout Rays) = 30
  • [解析光線数] (# Analysis Rays) = 1000000

得られる 3D レイアウトは、次のとおりです。

3D_Layout

上記の NSC 3D レイアウトでは、光線がセグメント番号ごとに色分けされ、[矢印の描画] (Fletch Rays) をチェックして矢印が表示されるようにしています。光線が点からだけではなく光源領域全体から放射され、最初のアパチャーが満たされてされていることがわかります。

[解析] (Analysis) タブ→ [光線追跡] (Ray Trace) に移動して、デフォルト設定のまま [クリアして追跡] (Clear & Trace) ボタンをクリックします。ディテクタ ビューアを開き、ディテクタ (色) のデータが表示されるように設定します。

Detector_Color

上記のスクリーンショットは、ディテクタ (色) で得られた結果を疑似カラーおよびトゥルー カラーで表示したものです。
グラフィックの隅でバーがぼやけていることがわかります。さらに詳細に調べるには、ディテクタ (色) のピクセル数と光源 (DLL) の解析光線数を多くします。

トゥルー カラーの結果では色が白く見えます。シーケンシャル ファイルで複数の可視波長を使用していると、0.44 ~ 0.64 um の波長を使用して 5800K の黒体スペクトルが放射されるように、光源 (DLL) が自動設定されるからです。

NSCE_6

シーケンシャル ファイルに使用している波長が 1 つのみの場合、またはいずれかの波長が可視光域外にある場合、光源の色またはスペクトルは、シーケンシャル ファイルからコピーされたシステム波長に設定されます。

例 4: 軸外システムの自動変換

上記の例は、[NSC グループに変換] (Convert to NSC Group)ツールが軸上光学系をノンシーケンシャルモードに自動的に変換する方法を示しています。この例では、軸外し放物面 (OAP) 鏡の偏心した開口を持つ軸外システムが自動的に変換される方法を示しています。

{Zemax}\Samples\Sequential\Tilted systems & prismsフォルダーのサンプルファイル「OAP using Chebyshev Polynomial surface.zmx」を開きます。次の変更を行います。

  • 座標ブレーク面の前に新しいサーフェスを挿入します。
  • 新しい面に、[面のプロパティ] (Surface Properties)...[タイプ] (Type)を展開し、[絞り面として設定](Make Surface Stop) を選択します。
  • [システム エクスプローラ] (System Explorer) ... [アパチャー] (Aperture) で、[アパチャー値] (Aperture Value)を50 mmに変更します。

System_explorer_3

これらの変更を行わずにシステムを変換すると、2つの問題が発生します。まず、[デザインの固定] (Design Lockdown)を実行すると、入射光線の位置と方向が大幅に変更されます。これは、[デザインの固定] (Design Lockdown)ツールがレイ エイミングを選択し、軸外のチェビシェフ多項式の絞り面を満たすように入射光線を調整するためです。絞り面を軸上の標準面に変更すると、レイ エイミング アルゴリズムは入射光線を変更しません。二つ目の問題は、[クリティカル光線セットの生成] (Critical Rayset Generator)で追跡された光線の一部が、チェビシェフ多項式面の長方形の開口部によって切り取られることです。開口値を50 mmに下げると、すべての光線が光学系全体で追跡され、[クリティカル光線追跡] (Critical Ray Tracer)を実行して、シーケンシャル光線とノンシーケンシャル光線を簡単に比較できます。

次に、チェビシェフ多項式表面を選択します。[面のプロパティ] (Surface Properties)を展開し、[描画] (Draw)に移動します。[ミラー基板] (Mirror Substrate)を[平面] (Flat)に変更し、厚さ5 mmを追加します。Lens_data_6

これで、ファイルをノンシーケンシャル モードに変換する準備ができました。

Shaded_model

[ファイル]から[NSCグループに変換]に移動し、[デザインの固定] (Design Lockdown)と[クリティカル光線セットの生成] (Critical Rayset Generator)を実行します。次に、[OK]をクリックして、ファイルをノンシーケンシャル モードに変換します。ノンシーケンシャル光学系の結果は次の通りです。

NSCE_7

Highlight the objects, right click, and select Ignore and Hide Object.シーケンシャル面の面1と面2がノンシーケンシャル[環] (Annulus)オブジェクトに変換され、ノンノンシーケンシャル コンポーネント エディタの行3と行4に配置されました。これらのオブジェクトは、この例には必要ありません(オブジェクト3は、OAPからの反射後に光線を遮断しています)。オブジェクトを選択し、右クリックから[オブジェクトを非表示にして無視]を選択します。

Ignore_and_Hide_Object

次に、[クリティカル光線追跡] (Critical Ray Tracer)を実行して、変換が正しいことを確認します。

Critical_Ray_Tracer_2

変換が成功したようです。次に、シーケンシャルのOAPがノンシーケンシャル オブジェクトに変換されたかを調べてみましょう。オブジェクト6-10は、ノンシーケンシャルのOAPのパラメータを定義しています。

NSCE_8

シーケンシャルのチェビシェフ多項式面のノンシーケンシャル面は存在しないため、オブジェクト6は[グリッド サグ面] (Grid Sag Surface)に置き換えられました。ミラーの背面は、オブジェクト7で定義された標準面によって定義されています。ミラーの前面と背面は、[複合レンズ] (Compound Lens)オブジェクト8を使用して結合され、偏心アパーチャは、この複合レンズ オブジェクトと矩形体積 オブジェクトのブーリアン演算によって定義されます。 OAPミラーの配置とプロパティは、ブール ネイティブ オブジェクト10によって定義されます。

ほとんどのシーケンシャル面は、同等のノンシーケンシャル 面やオブジェクトに自動的に変換されますが(サポートされているサーフェスの最新リストについては、OpticStudioのヘルプを参照ください)、この例が示すように、全ての面はグリッド サグ面に変換されます。面のサグは自動的にサンプリングされ、{Zemax} \ Objects \ Grid Files内の.GRDファイルに変換されます。レンズの前面と背面を定義するシーケンシャル面、およびこのOAPのように基板の厚さが定義されたミラーの場合、前面と背面の組み合わせにノンシーケンシャル オブジェクトに同等のものがない場合、オブジェクトはノンシーケンシャルの[複合レンズ] (Compound Lens) オブジェクトの参照オブジェクトとして変換されます。例えば、レンズの前面が偶数次非球面であり、背面が拡張多項式面のある場合、レンズもノンシーケンシャルの[複合レンズ] (Compound Lens) オブジェクトに変換されます。前面が偶数次非球面であり、背面が標準面のある場合、レンズはノンシーケンシャルの偶数次非球面 レンズ オブジェクトに変換されます。

この例に示すように、ミラー基板の厚さが0より大きい場合、コンバーターはシーケンシャルの基板の厚さを[複合レンズ] (Compound Lens) オブジェクトの厚さに複製します。この例で定義されているように、ミラー基板の形状が平面である場合、ミラーの背面は平らなな標準面で表されます。ミラー基板に曲率がある場合、[複合レンズ] (Compound Lens) オブジェクトの背面は、前面と同じ面タイプになります。 

レンズの前面と背面を定義する一連の連続する表面の場合、および基板の厚さが定義されたミラーの場合、前面の有効径は背面の有効径も定義します。前面に軸上に円形または矩形のアパチャーが含まれている場合、アパチャー値はノンシーケンシャルの[複合レンズ] (Compound Lens)オブジェクトのパラメータにコピーされます。この例の偏心した矩形の開口部のように、表面に偏心した開口部が含まれている場合、[複合レンズ] (Compound Lens)オブジェクトに加えて、コンバーターは偏心したシリンダ体積 オブジェクトまたはブール ネイティブ オブジェクトを含む矩形体積 オブジェクトを挿入して、指定された有効径にレンズのトリミングを試みます。

 

KA-01380

この記事は役に立ちましたか?
1人中1人がこの記事が役に立ったと言っています

コメント

0件のコメント

サインインしてコメントを残してください。