OpticStudio のシーケンシャル モードについて

この記事では、これから OpticStudio ユーザーになる可能性のある方々および新たに OpticStudio ユーザーになった方々を対象に、このソフトウェアに用意されているシーケンシャル モードの機能を紹介します。ここでは、システムのプロパティ設定、レイアウトの使用、基本的な解析機能、拡張された光源のモデリング、軸外し光学系のモデリングなどのデモが含まれています。

著者 Akash Arora

Introduction

光線追跡は、光学系を通じた光の伝播をモデル化するために幅広く適用できる手法です。この光線追跡を使用した光の伝播のモデル化は、一般的に幾何光学と呼ばれます。

シーケンシャル光線追跡では、追跡の対象となる光線が物体面から像面に到達するまで、事前に定義した面の順序で光線が各面に一度だけ到達するように設定して追跡します。結像光学系は、シーケンシャル面を使用して良好に記述できます。シーケンシャル光線追跡は計算速度に優れ、上記の光学系の設計、最適化、公差解析や解析にできわめて効果的です。

これまでの光学系の多くは結像光学系に分類できます。このような光学系として、写真用の対物レンズ、望遠レンズ、顕微鏡、望遠鏡、リレー レンズ、分光器などがあります。

OpticStudio のグラフィカル ユーザー インターフェイス

OpticStudio を初めて開くとデモ、フルのバージョンに問わず、リボンバー、ツールバー、システム エクスプローラ、ステータス バー、レンズ データ エディタ (LDE) が表示されます 。

 

OpticStudio が提供するすべての機能には、リボン バーのメニュー、各エディタ固有のツールバー、システム エクスプローラからアクセスできます。これらの機能のほとんどには、容易に使用できるように、リボン バーの上のツールバーにショートカットが用意されています。ツールバーに表示される機能を変更するには、リボン オプションの [ファイル] (File) → [プロジェクト環境設定] (Project Preferences) を選択します。

リボン バーの下にはレンズ データ エディタが表示されています。このエディタを表示したウィンドウは、固定表示にも浮動表示にもすることができます。浮動表示にすると、使いやすい場所に移動して、使いやすいサイズに変更できます。固定表示または浮動表示でのデフォルトの動作は、[プロジェクト環境設定] (Project Preferences)、またはリボン オプションの [設定] (Setup) → [ウィンドウ コントロール] (Window Control) グループで設定できます。レンズ データ エディタには、[コメント] (Comments)、[曲率半径] (Radius)、[厚み] (Thickness)、[ガラス] (Glass)、[クリア半径] (Semi-Diameter) (有効口径)、[コーニック定数] (Conic constant) の列があります。[コメント] (Comments) 以外の 5 つのデータを使用して、光学部品が持つ特性のほとんどを定義します。これらの列はデフォルトの順番で並べられています。列見出しをクリックして新しい位置にドラッグすることで、列を容易に並べ替えることができます。

それぞれの行が 1 つの光学面に相当しています。面ごとに専用のローカル座標系があります。光軸上の各面の位置は、その前にある面を基準とします。言い換えると、レンズ データ エディタの [厚み] (Thickness) 列の値は前の面からの距離を指しています。グローバルな基準点からの距離ではありません。デフォルトでは、物体面、絞り面、像面の 3 つの面が表示されます。どの面であるかは、その面の最初の列に表示されます。最初の列には面タイプも表示され、デフォルトは [標準] (Standard) 面です。使用できる面タイプがほかにも数多く用意されています。面によっては、標準面よりも多くのパラメータを定義することが必要なものもあります。そのような面タイプを定義する場合は、定義を必要とする列が追加で表示されます。

レンズ データ エディタをはじめとするすべてのエディタには、Microsoft Excel のスプレッド シートと同様の機能があります。列または行を右クリックすることで、フリーズ、非表示、挿入、または削除の各操作が可能です。複数のセルを選択してコピーする操作や、データをクリップ ボードから貼り付ける操作も用意されています。

 

レイアウト ウィンドウ

[プロジェクト環境設定] (Project Preferences) → [全般] (General) で、[セッション ファイルを使用] (Use Session Files) オプションをチェックしていることを確認します。OpticStudio ファイルを開くときに、[セッション ファイルを使用] (Use Session Files) オプションがチェックされていると、レンズ ファイルを最後に保存したときに開いていた解析ウィンドウが自動的に開きます。セッション ファイルを使用] (Use Session Files) オプションのチェックをはずすと、解析ウィンドウを開かずにレンズ ファイルを迅速に読み込むことができます。また、[計算したデータをセッションに含む] (Include Calculated Data in Session) をチェックしておくと、計算したデータをセッション ファイルに保存できます。

 

リボンの [ファイル] (File) [開く] (Open) を選択します。サンプル ファイルが格納されたディレクトリの一覧画面が表示されます。(Zemax フォルダ)\Sequential\Objectives\Double Gauss 28 degree field.zmx ファイルを選択します。ファイルが読み込まれ、レンズ データ エディタにデータが表示されます。このファイルには 12 個の面が存在し、第 6 面が光学系の絞り面 (STO) です。面ごとに曲率半径、厚み、ガラス、クリア半径が設定されています。これは写真で広く使用される対物レンズです。

[セッション ファイルを使用] (Use Session Files) 設定をチェックしている場合は、このダブル ガウス レンズのファイルを読み込むとレイアウト ウィンドウが開きます。レイアウトを使用すると、読み込んだレンズがどのようなものであるかを確認できます。

レイアウト ウィンドウは、他のウィンドウと同じようにサイズ変更や移動が可能です。レイアウト ウィンドウの設定を変更するには、そのメニュー バーで [設定] (Settings) を選択します。ダイアログ ボックスが展開され、レイアウト図の設定をカスタマイズできます。[光線本数] (Number of Rays) を 7 に変更します。続いて、[矢印の描画] (Fletch Rays) ボックスをチェックします。デフォルトでは設定が自動的に適用されます。つまり、設定を編集した後、別の設定に移動すると、編集済みの設定が直ちに適用されます。現在の解析でこの機能を無効にするには、[自動で適用] (Auto-Apply) のチェックをはずします。[プロジェクト環境設定] (Project Preferences) → [全般] (General) を選択すると、すべての解析で無効にすることができます。この設定を適用すると、レイアウトに描画される視野あたりの光線が 3 本から 7 本になります。光線には、光の伝搬方向を示す矢印も表示されます。デフォルトの設定を変更するこの基本的な手順は、OpticStudio のどのウィンドウでも共通です。

 

レイアウト ウィンドウの内容を詳しく表示できるようにウィンドウのサイズを変更できます。また、マウスのスクロール ホイールを使用するか、マウスの左ボタンを押しながら像の部分の上をドラッグすることで、像の任意の部分を拡大することもできます。プロットを何回かズームすることで、きわめて詳細な表示を得ることができます。表示のズームを解除するには、レイアウト ウィンドウのメニュー バーで [ズームのリセット] (Reset Zoom) を選択します。

リボン バーの [解析] (Analyze) → [システム ビューア] (System Viewers) グループを選択すると、他のタイプのレイアウトを開くことができます。選択したレイアウト プロットのタイプは、直ちに新しいウィンドウに表示されます。メインのツールバーで、解析プロットを起動するショートカットを定義することもできます。[プロジェクト環境設定] (Project Preferences) → [ショートカット キー] (Shortcut Keys) で、解析を起動するキーボード ショートカットもカスタマイズできます。

ヒント : どの浮動ウィンドウも、ウィンドウの右上隅の [X] をクリックして閉じることができます。固定ウィンドウには、そのタイトルが表示されたタブに同様のボタンがあります。

 

スポット ダイアグラム解析

OpticStudio では、上記以外にも数多くのタイプの解析ウィンドウを生成できます。

[セッション ファイルを使用] (Use Session Files) オプションをチェックしておくと、ダブル ガウス レンズのファイルを開くときにマトリックス スポット ダイアグラムも開きます。このタイプの解析ウィンドウには、視野と波長の組み合わせごとに形成されたスポットが個別に表示されます。

 

このほかにもいくつかの種類のスポット ダイアグラムが用意されています。標準スポット ダイアグラムを開くには、リボン バーの [解析] (Analyze) → [光線とスポット] (Rays & Spots) → [標準スポット ダイアグラム] (Standard Spot Diagram) を選択します。読み込んだレンズのスポット ダイアグラムが表示されます。

 

次に、スポット ダイアグラム ウィンドウのメニュー バーで [設定] (Settings) を選択します。この設定ダイアログ ボックスには [パターン] (Pattern) オプションがあり、[六極] (Hexapolar) に設定されています。この設定では、物体面から入射瞳に光線を発する際に使用する光線の分布を指定します。[六極] (Hexapolar) は、瞳の中で光線がデフォルトで示すパターンです。ドロップダウン ボックスをクリックして、今度は [ディザー] (Dithered) を選択します。続いて [OK] (OK) をクリックします。六極パターンではなく、擬似ランダム光線群によってスポット ダイアグラムが再描画されます。

 

 

ヒント : ウィンドウを右クリックして [設定を開く] (Open Settings) を選択すると、そのウィンドウの [設定] (Settings) ダイアログ ボックスが開きます。
 

横収差図と光路差 (OPD) 図解析

OpticStudio で光学系の幾何光学収差を評価する方法として、横収差図と光路差 (OPD) 図による解析機能の使用があります。これらの図を使用するには、リボンバーの [解析] (Analyze) → [収差] (Aberrations) を選択します。
次に、メニュー オプションを使用して [光線収差] (Ray Aberration) プロットを開きます。このウィンドウには、視野点および波長ごとにタンジェンシャル ファンとサジタル ファンの光線収差がプロットされます。

 

光線収差のほか、波面収差をプロットした収差図も生成できます。この解析タイプは光路差 (OPD) 図と呼ばれています。リボンのオプション [解析] (Analyze) → [収差] (Aberrations) →[光路差図] (Optical Path) を選択すると光路差図が開きます。視野点ごとおよび波長ごとの波面収差がプロットされます。

 

ヒント : 解析プロットの多くでアクティブ カーソル機能を使用できます。この機能では、ウィンドウの左上隅にマウス カーソル位置の座標が表示され、カーソルの移動にともなって変化します。光路差図や横収差図のウィンドウで、この機能を試すことができます。

 

MTF 解析

OpticStudio では、総合的な回折解析も可能です。

リボン バーで [ファイル] (File) → [開く] (Open) を選択して、(Zemax フォルダ)\Sequential\Objectives\Cooke 40 degree field.zmx ファイルを開きます。このファイルには、3 枚のレンズで構成した簡単な対物レンズのデータが記述されています。

ヒント : ツールバーの [開く] (Open) アイコンを使用してファイルを開くこともできます。

 

このレンズの MTF を確認するには、リボン バーで [解析] (Analyze) → [MTF] (MTF) → [FFT MTF] (FFT MTF) を選択します。高速フーリエ変換 (FFT) 手法を使用して、空間周波数に対する視野点ごとのタンゲンシャル応答とサジタル応答がプロットされます。ホイヘンス積分の計算に基づく MTF 計算も使用できます。

 

この設計の回折限界を MTF に表示するには、[FFT MTF] (FFT MTF) ウィンドウのメニュー バーで [設定] (Settings) をクリックし、[回折限界を表示] (Show Diffraction Limit) ボックスをチェックして [OK] (OK) をクリックします。回折限界がプロットに追加されます。

 

 

拡張光源解析

OpticStudio では、ほとんどの解析で一群の視野点を使用して物体をサンプリングしますが、拡張された物体光源による像をシミュレートする解析機能もいくつかサポートしています。幾何光学的光源、回折光源、部分的コヒーレント光源、実測光源のバリアントをすべて使用できます。ここでは一部のごく基本的な解析を取り上げ、同時に高度な解析を扱っている参照資料へのリンクも示します。

OpticStudio では、幾何光学的像解析機能を使用して、拡張した光源をモデル化できます。この機能を使用すると、物体面上の任意の視野点を中心とする平面の拡張光源について、有効な解像度の解析、ディストーションの表示、幾何光学的な効率の計算が可能です。

クック トリプレットの設計を使用して OpticStudio の像解析機能を調査できます。リボン バーの [ファイル] (File) で [開く] (Open) アイコンの下の矢印をクリックすると、最近開いたファイルのリストが表示されます。以前に扱ったクック トリプレットのファイルを開きます。[幾何光学的像解析] (Geometric Image Analysis) ウィンドウを開くには、リボン バーで [解析] (Analyze) → [拡張光源解析] (Extended Scene Analysis) → [幾何光学的像解析] (Geometric Image Analysis) を選択します。文字「F」のプロット (デフォルトの拡張光源) がスポット ダイアグラムとして表示されます。

 

文字「F」の代わりにグリッドの画像を表示するには、[幾何光学的像解析] (Geometric Image Analysis) ウィンドウのメニュー バーで [設定] (Settings) をクリックします。[ファイル] (File) の設定を GRID.IMA に変更します。拡張光源を生成するために使用する IMA フォーマットの詳細がヘルプ システムに記述されています。[表示方法] (Show) の設定を [疑似カラー] (False Color) に変更することもできます。この設定では、ディテクタ上に形成される拡張光源の像の表示が、有限個数のピクセルを使用してシミュレートされます。[OK] (OK) をクリックすると、これらの新しい設定で解析が再生成されます。

 

 

OpticStudio には幾何光学的ビットマップ像解析機能も用意されています。この機能は幾何光学的像解析機能に似ていますが、物体光源として BMP ファイル、JPG ファイル、または PNG ファイルを使用できる点が異なります。赤、緑、青の各波長が像面などの面上にあるディテクタのピクセルまで追跡され、RGB 画像が作成されます。他のスペクトル領域での解析では、任意の 3 つの波長を追跡できます。この機能は、写真のように現実的な画像の解析や、サポート対象のフォーマットで作成して保存したカスタム ターゲットの解析に使用できます。画像を適切にサンプリングするには、大量の本数の光線を追跡する必要があることが普通です。

[幾何光学的ビットマップ像解析] (Geometric Bitmap Image Analysis) ウィンドウを開き、次のように設定を変更します。[入力] (Input) を ALEX200.BMP に設定します。[X ピクセル] (X-Pixels) と [Y ピクセル] (Y-Pixels) を両方とも 100 に設定することで、像面のピクセル数を多くします。[X ピクセル サイズ] (X Pixel Size) と [Y ピクセル サイズ] (Y Pixel Size) を両方とも 0.5 に設定することで、各ピクセルのサイズを小さくします。最後に、[光線/ピクセル] (Rays / pixel) を 100 に設定し、追跡する光線を多くして [OK] (OK) をクリックします。

 

 

幾何光学的像解析も幾何光学的ビットマップ像解析も、光線ベースの解析です。画像シミュレーションでは、さらに包括的な機能がサポートされています。ここでは、PSF コンボリューション手法に基づいて幾何光学的計算または回折計算を実行できます。部分的コヒーレント像解析では、部分的コヒーレントな物体光源をシミュレートできます。この 2 つの機能については、以下の記事で詳しく説明しています。

軸外し光学系

OpticStudio では、折り返しミラー、ティルトしたコンポーネント、軸外しコーニック反射鏡などを使用した軸外し光学系もモデル化できます。

(Zemaxフォルダ)\Sequential\Tilted systems & prisms\Tilted mirror.zmx ファイルを開きます。このファイルは、OpticStudio で折り返しミラーをモデル化する方法を紹介しています。このファイルで開く 3D レイアウトで確認できるように、ティルトしたミラー面 (第 3 面) で折り返しのビーム光路を作成しています。

 

この光学系のミラーには、「座標ブレーク」面タイプを使用してティルトを適用しています。レンズ データ エディタで、第 2 面に相当する行をクリックします。続いて、キーボードの右矢印キーを使用して右方向にスクロールし、コーニック定数の列を通り過ぎた位置まで移動します。ディセンタやティルトを指定した列が表示されます。[座標ブレーク] (Coordinate Break) の [X 軸のティルト] (Tilt About X) パラメータが 10 に設定されていることがわかります。これは、ミラーが X 軸を中心に 10 度回転していることを示しています。

 

次に、(Zemax フォルダ)\Sequential\Telescopes\Unobscured Gregorian.zmx ファイルを開きます。これは 2 つのコーニック ミラーで構成した望遠鏡です。このファイルで開くシェーデッド モデル レイアウトで、座標ブレークを使用して主鏡と副鏡がティルトされていることがわかります。これにより副鏡 (第 5 面) が当初のビーム光路から外れた位置に移動し、光線が遮蔽されなくなります。

 

ヒント : レンズ データ エディタでクリックして選択した面は、すべてのレイアウト ウィンドウで強調表示されます。上図のシェーデッド モデル レイアウトでは、主鏡 (第 4 面) が強調表示されています。
この望遠鏡の主鏡は、軸外しのコーニック断面を持ちます。この面上でディセンタしたアパチャーにより、入射ビームに対するミラーの調整を実現します。この面のアパチャー設定を確認するには、レンズ データ エディタで第 4 面の [標準] (Standard) と表示されたセルをダブルクリックします。第 4 面の [面のプロパティ] (Surface Properties) ダイアログが開きます。このダイアログの [アパチャー] (Aperture) セクションをクリックします。ディセンタした円形アパチャーの設定がわかります。

 

ヒント : フル ライセンス バージョンの OpticStudio を使用している場合は、ナレッジ ベースの記事「シーケンシャル光学部品にティルトとディセンタを適用する方法」で軸外し光学系を詳しく調べることができます。

 

システム アパチャー、視野と波長データ

どの光学系にも、F ナンバー、入射瞳径、NA (開口数)、円錐角などのシステム アパチャーの仕様があります。これらの仕様により、光学系が物空間で収集する軸上ビームの幅を設定します。OpticStudio では、システム エクスプローラの [アパチャー] (Aperture) セクションでこのデータを容易に指定できます。[アパチャー] (Aperture) の左側の矢印をクリックして、その設定のグループを展開します。

 

視野データを使用して、物体面上で光線の出発位置となる点を指定します。このデータには、システム エクスプローラからもアクセスできます。システム エクスプローラで簡易表示ではなく、視野のすべての設定を表示するには、[視野] (Field) 見出しをダブルクリックして [視野データ] (Field Data) ダイアログを開きます。

 

追跡対象とする光線の波長を [波長データ] (Wavelength data) セクションで設定できます。この操作はシステム エクスプローラでも可能です。[波長] (Wavelength) 見出しをダブルクリックすると専用のダイアログが開きます。

 

より使いこなすためには

Sequential フォルダにある他のサンプル ファイルや既存のカスタム ファイルを開いたり、独自のシステムを最初から作成したりして、OpticStudio のシーケンシャル モードについて引き続き検討することをお勧めします。これらのサンプル ファイルを開いた後で、リボン バーに表示されているその他の解析オプションを試してみることもできます。

OpticStudio の各種機能を試す際に、そのヘルプ システムを優れた情報源として使用できます。ヘルプ システムはリボン バーの [ヘルプ] (Help) タブから利用できます。

 

KA-01671

この記事は役に立ちましたか?
2人中2人がこの記事が役に立ったと言っています

コメント

0件のコメント

サインインしてコメントを残してください。