OpticsBuilder文件准备

本文提供了Opticstudio 20.1及更高版本中OpticsBuilder相关工具的概述。OpticsBuilder工具将OpticStudio镜头文件(ZMX文件)转换为OpticsBuilder文件(ZBD文件)格式。这使得光学工程师能够将他们的设计打包成一种统一格式,并很容易地从支持Opticsbuilder的CAD程序(如SOLIDWORKS或Creo)中访问。

作者 Jacob Hart and Alexandra Culler

简介

OpticsBuilder文件准备工具通过将OpticStudio模型转换为OpticsBuilder(ZBD) 文件,使得光学工程师和机械工程师之间的文件传递更加高效。简单的转换过程有三个步骤:用户输入、绘图输入和保存.ZBD文件。

OpticsBuilder文件准备概述

OpticsBuilder文件准备工具位于OpticStudio内的文件...转换 (File...Convert)部分。

提示:如果您没有看到OpticsBuilder文件准备按钮,您需要将软件升级到OpticStudio 20.1或更高版本。

OpticsBuilder文件准备工具内有三个选项卡来对应转换过程的每个步骤。在“用户输入 (User Inputs)”选项卡中,光学工程师可以设置他们的分析偏好,并在比较OpticsBuilder光线追迹结果时为光斑尺寸、光线截取和像面污染定义允许的变化量。允许的变化量范围即序列系统到非顺序系统转换所允许的最大变化量。有关更多信息,请参见“错误 1: 光斑尺寸不匹配”一节。“绘图输入 (Drawing Inputs)”选项卡允许在 OpticsBuilder中自动填充生成镜头绘图所需的信息。最后,“保存 .ZBD 文件 (Save .ZBD File)”选项卡使用已更新的分析设置保存转换后的文件。

OpticsBuilder文件准备工具具有以下功能:

  • 将序列文件转换为非序列文件。为了达成该目的,OpticsBuilder 文件准备工具将执行以下操作:
    • 转换序列表面称为对应的非序列几何物体
    • 检查确保转换后光线位置正确
    • 检查确保转换后光线角度正确
    • 确认光斑尺寸的变化在转换后仍然低于允许值
    • 从序列模式转换失败后,打开并检查非序列文件
  • 验证OpticsBuilder是否支持特定的非序列物体并能够导出该物体
  • 为序列设计生成特定边界光线集合
  • 手动填充双胶合、三胶合和四胶合镜头的绘图数据
  • 添加注释到 ZBD 文件,供其他工程师参考
  • 在光线追迹分析中,选择是否启用散射或光线分裂

要执行上述步骤,OpticsBuilder文件准备工具将复制初始文件。然后,如果文件是序列模式的,则将运行锁定设计(Design Lockdown)工具,生成特定光线集(Critical Rayset),并使用非序列转换工具。这与转换到NSC组工具(Convert to NSC Group) 的使用过程类似。在帮助系统文件“公差选项卡>加工支持组>锁定设计 (The Tolerance Tab > Production Tools Group > Design Lockdown)”、“公差选项卡>加工支持组>特定光线生成器(The Tolerance Tab > Production Tools Group > Critical Rayset Generator)”和“文件选项卡>转换文件组>转换为NS组 (The File Tab > Convert Group > Convert to NSC Group)”中有更多关于这些步骤的信息。

一旦完成,这两个文件将被比较。首先,旋转和偏移矩阵将被拉出并进行比较。然后,光线追迹将在非顺序文件中对每个视场逐次运行,每个视场分配运行10,000条分析光线。最后将探测数据存储起来,并与序列文件提供的几何图像分析工具中的光斑大小数据进行比较。该工具将有以下设置:

该工具将遍历分析每个视场。对于每个视场而言,像素大小将由非序列模型中探测器上的x方向像素数量决定。

最后,特定光线集将被载入到非序列文件中,光线的着陆坐标将从探测器中读取。这些坐标将与原始的序列文件进行比较,任何更改都将与用户在“用户输入”对话框中输入的设置进行比较。

如果文件是非序列的,那么OpticsBuilder文件准备工具将检查不兼容的物体,并运行光线追迹来比较初始文件和复制文件。保存光线轨迹并进行路径分析来定位探测器的位置。

OpticsBuilder文件准备使用步骤

OpticsBuilder文件准备工具可以在序列模式或非序列模式中访问。使用之前,请打开要共享的文件并导航至文件... OpticsBuilder文件准备 (File...Prepare for OpticsBuilder)。您将发现自己位于“用户输入”选项卡。此时,您将需要执行以下操作:

  1. 选择分析偏好选项和允许的变化量。在这里,您可以选择在光线追迹中考虑散射或光线分裂。此外您还可以定义文件格式更改后像平面上允许的改变量。特别是允许的“光斑尺寸”变化将用于定义在文件从序列模式转换为非序列模式时可能发生的光斑尺寸变化量允许范围。
  2. 选择需要打开CAD元件的程序(SOLIDWORKS或Creo)。
  3. 输入特定光线追迹公差信息。对于一个序列系统将产生特定光线集,并将用于分析成像质量和光束遮挡。
  4. 点击准备(Prepare)。此时,该工具将分析文件以确保没有错误或无效的物体类型。

只要ZBD文件创建成功,用户则可以通过单击“下一步 (Next)”转到“绘图输入”选项卡。如果ZBD文件创建不成功,将显示一条错误消息,指示进程失败的原因和用户可能用于修复问题的步骤。导航到“潜在转换错误”,以获得有关您可能收到的错误消息的更多信息。在进行下一步之前,必须解决任何存在的错误提示。

“绘图输入”选项卡是用户为SolidWorks中自动生成镜头制图输入绘图数据的地方。

每个透镜表面组合由屏幕顶部的标签表示。如果一个元件类型被选择为“单透镜 (Singlet)”之外的其他类型,则将在该元件之后创建一个选项卡来指定胶合属性。

对于序列模型,在“绘图输入”选项卡上将自动填充以下信息:

  • 前表面和后表面曲率半径
  • 前表面和后表面的通光孔径
  • 前表面和后表面的波长范围
  • 前表面和后表面的波长公差
  • 透镜材料
  • 折射率
  • 阿贝数
  • 中心厚度
  • 参考波长

这些数据来自镜头数据编辑器和公差数据编辑器。其他数据域数据必须手动输入。

对于非序列模型,在“绘图输入”选项卡上将自动填充以下信息:

  • 透镜材料

填充绘图输入后,用户应该选择“下一步 (Next)”进入“保存 .ZBD 文件 (Save .ZBD File)”选项卡来输入注释。这些注释将附加到生成的文件中,并将被其他工程师查看到。当用户准备创建 ZBD 文件时,他们应该单击“保存 (Save)”。

ZBD文件格式

OpticsBuilder使用的ZBD文件格式旨在携带迭代光学机械封装分析所需的所有必要信息,因此可使得文件在OpticStudio和支持的CAD程序之间轻松地来回交换。此文件类型可以在OpticsBuilder和OpticStudio 20.1或更高版本中打开。ZBD文件中的信息包括以下内容:

  • 序列模型(若存在)
  • 非序列模型
  • OpticStudio 基线光线追迹结果
  • 特定光线集(仅存在于序列模型)
  • 材料属性
  • RMS光斑尺寸、光线遮挡和像面污染的允许变化程度
  • 光学绘图信息
  • 光学公差值

当在OpticStudio中打开ZBD文件时,将显示一个包含非序列模型的ZAR文件。

潜在转换错误

OpticsBuilder文件准备工具将使得光学工程师可以把OpticStudio设计转换为一个CAD友好的ZBD文件。出于这个目的,如果转换没有按照预期执行,它将显示错误提示。这使工程师有机会更新文件并在文件传递之前修复任何问题。存在六个可能显示的错误信息:

  1. 错误:光斑尺寸与指定阈值不匹配
  2. 错误:物体不受CAD平台支持
  3. 错误:特定光线失败。请检查非序列文件
  4. 错误:转换非序列文件失败。请检查非序列文件
  5. 错误运行分析:锁定设计未成功
  6. 错误运行分析:参考物体未设置在物体实体上

错误 1: 光斑尺寸不匹配

作为OpticsBuilder文件准备对话框中“用户输入”选项卡的一部分,可以为光斑尺寸指定一个“允许的变化量”。当系统从序列模式转换为非序列模式时,将分析所有视场的光斑尺寸。如果光斑尺寸的变化大于用户设置的值,则会出现此错误提示。通常,这表示“允许的变化量”值太大,需要更新。通常,在非序列光线追迹和以序列光线追迹之间总是存在一些噪声/误差。预计这两种模式在光斑尺寸上有轻微的不同。

除此之外,还有几个典型的原因会导致光斑尺寸的改变:

  • 转换过程中的锁定设计部分会产生对光束轮廓存在不利影响的孔径
  • 系统没有正确转换,探测器不再位于正确的位置
  • 该系统非常大,并产生一个较大的光斑尺寸。光斑尺寸的变化百分比影响对于1000 um光斑比10 um光斑大得多

以上列表并不全面。如果您已经将光斑尺寸变化量更新到一个合理的级别,那么您可能需要逐个检查转换过程中的每个步骤。首先,在公差内运行公差...锁定设计 (Tolerance...Design Lockdown) 并观察孔径的应用将如何影响光线轨迹。然后,打开非序列模式并检查元件放置或定义中的错误。

该错误提示将仅存在于序列模式中。

错误 2:物体不受CAD平台支持

在某些情况下,无法将非序列物体导出到ZBD文件中。这些物体类型需要先进行转换。

在大多数情况下,当模型中的物体没有等效物理物体时,就会发生这种情况。一个不受支持物体的典型例子为用户自定义物体 (User Defined Object)。当使用用户自定义物体时,OpticStudio 通过外部 DLL 定义物体几何形状。该信息不能被读入外部机械设计程序,因此不能被转换成 ZBD 文件格式。修复此错误的一种方法是将无效物体转换为网格矢高表面 (Grid Sag Surface) 或布尔对象 (Boolean object)。在知识库文章“如何使用布尔物体、原生布尔物体和组合透镜物体”中有更多关于布尔物体类型的信息。

有一些物体存在已知的兼容性问题,如下表列出:

  • CAD 装配文件:Autodesk Inventor
  • CAD 装配文件:Creo
  • CAD 装配文件:SolidWorks
  • CAD 零件:Autodesk Inventor
  • 自由曲面 Z
  • 网格矢高透镜
  • 扫描物体

该错误提示将仅存在于非序列模式中。

错误 3:特定光线失败

OpticsBuilder文件准备工具将在系统中执行光线追迹,以查找特定光线角度和位置的任何偏差。如果偏差大于规定的公差,转换将失败。同样地,如果所应用的光阑切断了一条边缘光线或一条主光线,就不会产生特定光线。观察这些光线如何通过系统被追迹的最佳方法是打开非序列文件,然后查看布局图,看看光线是如何通过系统的。这将提供查看是否有任何光线错过物体或被提前遮挡的情况。

或者,如果您以序列模式启动文件,则可能希望重新打开初始文件并执行锁定设计。你可以通过导航至 公差…锁定设计 (Tolerance…Design Lockdown) 来做到这一点。锁定设计工具将对所有表面应用孔径,并可能遮挡光线。在应用了锁定设计之后,你可以通过导航至 设置...系统检查 (Setup…System Check) 来实现。如果有任何“错误”或“警告”,需要在转换文件将其解决。

该错误提示将仅存在于序列模式中。

错误 4:转换至非序列失败

有时,从序列模式到非序列模式的转换会失败。通常这是由于使用了不支持的表面或孔径类型导致的,尽管有时可能是由系统资源管理器中的设置造成的。如果您收到此错误,熟悉帮助系统文件中“文件选项卡...转换文件组...转换至NSC组...转换序列表面至非序列物体 (The File Tab...Convert Group...Convert to NSC Group...Converting sequential surfaces to non-sequential objects) 部分将很有帮助。

此外,在帮助系统文件中的“文件选项卡...转换文件组...转换至NSC组...例外和限制 (The File Tab...Convert Group...Convert to NSC Group...Exceptions and Restrictions)“部分有转换兼容性的完整列表。仔细阅读这个列表,确保你的系统没有任何不兼容的表面设置。有关非顺序转换过程的更多信息,请参阅知识库文章“将序列表面转换成为非序列物体”。

该错误提示将仅存在于序列模式中。

错误 5: 锁定设计未成功

锁定设计工具将系统的所有理想输入转换为实际的制造输入。作为该功能一部分,半直径将被固定的,且任何模型玻璃类型都将被转换成实际玻璃。锁定设计失败可能有几个原因,因此当给出错误提示时,工具也会尝试告诉您错误来自何处。此外,还列出了一些典型的修复程序。一个错误提示示例如下:

在上面的示例中,错误报告“在材料库中找不到玻璃 *F2*!(Can't find glass *F2* in catalog!)”。这个错误是因为没有材料库被列在 系统选项...材料库...当前玻璃库 (System Explorer...Material Catalogs...Catalogs to Use) 中。如果没有参考材料库,该工具无法将模型玻璃转换成类似的真实材料。

如果您看到此错误,请尝试使用OpticsBuilder文件准备工具提供的潜在修复程序列表进行修复。

该错误提示将仅存在于序列模式中。

注意:在版本 20.1中,“打开非序列文件 (Open Non-Sequential File)”按钮将可能出现此错误。此时代表文件打开不正确,将打开一个错误的文件。

错误 6:参考物体未设置在物体实体上

此错误等同于序列模式下的“无法确定物体坐标!(Cannot determine object coordinates!)”错误。通常,当光线瞄准算法找不到光阑时,就会出现这个错误。这是罕见的,但它可能发生在非常倾斜、偏心或高度畸变的系统中。此错误提示将在转换期间出现,并且很可能是锁定设计步骤中出现问题导致的。如果您在使用OpticsBuilder文件准备工具时收到此错误,请尝试在初始文件中手动应用锁定设计,检查并查看是否出现错误。如果是,您可能需要手动更新系统设置来帮助追迹光线。查阅知识库文章“什么是光瞳漂移?它是如何计算的?”可获取更多详细信息。

在非序列模式下,当光线追迹的路径分析失败时,将出现此错误。从20.1开始,这是一个已知的Bug,其中至少有一条光线从非光源物体开始被错误地列出。由于此故障(最多)影响特定光线追迹中的少数光线,因此可以通过重新运行OpticsBuilder文件准备工具来绕过此错误。之后,将使用一组新的随机光线重新运行光线追迹,并且不会对转换或系统产生负面影响。

该错误提示将存在于序列模式和非序列模式中。

KA-01891

这篇文章有帮助吗?
0 人中有 0 人觉得有帮助

评论

0 条评论

文章评论已关闭。