OpticsBuilder绘图指南(Creo)

本文是OpticsBuilder入门免费教程的一部分。

这篇博文将介绍使用OpticsBuilder在Creo Parametric中创建自定义绘图模板来自动创建镜头图纸的过程。OpticsBuilder可以使用镜头绘图工具自动创建符合ISO 10110的圆形孔径镜头图纸。该工具使用以.ZBD文件格式导入的自定义属性生成具有尺寸和材料数据的镜头图纸。绘图工具将执行处理数字格式、图片和表格放置、镜头尺寸标注和镜头数据自动填充的宏。

作者 Jacob Hart

简介

使用OpticsBuilder创建的Creo Parametric装配文件包含机械和光学元件。OpticsBuilder可以使用生成镜头图纸工具创建圆形孔径透镜的图纸。图纸模板是在绘图中组织和呈现镜片几何形状和属性的框架。本文是一个分步指南,用于了解自定义图纸模板中包含哪些信息以及如何创建自定义图纸模板以与OpticsBuilder一起使用。

使用OpticsBuilder绘图工具

按以下步骤使用绘图工具:

  1. 输入一个.ZBD文件到OpticsBuilder中。
  2. 点击生成镜头图纸
  3. 生成镜头图纸对话框中选择要为其生成图纸的光学元件
  4. 选择一个图纸模板(OpticsBuilder或自定义)
  5. 点击 OK 来开始绘图

Figure 1

OpticsBuilder绘图模板

绘图工具启动后,将创建镜头前视图和横截面视图。图中增加了镜片厚度和面直径的尺寸。如果用户在绘图工具中选择OpticsBuilder模板,图纸将如下所示。

当使用OpticsBuilder绘图模板时,如果数据已经保存至ZBD文件内,以下数据将自动填充至绘图表格内:

  • 包含正负号的透镜曲率半径,指示凸面或凹面 (R)
  • 通光孔径半径 (Øe)
  • 透镜材料 (Glass:)
  • d 光折射率 (Nd)
  • d 光阿贝数 (Vd)
  • 光焦度不规则度 (3/)
  • 倾斜 (4/)
  • 表面不完美度公差 (5/)
  • 参考波长 (6/)
  • 材料不完美度 – 应力双折射 (0/)
  • 材料不完美度 – 气泡和夹杂物 (1/)
  • 材料不完美度 – 不均匀性和纹理 (2/)
  • 镜头名称 (Part/DRAWING)
  • 绘图表格缩放 (SCALE)

双胶合镜头和偶次非球面镜头

双胶合镜头装配体将自动为每个透镜和胶合后镜头组生成绘图。非球面透镜(仅限于偶次非球面)将存在额外的绘图工作表中生成非球面系数和矢高表格。

创建自定义绘图模板

自定义图纸模板允许用户定义自己的图纸模板以满足他们的需求。用户可以创建表格、注释、图片,并添加与镜片几何形状和材料属性相关的参数。如果自定义模板的绘图尺寸或方向与OpticsBuilder模板不同,则必须创建新的绘图格式。

创建自定义绘图模板的第一步是在Creo中创建新的绘图格式以选择图纸尺寸和方向。Creo绘图格式包含表格、注释和图形的框架,它们将成为Creo图纸模板的永久部分。

确定绘图格式后,单击确定以选择图纸尺寸和方向。

单击确定以创建绘图模版。创建带有边框线的空白图纸以启动格式。

绘图边框创建

图纸边框用作创建几何图形的参考。要创建边框,请使用草图选项卡下的Offset Edge工具,步骤如下:

  1. 打开你的空图纸模版
  2. 选择草图选项卡
  3. 选择Offset Edge工具
  4. 选择边界边缘以将其偏移指定距离。要反转偏移方向,请使用负偏移数。
  5. 使用Corner工具并按住Control在它们的交叉点处选择和修剪边界线

创建表格

创建图纸边框后,您应该开始创图纸表格。可以使用草图选项卡下的表格工具创建表格,也可以通过绘制草图线来创建表格单元格。本教程使用草图线创建表格。这在选择样式和格式以应用于表格中的各个行时提供了更大的灵活性。

要开始绘制表格,您应该首先选择草图选项卡。在草图选项卡中,线条工具可用于构建表格。可以通过单击草图选项卡中的线型来修改线的外观。使用线条工具创建的线条可以绘制在图纸上的任何位置。创建草图实体时,系统将提示您捕捉参考。当光标在附近时,选择作为捕捉参考的任何对象都将自动捕捉。捕捉参考与图纸模版中的其他线之间的交点也会自动捕捉。

通过在垂直和水平方向上与父线的不同距离创建新线,Offset Edge工具也可用于创建表格。

表格创建完成后,静态纯文本注释可以永久作为图纸表格的一部分添加到图纸格式中。为此,请转到Annotate...Note 并将注释放置在表格中的适当位置。完成表格线和文本注释后,您就可以保存图纸格式并开始生成图纸模板了。在继续下一步之前,使用文件…保存将图纸格式保存为.frm文件。

  1. 关闭图纸格式
  2. 创建一个新的图纸
  3. 选择 Empty with Format 选项
  4. 使用新建加载作为图纸模版一部分创建的新绘图格式
  5. 点击确定创建新的图纸
  6. 选择工具选项卡

选择模板图标从绘图模式切换到模板模式

图纸注释和自定义参数

添加注释是创建工程图模板的下一步。注释可能包含文本、镜头数据参数或文本和数据的组合。在OpticStudio中创建.ZBD文件后,自定义参数将附加到每个镜头。

要在.ZBD文件创建期间查看与光学对象关联的自定义参数,请转到工具...参数

从头开始创建自定义图纸模板时,没有定义自定义参数。但是,可以通过创建包含参数名称且前面带有 & 的注释来调用自定义参数以填充图纸中的表格。生成图纸时,如果参数存在,则将填充调用自定义参数的任何注释。

通过添加参数、文本和另一个参数名称,可以将文本和自定义参数组合在单个注释中。两个参数名称都必须以 & 开头。这对于创建包含公差数据的字段很有用。

自定义图纸模板现在应该可以添加自定义制造参数数据了。为了帮助创建图纸,Creo的OpticsBuilder绘图模板中使用的自定义参数名称如下所示。

非球面

非球面镜头是绘图工具中的一种特殊的情况,仅支持偶次非球面。当绘制一个均匀的非球面时,OpticsBuilder模板在第一张图的顶部包含了一个矢高方程,另外两张图包含非球面系数和一个矢高表格。

要在自定义图纸模板中为非球面创建额外的图纸,您应该:

  1. 打开您的模版
  2. Layout选项卡中使用New Sheet创建两张额外的工作表
  3. Table选项卡中使用Table创建一个新的表格
  4. Layout选项卡中使用New Sheet再创建一张额外的工作表
  5. Table选项卡中使用Table创建两个新的表格
  6. 右键单击屏幕底部的每个新工作表标签
  7. 选择设置
  8. 将图纸格式更改为正确的图纸尺寸并选择确定以制作空白图纸
  9. &开头的非球面系数和矢高值参数填充三个新表
  10. 保存您的模版

保存绘图模板

使用表格、注释和自定义参数创建图纸模板后,用户应使用文件…另存为…Save a Copy将其模板保存为.drw文件。图纸格式包含创建的图纸方向、大小、边框、表格和静态注释。工程图模板包含所有使用的动态注释、模型视图、参数和尺寸。工程图模板在保存时会参考图纸格式。

 

KA-01959

这篇文章有帮助吗?
1 人中有 1 人觉得有帮助

评论

0 条评论

文章评论已关闭。