探索OpticStudio中的序列模式

这篇文章旨在向新用户介绍序列模式的功能。文中介绍了如何设置系统属性,使用布局图 (Layouts)、基本的分析功能和扩展的光源模型,以及对离轴系统进行建模。

作者 Akash Arora

简介

光线追迹广泛应用于模拟光在光学系统中的传播过程。使用光线追迹的方式对光的传播进行模拟的方法通常称为几何光学。

在序列模式的光线追迹过程中,光线会按预先定义的一系列表面的顺序进行追迹,从物面穿过整个系统传播到像面上。其中,光线与所定义的每个序列表面只接触一次。使用序列表面能够很好地描述成像系统。并且光线在序列表面中追迹的计算速度非常快,因此在进行光学系统的设计、优化和公差分析时非常有用。通过光线追迹可以快速实现光学成像系统的像差计算,例如光线光扇图 (ray fan) 的绘制、衍射计算以及波前差计算等。

许多传统的光学系统都可以归类为光学成像系统,包括相机物镜、远摄镜头、显微镜、望远镜、中继镜和光谱仪系统等。

OpticStudio中的图形界面

当您首次打开OpticStudio时(无论是试用版还是完整的许可证版),您将看到如图所示的界面,其中包括了分析功能导航栏 (Ribbon)、工具栏 (Toolbar)、系统选项栏 (System Explorer)、状态栏和透镜数据编辑器(Lens Data Editor)。

OpticStudio提供的所有功能都可以在分析功能导航栏、自定义工具栏或者系统选项栏中相应的子菜单里找到。大部分功能都可以通过在分析功能导航栏上方的工具栏中设置快捷键来实现快速访问。您可以在文件 (File) 菜单中的配置选项 (Project Preferences) 里对快捷键进行设置。

在分析功能导航栏下是透镜数据编辑器。编辑器所在窗口可以布局在特定区域或者切换到浮动状态。当窗口是浮动状态时,它能够被鼠标拖动或者缩放。默认的窗口状态可以在配置选项中设置,或者在设置 (setup) 菜单中的窗口 (Window Control) 中进行调整。透镜数据编辑器是一个数据列表,它包括了备注 (Comments)、半径 (Radius)、厚度 (Thickness)、材料 (Glass)、半口径 (Semi-Diameter) 和圆锥系数 (Conic constant) 等数据列,其中后5项参数决定了光学元件的主要特性。这些数据列按默认顺序排列,您可以通过按住列表名称并前后拖动的方式来调整排列的顺序。

表格的每一行都对应一个光学表面,每个表面都有自己的局部坐标系。每个表面在光轴上的位置是参考于前一个表面的。也就是说,透镜数据编辑器中的厚度参数表示当前表面相对于前一个表面的距离,而不是相对于一个全局的参考点的距离。

在默认情况下,编辑器中会包含三个表面:物面 (Object)、光阑面 (Stop) 和像面 (Image)。数据编辑器在第一栏里对这些表面进行了标记,并且这些表面的表面类型默认为标准面 (Standard)。OpticStudio还支持其他多种表面类型。其中一些表面类型会需要用到比标准面更多的定义参数。当使用这类表面类型时,透镜数据编辑器中会出现额外的数据列以供参数定义。

在透镜数据编辑器以及其他所有的编辑器中,它们和Microsoft的Excel电子表格有相似的功能。您可以在行或者列上右键点击来进行冻结、隐藏、插入或删除等操作。可以选取多个单元格里的数据并复制,也可以从剪贴板里复制粘贴数据到表格中。

布局图窗口

首先请确认在配置选项 (Project Preferences) 常规 (General) 选项卡中勾选“使用Session文件 (Use Session Files)”选项。这样当您打开一个已经勾选了该选项的OpticStudio文件后,软件将自动打开文件上次保存时所有已经打开的分析窗口。取消勾选该选项会使OpticStudio打开文件时不打开任何分析窗口,从而加快文件的加载速度。如果勾选“计算数据保存于Session文件 (Include Calculated Data in Session)”则已经计算的分析数据也将会保存到文件中。

当点击文件 (File) 菜单中的打开 (Open) 按钮时,您将会看到包含所有示例文件的目录。打开文件Zemax\Samples\Sequential\Objectives\Double Gauss 28 degree field.zmx。这会使OpticStudio加载该文件并在透镜数据编辑器中输入该文件的数据。在这个示例中,总共包含了12个表面,其中表面6对应系统的光阑面。每个表面都包含半径、厚度、玻璃材料和半口径参数。这该示例文件为一个常用的照相物镜系统。

如果勾选了“使用Session文件 (Use Session Files)”,则加载该示例文件时会打开一个布局图窗口。布局图可以用来直观地查看所载入透镜系统的结构。

布局图窗口和其他窗口一样可以被拖动和缩放。如果需要更改窗口的设置,点击窗口菜单栏中的设置 (Settings)。在弹出的下拉对话框中您可以自行更改布局图的相关设置。OpticStudio默认自动应用设置的更改,也就是当更改设置参数后点击所编辑的参数以外的区域时,更改会自动生效。在当前窗口中,您可以取消勾选“自动应用 (Auto-Apply)选项来取消这一功能,您也可以在配置选项 (Project Preferences) 中的常规 (General) 选项卡的设置中对所有的分析窗口进行统一的设置。在本例中,我们将光线数 (Number of Rays 设为7,并勾选“光线箭头 (Fletch Rays)选项。一旦更改的设置生效,布局图会在每个视场中绘制7条光线而不是原来的3条,同时在光线上会有箭头标记出光线的传播方向。在OpticStudio的其他分析窗口中进行设置更改和本例类似。

为了更清楚的查看布局图中的内容,您可以对窗口进行缩放。您也可以通过转动鼠标滚轮或者点击鼠标左键拖动选取一个方形区域的方式来放大布局图中的一部分。通过对布局图进行多次放大,您可以看到很多系统的设计细节。如果想让布局图恢复到原先的比例大小,您可以点击窗口工具栏中的整屏显示 (Reset Zoom) 按钮。

您可以在分析 (analyze) 菜单栏的视图 (System Viewers) 中打开其他类型的布局图。所选择的布局图会在一个新的窗口中显示。您可以在顶部工具栏中定义各种分析功能的快捷键,您也可以在配置选项 (Project Preferences) 中的快捷键 (Shortcut Keys) 中设置键盘快捷键。

使用技巧:您可以点击窗口右上角的关闭按钮来关闭任意一个浮动的窗口,锁定状态的窗口的关闭按钮位于窗口标题的右侧。

点列图分析

OpticStudio可以生成许多不同类型的分析窗口。

如果您勾选了使用Session文件选项,那么在打开示例文件时同样还会默认打开矩阵点列图 (Matrix Spot Diagram) 分析窗口。在这个窗口中展示了不同的视场和波长组合下像面上的光斑形状。

OpticStudio还支持其他类型的点列图分析。选择分析菜单栏中的光线迹点 (Rays & Spots) 中的标准点列图 (Standard Spot Diagram) 功能。您将看到当前透镜系统的点列图分析结果。

点击点列图分析窗口的设置 (Settings) 选项。可以看到,在设置菜单中包含样式 (Pattern) 选项,该选项默认为六边 (Hexapolar)。它用来定义光线从物面入射到系统入瞳时的光线分布,在默认情况下光线在光瞳中的分布为六边形。点击样式的下拉菜单,选择杂乱 (Dithered) 并点击确定。点列图会重新绘制,现在光线的分布从原先的六边形分布变成伪随机分布。

使用技巧:在分析窗口中单击右键弹出下拉菜单,打开设置对话框 (Settings) 同样可以对该窗口进行设置。

光线和OPD光扇图分析

在OpticStudio中,可以通过分析光线像差和光程差的方法来衡量一个光学系统的几何像差。您可以在分析 (Analyze) 菜单中的像差分析 (Aberrations)中找到这些功能。

打开光线像差图 (Ray Aberration),分析窗口中显示了每个视场和波长下子午方向和弧矢方向的光扇图。

除了光线像差,OpticStudio也能生成波前像差光扇图。这类分析图表也称为OPD光扇图(光程差,Optical Path Difference)。在分析菜单中的像差分析下拉菜单中选择光程差图 (Optical Path)。OpticStudio将对每个视场和波长绘制相应的波前像差光扇图。

使用技巧:许多分析图表都支持窗口光标 (Active Cursor) 功能,当您的鼠标光标移动到图表上方时,该功能可以显示光标所在位置的坐标信息。您可以在刚打开的光线光扇图OPD光扇图中尝试这一功能。

MTF分析

OpticStudio同样支持对系统进行衍射分析。

点击文件 (File) 菜单中的打开 (open) 按钮,打开Zemax\Samples\Sequential\Objectives\Cooke 40 degree field.zmx,该示例文件为一个简单的名为库克三片镜的三透镜物镜系统。

使用技巧:您也可以通过点击顶部工具栏中的打开按钮来选择要打开文件。

点击分析 (Analyze) 菜单中MTF曲线 (MTF) 中的FFT MTF来查看这个镜头的MTF(调制传递函数)分析结果。OpticStudio会以空间频率为自变量,使用快速傅里叶变换 (Fast Fouier Transform, FFT) 的方法计算每个视场下子午方向和弧矢方向的响应,并以图表的形式展示出来。OpticStudio还支持基于惠更斯积分 (Huygens Integral) 的MTF算法。

如果您想查看这个镜头设计的MTF衍射极限,您可以在FFT MTF窗口中打开设置 (setting) 菜单,勾选“显示衍射极限 (Show Diffraction Limit)”选项并点击确定OK。衍射极限将添加到图表中。

拓展图像分析

虽然大部分分析功能是通过设置一系列视场点来对物面进行采样的,但OpticStudio也支持使用扩展图像作为物面,对其成像结果进行模拟分析。OpticStudio支持几何图像、衍射图像、部分相干图像或使用测量所得的光源数据进行模拟。我们将展示一些基础的分析功能,同时也会提供进阶功能的相关材料。

在OpticStudio中几何图像分析 (Geometric Image Analysis) 功能可以用来创建扩展图像。这一功能可用于分析物面上以任意视场点为中心的平面扩展光源,并计算成像的有效分辨率、畸变和系统效率等参数。

您可以使用库克三片镜系统来测试OpticStudio中的图像分析功能。点击文件菜单栏中打开按钮下方的下拉箭头,OpticStudio会显示最近打开过的文件。在下拉列表中,选择之前打开过的库克三片镜文件。几何图像分析 (Geometric Image Analysis) 功能位于分析 (Analyze) 菜单栏中扩展图像分析 (Extended Scene Analysis) 中。打开后您将看到字母“F”的图案(默认的扩展图像)会以点列图的形式展现在窗口里。

如想使用网格图案代替字母“F”,您可以选择几何图像分析窗口的设置菜单,选择其中文件 (File) 菜单里的GRID.IMA文件。有关使用IMA格式文件生成扩展图像的详细信息可以在帮助系统中搜索查看。您可以在设置菜单中把显示 (Show) 选项修改成伪彩色 (False Color)。这会模拟使用有限像素数量的探测器对扩展图像所成的像。点击确认,重新生成分析结果。

OpticStudio还支持几何位图图像分析 (Geometric Bitmap Image Analysis) 功能,它和几何图像分析类似,但可以扩展使用BMP、JPG或者PNG格式的图片文件作为物面图像。OpticStudio会追迹红、绿、蓝三种波长的光线到像面或者其他指定表面上的探测像素上,从而生成RGB三色图像。OpticStudio也可以追迹光谱中其它三种波长的光线。这一功能可以用来分析实际图像或者使用所支持的格式保存的自定义图像。通常情况下为了保证图像的采样率足够,OpticStudio需要追迹数量非常多的光线。

打开几何位图图像分析窗口,并如下图所示对设置进行修改:将输入 (Input) 改为ALEX200.BMP,将像面上的X像素 (X Pixels) Y像素 (Y Pixels) 改为100,将X像素大小 (X Pixel Size) Y像素大小 (X Pixel Size) 改为0.5,然后增加追迹的光线数目,把光线/像素 (Rays/Pixel) 改为100,最后点击确定

几何图像分析几何位图图像分析都是基于几何光线的进行分析的。图像模拟 (Image Simulation) 功能可以实现更全面的分析。它可以基于点扩散函数 (Point Spread Function, PSF) 卷积的方法进行几何计算或者衍射计算。部分相干图像分析 (Partially Coherent Image Analysis) 功能可以模拟部分相干的物面图像。您可以阅读以下文章了解更多信息。

离轴系统

OpticStudio也可以对离轴光学系统进行建模,例如包含反射镜、倾斜的元件或者离轴的圆锥曲面镜的光学系统。

打开文件\Zemax\Samples\Sequential\Tilted systems & prisms\Tilted mirror.zmx,该文件展示了在OpticStudio中构建反射镜系统。如文件中的3D布局图所示,镜面(表面3)是倾斜的,并且光路由于反射镜的存在而产生折叠。

该系统中的反射镜使用坐标间断 (Coordinate Break) 表面类型来实现的。在透镜数据编辑器中,点击表面2数据行的任意列,用键盘上的右方向键往右滚动表格,使数据编辑器显示圆锥系数 (Conic) 数据列之后的数据。您将看到定义元件偏心和倾斜的数据表格。可以看到表格中倾斜X (Tilt X) 中的参数是10,这表明反射镜绕X轴旋转了10°。

现在打开文件\Zemax\Samples\Sequential\Telescopes\Unobscured Gregorian.zmx,这是一个由两个圆锥反射镜构成的望远镜系统。从文件默认打开的实体模型 (Shaded Model) 图可以看到,主反射镜和次反射镜使用坐标间断面进行了倾斜,这使得次反射镜(表面5)不在系统输入光的光路上,从而避免了遮光问题。

使用技巧:在透镜数据编辑器中选中一个表面时(点击该表面),该表面会在任何视图窗口中高亮显示。在上述的实体模型视图中,主反射镜(表面4)为高亮显示。

该望远镜系统的主反射镜是一个离轴的圆锥曲面镜的一部分,该表面上的偏心孔径使反射镜面与入射光束对准。如果需要查看该表面的孔径设置,您需要选中表面4,然后单击透镜数据编辑器左上角的表面属性 (Surface Properties),或者直接通过双击表面4在表面类型列的对应单元格打开表面4的表面属性对话框。点击左侧的孔径 (Aperture) 选项卡,查看该孔径的偏心设置。

使用技巧:在这篇文章中,您可以进一步探索有关离轴光学系统的更多内容, ”如何让光学元件绕空间任意一点倾斜”。

系统孔径,视场和波长数据

每个光学系统都对系统孔径有详细指标,例如F/#(相对孔径)、入瞳直径 (Entrance Pupile Diameter)、数值孔径 (Numerical Aperture) 或者物方锥角 (Cone Angle)。该参数定义了光学系统从物方空间收集到的轴上光束的宽度。在OpticStudio中,该数据可以在系统选项栏中的孔径菜单中进行设置。点击系统孔径左侧的下拉箭头,您可以在展开的菜单中对系统孔径进行设置。

视场数据用来定义物面上发射光线的位置。该数据同样可以在系统选项中设置。如果您想查看有关视场设置的全部信息而不是在系统选项中概览,您可以展开视场设置菜单后点击打开视场编辑器 (Open Field Data Editor), 打开视场数据编辑器对话框。

您可以在波长数据菜单中设置追迹光线的波长。同样,它在系统选项中也有对应的菜单,双击波长的标题可以打开波长数据编辑器 (Wavelength Data) 进行相关设置。

进阶学习与探索

您可以随时打开Sequential文件夹下的其他示例文件、已有的自定义文件或者从头创建您自己的系统,来继续探索OpticStudio序列模式。您可以在打开的示例文件中尝试分析菜单栏中的其他分析功能。

OpticStudio中的帮助系统 (Help Sytem) 是非常好的学习资源,您可以在探索其他分析功能时查看帮助系统以获取更多信息,帮助系统可以在帮助菜单中打开。

 

KA-01671

这篇文章有帮助吗?
2 人中有 2 人觉得有帮助

评论

0 条评论

登录写评论。