使用ZOS-API所需的OpticStudio版本及编程语言

本文介绍了可与ZOS-API进行通信的最常用的 .NET或 .COM语言的相关信息。

作者 Sandrine Auriol

支持ZOS-API 的 OpticStudio的版本

自OpticStudio 15版本起,可使用ZOS-API。越来越多的功能被添加到ZOS-API 当中。

可以连接到ZOS-API 的工具、程序

ZOS-API可以与任何支持 .NET或 .COM的语言一起使用。更多信息,请查阅帮助手册内如下章节:编程选项卡(Programming TAb)...关于ZOS-API(About the ZOS-API)...连接 (Get Connected)...

以下是可以与ZOS-API进行交互的语言列表:

Language

.NET

.COM

Comments

C#

X

 

 

C++

 

X

 

Matlab

X

 

根据我们的经验,任何高于2015版的Matlab版本都可以访问 .NET库。有关更多信息,请参见https://uk.mathworks.com/help/matlab/using-net-libraries-in-matlab.html

Mathematica

X

 

有关更多信息,请参见 https://reference.wolfram.com/language/NETLink/tutorial/Overview.html

Python

X

X

Python有两种选择,但建议直接使用 .NET。

有关更多信息,请参见开始使用Python

Excel VBA

 

X

 

KA-01896

这篇文章有帮助吗?
1 人中有 1 人觉得有帮助

评论

0 条评论

文章评论已关闭。